Skip navigation
Currently Being Moderated

Can't export to RGB pdf - Indesign CS6

Oct 2, 2012 7:25 AM

Tags: #rgb #pdf #export #indesign

Hi there,

 

I'm trying to export a web pdf with RGB color settings but it doesn't work. Everything looks good in the Indesign document and I've switched to RGB transparency blend space. When I export to a interactive pdf it comes out as a CMYK pdf and when I try a print pdf i just get the error: "1 problem (1 failure) was found with a background task: mydocument.pdf"

 

What could be wrong??

 
Replies
  • Currently Being Moderated
    Oct 2, 2012 7:32 AM   in reply to ramoand

    The RGB Colour Setting is only for how Transparency interacts - it's not a RGB setting for the entire document.

     

    To make the PDF into RGB you need to go to the File>Export and choose PDF (INteractive) and that should make it RGB, but this has Spreads turned on by default in CS5.5 and prior, I think this was fixed in CS6.

     

    If you are exporting from CS5.5 or below then choose PDF (Print) and choose the smallest file size option, and that is automatically set to convert to RGB - you can check that out in the Output area of the PDF Export Dialog Box.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 2, 2012 8:18 AM   in reply to ramoand

    How are you checking that it's coming out as CMYK?

     
    |
    Mark as:
  • Rob Day
    3,118 posts
    Oct 16, 2007
    Currently Being Moderated
    Oct 3, 2012 6:11 AM   in reply to ramoand

    Is the logo a spot color? If you have to export to interactive try converting the spot color to process. If you don't need interactive try exporting as PDF/X-4.

     
    |
    Mark as:
  • Rob Day
    3,118 posts
    Oct 16, 2007
    Currently Being Moderated
    Oct 3, 2012 7:37 AM   in reply to ramoand

    The logo has a green gradient so I guess that means it's not a spot color logo?

     

    A gradient can be made with a spot color. Spot colors have a spot color icon in the Swatches panel. You should be able to double-click the swatch and change it to process:

     

    Screen shot 2012-10-03 at 10.31.33 AM.png

    I want this pdf to be suited for the web so then I should use the INteractive export, right?

     

    Are there interactive elements like buttons? If not PDF/X-4 should keep color unchanged.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 3, 2012 10:17 AM   in reply to ramoand

    Since you mention RGB, PDF and InDesign CS6, just thought I should mention that if you ever need to convert PDF to InDesign CS6, Markzware PDF2DTP can do that.

     
    |
    Mark as:
  • Rob Day
    3,118 posts
    Oct 16, 2007
    Currently Being Moderated
    Oct 5, 2012 5:37 AM   in reply to ramoand

    Is it impossible to export with RGB colors???

    No.  It sounds like you might have an RGB profile conflict—it could be something like a conversion from AdobeRGB to sRGB that shifts the color. Can you post a screen capture that shows the differences?

     

    In Acrobat Pro you can check the color space of page items via Output Preview>Show. If you select CMYK does the logo show?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 9, 2012 10:51 AM   in reply to Rob Day

    To export compliant RGB PDF documents, you need to "Print..." to the Adobe PDF printer profile.  The Export... will not get compliant documents, but going via the print driver will.  I am on Windows, and noticed the color shifts in Reader as well, did some exploring and by using the Print to PDF I get RGB PDF files that do not shift color.

     
    |
    Mark as:
  • Rob Day
    3,118 posts
    Oct 16, 2007
    Currently Being Moderated
    Oct 9, 2012 11:34 AM   in reply to PyrognosisNYC

    Compliant to what—a PDF/X standard? Exported PDF/X-4 documents pass compliance preflight in AcrobatPro without a problem.

     

    Maybe this a Windows thing, but on OSX I don't have any problem exporting RGB colors and getting them to preview the same in the latest versions of Acrobat, Reader, and Preview. Here's an out-of-gamut green exported as PDF/X-4:

     

    Screen shot 2012-10-09 at 2.27.27 PM.png

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 9, 2012 11:40 AM   in reply to Rob Day

    Me either…on Windows. Sounds like something very specific to the user’s system or user error.

     

     

     

    Bob

     
    |
    Mark as:
  • Rob Day
    3,118 posts
    Oct 16, 2007
    Currently Being Moderated
    Oct 9, 2012 2:10 PM   in reply to Bob Levine

    In AcrobatPro the default simulation profile for a PDF/X-4 is the Output Intent profile which has to be a print profile—usually CMYK—so the green can preview as CMYK or RGB depending on the chosen simulation profile.

     

    I think in earlier versions of Reader the display of PDF/X-4 was also through the Output Intent, so it might be the Reader version.

     

    Screen shot 2012-10-09 at 5.03.14 PM.png

     

    Screen shot 2012-10-09 at 5.03.24 PM.png

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2012 2:19 PM   in reply to Rob Day

    I've been having the same issue.  If I print to PDF the issue does not occur, but I needed to Export as a PDF because the interactive doc format maintains hyperlinks.  After much frustration I've found that the issue is linked to having any semi-transparent element on a page. 

     

    Each of the images are different pages from the same document. As you can see if there is a PNG with transparency, or a JPEG with a transparency applied in InDesign, the colors appear as CMYK "For Print" rather than the expected RGB.

     

    Note that this document was setup for web (Document Setup > Intent > Web).

    1.png

    2.png

    3.png

    4.png

    Unless there are some settings that I'm missing this sure seems like a bug Adobe should fix.

     
    |
    Mark as:
  • Rob Day
    3,118 posts
    Oct 16, 2007
    Currently Being Moderated
    Oct 26, 2012 2:46 PM   in reply to nauchilaan

    Where are you viewing the exported PDF? If it's AcrobatPro you might have a CMYK simulation profile set.

     

    I tried exporting an interactive PDF with your colors and transparency, and it previewed correctly in AcrobatPro (sRGB simulation), Reader, and Preview. Here's AcrobatPro with different simulations:

     

    Screen shot 2012-10-26 at 5.35.35 PM.png

     

     

    SWOP:

     

    Screen shot 2012-10-26 at 5.35.59 PM.png

     

     

     

    Reader 9.5, Preview 5.03, Safari:

     

    Screen shot 2012-10-26 at 5.44.13 PM.png

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2012 2:47 PM   in reply to nauchilaan

    nauchilaan wrote:

     

    Unless there are some settings that I'm missing this sure seems like a bug Adobe should fix.

    Well, what settings are you using?

     
    |
    Mark as:
  • Rob Day
    3,118 posts
    Oct 16, 2007
    Currently Being Moderated
    Oct 26, 2012 2:52 PM   in reply to nauchilaan

    Also, make sure your Transparency Blend Space is RGB

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2012 3:11 PM   in reply to Rob Day

    Thank you both for the quick reply.

     

    Rob: I'm using Acrobat X to view.  It seems that if CMYK simulation profile was set then all of the pages would render the same .  The only variable on these images was the transparency but they render differently in the same document.  Your test appears to be using a solid block of color with the transparency set to ~50%. I just check and yes, that form of transparency works fine.  Please try again using a PNG 24 with transparency or by using the Gradient Feather Tool on an imported image.  BTW, the transparency blend space is set to Document RGB.

     

    Peter:  If there are settings that are affecting this outcome that I'm not aware of then I can't really tell you what those settings are. Please let me know which settings I should report back on.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2012 3:18 PM   in reply to nauchilaan

    We need to know waht the transparency blend space is set for in ID and what PDF preset yiou are using (or if not using a preset, what acrobat compatibility is being used, and what settings you are using for color in the Output screen of the export dialog (for a print PDF) or give a screen capture of the interactive export dialog.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2012 3:35 PM   in reply to Peter Spier

    Blend space is RGB:

    5.jpg

     

    I am not using a PDF preset for export.  I'm selecting "Export...", selecting "Adobe PDF (Interactive)" from the "Save as" menu...

    5B.jpg

     

    And then exporting with the default settings in the dialog:

    6.jpg

     
    |
    Mark as:
  • Rob Day
    3,118 posts
    Oct 16, 2007
    Currently Being Moderated
    Oct 26, 2012 4:37 PM   in reply to nauchilaan

    Please try again using a PNG 24 with transparency or by using the Gradient Feather Tool on an imported image.  BTW, the transparency blend space is set to Document RGB.

    The color here is a placed JPEG—set your simulation profile to sRGB

     

    Screen shot 2012-10-26 at 7.30.17 PM.png

     

    It seems that if CMYK simulation profile was set then all of the pages would render the same .

     

    The Transparency Blend Space in Acrobat could be different check the flattener preview:

     

    Screen shot 2012-10-26 at 7.34.31 PM.png

     

     

    What does your PDF look like in Acrobat Reader?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2012 6:59 PM   in reply to Rob Day

    Rob, thank you, this was very helpful.  The document appeared correctly in Acrobat Reader so the issue seemed to be with Acrobat Pro.   The first suggestion didn't seem to help.  Switching the simulation profile momentarily changes the look of the document, but upon closing the Output Preview dialog the colors switch back.

     

    However, the second suggestion worked.  Changing the Transparency Blend Space, applying it to the entire document, and then saving it appears to permanently change the doc - even when closing and re-opening in Acrobat Pro.   It solves the problem, but only for that particular document.  As a test, I exported another version of the same file from InDesign and I ran into the same issue.  Even though the problem appears in Acrobat Pro it still seems like this is a problem with the ouput from InDesign. 

     

    Will I need to change the Transparency Blend Space for every document I output from InDesign inside Acrobat Pro or is there some setting in InDesign that will solve this issue?

     
    |
    Mark as:
  • Rob Day
    3,118 posts
    Oct 16, 2007
    Currently Being Moderated
    Oct 27, 2012 4:28 AM   in reply to nauchilaan

    Will I need to change the Transparency Blend Space for every document I output from InDesign inside Acrobat Pro or is there some setting in InDesign that will solve this issue?

     

    I'm not sure why you are getting a CMYK blend space with an interactive PDF—I always get an sRGB blend space with ID interactive PDFs.

     

    Are you actually making edits in AcrobatX? Why not just preview in Reader or a browser?

     
    |
    Mark as:
  • Rob Day
    3,118 posts
    Oct 16, 2007
    Currently Being Moderated
    Oct 27, 2012 4:41 AM   in reply to nauchilaan

    As a test, I exported another version of the same file from InDesign and I ran into the same issue.  Even though the problem appears in Acrobat Pro it still seems like this is a problem with the ouput from InDesign.

     

    Have you tried a new document where you choose Web as the Intent from the New Document dialog?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 29, 2012 9:41 AM   in reply to Rob Day

    I want it to show up properly in Acrobat X because of others reviewing the document.  At this point I have a work-around so I'm good.  Thank you for all the help.  It is much appreciated.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 29, 2012 9:43 AM   in reply to nauchilaan

    BTW, I did choose Web as the Intent from the New Document dialog for the four test images posted above.  That didn't change the outcome.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 28, 2012 3:58 PM   in reply to ramoand

    I have been trying to export RGB green 255 from InDesign to PDF without much success.

    After reading through this thread, I've decided the work-around of exporting to Interactive PDF,

    then converting the 'Output intent' within Acrobat to Adobe 1998 (or sRGB, take your pick) does the trick for me.

     

    Also, I've converted the RGB green 255 to process, not spot. Not sure if this makes a difference to my work-around.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 11, 2012 2:46 AM   in reply to matt-dd

    This has been frustrating me all day! Working on a client document in InDesign RGB and Acrobat keeps rendering incorrect colour space.

     

    Is there any way to remove this as a default once you export as Interactive PDF? It seems rather painful to have to change the Transparency Blend Space manually for each document.

     
    |
    Mark as:
  • Rob Day
    3,118 posts
    Oct 16, 2007
    Currently Being Moderated
    Dec 11, 2012 4:31 AM   in reply to designraven

    Is you client viewing in AcrobatPro? I think you can expect most of the world will be viewing an interactive PDF in AcrobatReader, Preview, or a Browser plugin where a simulation profile won't be a problem.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 24, 2013 5:10 AM   in reply to ramoand

    Hey dude,

    Try: Edit > Colour Settings : Working Space (and if set to anything other than adobe RGB then change to adobe RGB). that could be the problem.

     
    |
    Mark as:
  • Rob Day
    3,118 posts
    Oct 16, 2007
    Currently Being Moderated
    Sep 24, 2013 6:38 AM   in reply to ben_UFO

    All objects in interactive PDFs get converted to and tagged with sRGB on export. You can see it in Acrobat Pro's Output Preview>Object Inspector:

     

    Screen Shot 2013-09-24 at 9.36.09 AM.png

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 9, 2013 7:15 AM   in reply to Rob Day

    I was also having this issue. I had Edit > Transparency Blend Space set to "RGB" and my placed PSD's were being flattened using what looked like CMYK. I tried a variety of different color settings with no difference. It may have something to do with the file type, because if I used something other than PSD (eg tiff, pdf, etc) I would get other results. Still, this didnt make sense to me and I dont want to have to save a sepereate file type just to place in indesign. It doesnt make sense.

     

    Finally I came up with a little fix: If I take the objects that I want RGB color and set the opacity to 99.99% in the effects pallette, it seems to force the RGB blend space. This worked for me anyway. Not perfect but it did the trick and you cant notice any actual transparency.

     

    Hope that helps anyone else experiencing frustration with this.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 31, 2013 4:11 PM   in reply to ramoand

    I toiled with this for several hours yesterday. Some pages would render in RGB as expected and desired - while others would only display in CMYK. I tried everything that was recommended above. I should also mention that the document looked fine in Apple's Preview - only had the issue in adobe Acrobat Pro (and presumably reader - but I didn't have reader to test it on). 

     

    I couldn't find any logic to deduce why some would and others wouldn't display properly, but I noticed on one of the pages that did work, I had a text box with some text in it, set in the default "black" (C:0 Y:0 M:0 K:100) color from the color pallete, and it was set to 50%. I tried placing this same Text box on a page that was rendering incorectly - re exported the page. It worked.

    So I tried adding that same text box to the master page - it failed.

    I tried again, this time setting the opacity to zero, but leaving the element on the top layer on the page (not on the master). It worked.

     

    TL/DR: Try this - create a type box, use the default black (C:0 Y:0 M:0 K:100) in the colors pallete - set in some text at 0% opacity (I used 10 pt "©mycompany" for example) and place on the top layer of your page. (in this case, it was overtop a placed PSD backgound - in case that matters)

     

    I hope this works for others dealing with this issue.

     

    B.

     
    |
    Mark as:
  • Rob Day
    3,118 posts
    Oct 16, 2007
    Currently Being Moderated
    Nov 1, 2013 6:14 AM   in reply to bhopkin

    only had the issue in adobe Acrobat Pro (and presumably reader - but I didn't have reader to test it on).

     

    Keep in mind that AcrobatPro is a print program and by default will usually show  a print simulation (CMYK) of the page. So when you export an interactive PDF all of the objects get converted to sRGB and AcrobatPro defaults to softproofing the conversion from sRGB to your AcrobatPro CMYK Working space. You have to set the simulation profile in Output Preview to sRGB to see the original ID preview

     

    That will not happen with Reader. Reader doesn't have a print output simulation. Here's the same interactive PDF in Reader and AcrobatProXI:

     

    Screen Shot 2013-11-01 at 9.03.47 AM.png

     

    If I set AcrobatPro's simulation profile to sRGB  and the displays match:

     

     

     

    Screen Shot 2013-11-01 at 9.07.17 AM.png

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (1)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points