Skip navigation
This discussion is locked
Currently Being Moderated

DPS App Builder

Oct 2, 2012 11:24 PM

 
Replies 1 2 Previous Next
  • Currently Being Moderated
    Oct 2, 2012 11:24 PM   in reply to Community Help

    Hi Guru!

    When I try to create an app from the shared cloud folio from Indesign and later downloading from the DPS App Builder I've got an error message: Sign in failed, please try again.

    But the same articles re-created into the local folio and downloading from DPS App Builder signed in successfully, but the app is crashed and closes every time after the starting on the iPad. (680Mb folio)

    Any advise and suggestion how to find the causes this problem?

    Thanks in advance!

    (161 articles (PDF), lots of interactive elements: audio, video, hyperlinks, 3d,... Adobe Cloud CS6 acc, Apple iOS Dev acc, iMac 27, iPad 3)

    Vitaliy.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 3, 2012 1:09 AM   in reply to V i

    Have you checked the name of the articles. Make sure you are not using any sepecial charachters in the names of the articles.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 3, 2012 8:26 AM   in reply to Community Help

    Yes, the name of the artciles are the same - that's why I re-create the local folio with the same copy-pasted names from the cloud folio.

    Only "_" underscore symbol in the names.

    Any checking tools or something for debugging the structure of the folio exist?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 4, 2012 9:46 AM   in reply to Community Help

    Hi!

    Another question: is it possible to convert cloud folio to the local folio (local folio to cloud is no problem)

    ?

    Thanks,

    Vi.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 4, 2012 10:08 AM   in reply to V i

    Right now it is not possible to directly convert a cloud folio to a local folio. As a workaround, you could copy each article (select the article, then "Copy To..." will be a menu item in the upper right menu of the Folio Builder panel). That will take a lot of time since you have 161 articles.

     

    As far as options to check the structure of your folio, you can try to preview the folio on your Desktop or by using Preview on Device with an iPad. Or if you do already have the folio uploaded to the cloud, try publishing it as private.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 4, 2012 10:10 AM   in reply to Stephen Ash

    I got it, thank you...

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 9, 2012 8:57 AM   in reply to Community Help

    Hi,

    I'm having trouble with the App builder. I need to create a iPhone version which is all set up in indesign and i have the folio file ready however i can't seem to find an option for it?

     

    Have i purchased the wrong edition of DPS? I only have the single edition... do i need enterprise or professional?

     

    I was told all i needed was the single edition!

     
    |
    Mark as:
  • Bob Bringhurst
    4,638 posts
    May 29, 2007
    Currently Being Moderated
    Oct 9, 2012 8:59 AM   in reply to anthony_muoio

    Single Edition is iPad only. To create iPhone or Android apps, you need a Pro or Enterprise subscription to DPS.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 9, 2012 6:27 PM   in reply to Community Help

    Hi, how many App Builder accounts should be set up for each DPS account? I wonder if we need more than 1x App Builder account, and if a single App Builder account only has access to create new apps, and access to apps created under the App Builder account.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 9, 2012 7:45 PM   in reply to CuriousA

    Check you certificates and call tech support. Had a similar problem.  Only way to fix it was tech support. In the end my certifiactes while they were green were bad and a bug in the system.  And I had hypens in my story names also. But that wasn't the full issue...just part of it.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 13, 2012 2:39 AM   in reply to Community Help

    I have the Cloud, but I'm getting an error that says I need to purchase Single Edition when I try to publish an app.I've reinstalled latest version of DPS App Builder and trashed the original. I've restarted the computer. I have the latest version of InDesign. any suggestions for next step? thanks!

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 22, 2012 10:47 PM   in reply to mikelly3213614

    I think its a bug. Call Gold technical support if you have the Pro version of DPS. I also got similar errors.  They fixed stuff on that end. Number is located at the bottom of the Adobe Dashboard home page left hand side

     

    You'll propably get an answer quicker and waste less time.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 30, 2012 1:38 PM   in reply to Community Help

    After I upload all my splash screens for SD and HD, I cannot proceed to the next screen. There are green ticks next to HD and SD, and all looks good. I have not uploaded any fonts. Do I have to? There is no HTML in the app.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 5, 2012 10:58 AM   in reply to Community Help

    DPS App builder is very picky! When I add the mobileprovision files, it just put a red line around the fields and doesn't let me go on. The "Step-by-Step Guide to Publishing iPad Apps" states on p.45 "if your mobileprovision files are not accepted, go back to the Apple developer site and re-create them." what I tried a lot with no success. Am I messing something? Please help!

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 8, 2012 12:29 PM   in reply to udini

    I was making my icons in Illustrator and exporting them as PNG. When I went back in and re-exported them, I checked the Export Artboard option, which must ensure that the dimentions of the artboard is conformed to. I think wit out this checked the exported PNG must have been larger that DPS App builder could accept. I also changed the extension to .PNG instead of .png - not sure that this made a difference though, but I was desperate! This fixed my issue and I was able to proceed to the next screen. Hope this helps. If you hover over the feild where the icon has been rejected, a red fly out box appears to explain what's wrong with the icon.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 11, 2012 5:40 PM   in reply to Community Help

    When I update a folio I am being forced to create a new app from scratch. In doing this I end up with two apps with the same name created in different dates. How can I delete the previous app from the DPS App Builder? I first tried to update the folio and then edit the app, but this didn't work. So I created a second app but now I do not have a way of deleting the first one. Should I do the update differently?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2012 10:25 AM   in reply to Community Help

    DPS app builder -- another question.   Finally made sure every article (there are over 100) was relinked to the proper foler -- went thru all the certificates, splash uploads, etc.  Everything looked great until the final screen.   I can see a Developer app (.ipa) listed for download and the zip Distribution file.  However, when I click to download the .ipa, the DPS App Builder says "The folio included in this application is missing. The app was initially created on another machine, the folio file has been moved or the App Builder application storage was deleted."  HELP!!!  What do I do next!!!!  Do I need to create an entirely new folio online?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2012 10:40 AM   in reply to buglegirl101

    This is exactly the same error I got when I tried to simply edit the app I had previously created. Once I made updates to my folio I got this same error. So I went back to InDesign and choose Create App... again. This allowed me to create a second version of the app. Same name, icons, certificates, etc. Once I did this, I was able to download the new .ipa file. But now I have two apps on the App Builder with exactly the same name. I would like to be able to delete the old one to avoid confusion

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2012 11:58 AM   in reply to Community Help

    I am having this problem too. I created an App, tested it about a week ago. Came back to make a small change this week and it told me there was an update for both the Folio panel and DPS App Builder, now when I try to download the Developer app I get the same message "The folio included in this application is missing. The app was initially created on another machine, the folio file has been moved or the App Builder application storage was deleted." Is this because the original app was built using App Builder V2.3 and now it is V2.4?

    I also tried creating the app from scratch, but my serial number (single edition) is being used for the first one and I can't work out how to delete it to release the serial number and reuse for the new App (not yet published to Apple App store)

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2012 1:31 PM   in reply to chendabooks

    I had the same issue last week, but what I did was delete the app from App Builder and I also deleted the actual .folio files and its resources and when back to Folio Builder and created the App again. Went through the App Builder process again and soon after that everything was good to go. A bit of a pain but it worked.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2012 1:34 PM   in reply to Automator21

    Automator21, how did you delete the app on App Builder? I do not see the option anywhere.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2012 1:41 PM   in reply to castorga

    I selected the app so its hi-lighted and clicked on the delete button that is on the bottom right hand corner.

    AppBuilder.png

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2012 2:03 PM   in reply to Automator21

    Wow. I was so fixated on the options on top that I never saw the delete button at the bottom. I wonder why they didnt put the option above together with Manage and Edit.

     

    Thanks!

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2012 3:00 PM   in reply to chendabooks

    chendabooks wrote:

     

    I am having this problem too. I created an App, tested it about a week ago. Came back to make a small change this week and it told me there was an update for both the Folio panel and DPS App Builder, now when I try to download the Developer app I get the same message "The folio included in this application is missing. The app was initially created on another machine, the folio file has been moved or the App Builder application storage was deleted."

     

    This error occurs when the folio is no longer on disk in the same location as when you created the application. Try editing the application in App Builder and look on the App Details screen for the path to the folio. Then double-check and make sure the folio is actually at that location on disk.

     

    Neil

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 13, 2012 9:39 AM   in reply to Neil Enns - Adobe

    Hi Neil thanks for the response. The Folio was not created as a local folio, so unless the folio has moved on the Adobe DPS server I am not sure how this comes about. But I am going to take a look at what you suggest later to see if the App details screen shows the path to the folio.

    cheers

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 13, 2012 2:32 PM   in reply to chendabooks

    Even if you created the folio as an online folio in Folio Builder Panel, when you make a Single Edition application the folio does wind up being stored locally. Let me know what you find when you look at the app configuration. Also, are you on the same machine that you originally used to create the app?

     

    Neil

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 14, 2012 1:37 AM   in reply to Neil Enns - Adobe

    Hi Neil, in App Details the Folio:information just shows the folio name, no path. I don't know where this folio is stored and I am certain that nothing has moved, and yes it is the same computer...

    Cheers

    Phil

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 14, 2012 8:12 AM   in reply to chendabooks

    Ok, that means you built using Create App in the Folio Builder Panel. Let me talk to the engineers and get back to you.

     

    Neil

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 14, 2012 8:51 AM   in reply to buglegirl101

    I went back to my computer-- opened the 1 article  I thought might have had changes that did NOT get uploaded -- and, once I did that, I was able to create the zip file and upload the app.  Boy, once you start putting all the pieces together, you just have to single task-- and really pay attention-- and it works!  THANKS, ADOBE--the step by step guide was SO HELPFUL!

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 14, 2012 2:32 PM   in reply to chendabooks

    Phil, did you by chance rename your folio in Folio Builder Panel while you were working on it, prior to upgrading to release 24?

     

    Neil

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 14, 2012 2:38 PM   in reply to Neil Enns - Adobe

    Hi Neil, no I have not changed anything on the folio. The only thing I changed was to turn off the shine effect in the App Builder.

    Phil

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 15, 2012 8:40 AM   in reply to Neil Enns - Adobe

    Neil, I'm having the same problem. I may have renamed the folio before upgrading to r24. Also, I upgraded some of the articles to CS6 but not all of them.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 28, 2012 7:18 AM   in reply to Community Help

    Trying to export the developer app from the app builder always results in

     

       sign in failed, please try again

     

     

    Multi Folio app

    Builder V 2.4.0  | DPSAppBuilder-2.4.0.34.63865.dmg

    Profiles checked

     

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 11, 2012 7:58 AM   in reply to Bob Bringhurst

    We have a Professional subscription with Adobe DPS but as we log in for the first time to publish and produce an android app we have only one option and that is to produce for IPad. Why is this?

     
    |
    Mark as:
  • Bob Bringhurst
    4,638 posts
    May 29, 2007
    Currently Being Moderated
    Dec 11, 2012 11:27 AM   in reply to tomowens08@gmail.com

    When you sign in to DPS App Builder, you need to use an account that has been assigned the "DPS App Builder" role. You (or your DPS admin) should sign in to the Dashboard using your master account and assign Application and DPS App Builder roles to the appropriate accounts. See the Account Administration tool help article.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 12, 2012 3:00 AM   in reply to Bob Bringhurst

    Hi Bob thanks for getting back,

     

    We want to assign a delegate account that already existing with a folio built to the master account.

     

    We get this error: The email address you entered is already a Digital Publishing user. Please choose a different Adobe ID or create a new Adobe ID for the user.

     

    Is there a way of doing this as other wise it seems we would have to start from scratch with a new account?

     

    I hope my terminology is correct.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 12, 2012 8:38 AM   in reply to Community Help

    Hello guys,


    Sounds interesting, though it irks me that the DPS single edition does IOS

    and not Android???


    GRRRRRRRR!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


    its not like Apple need more quailty apps, Android desperately needs good

    Tablet Apps!


    Why why why???

     
    |
    Mark as:
  • Bob Bringhurst
    4,638 posts
    May 29, 2007
    Currently Being Moderated
    Dec 12, 2012 11:04 AM   in reply to tomowens08@gmail.com

    Tom - If you already verify an Adobe ID to work with DPS, it's difficult to make it a delegate account at this time. With the next release, it should be much easier. Contact a Gold support representative, or see this kb doc: http://helpx.adobe.com/digital-publishing-suite/kb/changing-id-email.h tml

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 13, 2012 6:50 AM   in reply to Bob Bringhurst

    Thanks for getting back.

     

    We have contacted your support about deleting the account. This can then be used to register as a delegate account, no longer being associated with DPS single edition.

    I assume this should work. We have very little content associated with the existing account, so this can be deleted. They said it may take 24-48 hours and a senior member may have to do it. Are you able to do this for us?

     

    Also when using our master account, we have an IPad app which is a separate but related project for separate distribution. We want to use Push notifications but DPS app builder tells us that the development push cert is not valid.

    We have followed all steps to first create an App ID then produce a Push Development SSL cert using a Certificate signing request. We then use Keychain access to export a .p12 APNS development cert. This is stored on the same server as all our certificates.

    We then import to App Builder under Development APNS Certificate and give the password that keychain access prompted us for.

    We get a 'This is not a valid Apple Push Development Certificate' error.

    It's important to note that our Production APNS cert seems to process fine using DPS app builder.

    What am I doing wrong?

     

     

     
    |
    Mark as:
1 2 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points