Skip navigation
Vynx
Currently Being Moderated

Flash CS6 can't compile some working project a few day/week old

Nov 9, 2012 10:16 AM

Tags: #test #flash #swf #won't #can't #exporting #movie #cs6 #build #compile #dissapear

When I tried Monday to reopen one of my project FLA (Succesfully publish on iTunes 2 weeks ago) to add content for a future update, I was unable to build/compile my project on the laptop I code and build it originally. I code under FlashDevelop and put all my assets in Flash CS6 and build from the Flash IDE. I did put an emphasis on "laptop I code originally" because if I take my project on my home desktop or a colleague desktop, no problem, everything is compiling perfectly. A new created FLA project will also work smoothly.

 

In detail, when I try to test my movie the "Exporting SWF Movie" window briefly show up then disappear. No error are given in the output panel or any other alert window. But if I try to compile SWF by going trough debug mode I get "You cannot debug this SWF because it does not contain ActionScript". That error didn't bring me any solution for me when look online. I've try to build for Flash Player 11.4 down to 9 with no change, but sometime get the simulator window if building for AIR iOS but get same result.

 

The only change I notice on my system is that Monday Java made me upgrade to 7. I think I may have been running Java 6.0.36 prior to that update. But I'm not sure Java is at fault since other project run on my machine and my project was tested on a computer running Java 7 and 6. Also, in my attempted to make this work i've uninstall all java from my computer and notice that new project that were working, were still working without java. So is java needed for the compiler? I've also try to add memory to the jvm.ini file since I got an issue with this under CS5.5. No change. Reinstalling Flash CS6 also didn't change anything.

 

Adobe support told me it was a know issue with many other customer but couldn't give me more info or point me to a forum discussion related to my problem. They told me to contact java or look online for more information. (I'm a bit disappointed by that lack of proactivity from support but that is an other topic)

 

So my guess is .. I don't have any guess.

 

Technical detail of my Laptop

Dell Vostro 3700

Intel Core i5 2.40GHz

3 GB RAM

Windows 7 Home Premium 32bit

 

Windows and all my adobe product are up to date

 

My bottom question is does anyone have found a solution for this. Do you have link to share that cover that topic. If its well know as adobe support pretend, is that bug refer to something special other then "Swf can't compile".

 

Any hint or tip are welcome. Thanks.

 
Replies
  • Currently Being Moderated
    Nov 10, 2012 7:12 AM   in reply to Vynx

    Just a shot in the dark--try checking your build paths to swcs and directories of source code. Also, what happens if you move it to another directory on that machine and compile it?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 13, 2012 5:28 PM   in reply to Vynx

    All I know is that sometimes the paths don't work right--especially if you're using a swc and you use the "+" button to add a path to it instead of the button that looks like a swc icon. It stands to reason that if you change the path, you could fix the problem, especially if moving the project meant you had to set that up again.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points