Skip navigation
florosg
Currently Being Moderated

HTTPService is missing from Flash Builder 4.7

Nov 10, 2012 5:01 AM

Hi to all,

My project use HTTPService , but when i moved to Flash Builder 4.7 HTTPService is gone !!!!

I Have the following compiler error  : Type was not found or was not a compile-time constant: HTTPService.

 

 

Please please i need your help since i have a stric project deadline .

 

Ps . i overlay the new Air 3.5 sdk

 
Replies
  • Currently Being Moderated
    Nov 10, 2012 8:58 PM   in reply to florosg

    I would ask on this forum: http://forums.adobe.com/community/labs/flashbuilder4-7

     

    Also add whether this is a new project or a migrated old project, and whether a brand new project has the same issues.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 8, 2013 2:06 AM   in reply to Flex harUI

    Does this issue resolved by anyone (?) I'm having the same issue here, its new actionScript project, AIR SDK 3.4 using, and FB 4.7; though I've succeed adding HTTPService class by adding rpc.swc and framework.swc manually in the project, but Flex compiler starts returning strange errors when I actually added the class (containing HTTPService call) inside the main class (application components) files. Here as they are:

     

    Unable to resolve resource bundle 'collections'

    Unable to resolve resource bundle 'core'

    Unable to resolve resource bundle 'logging'

    Unable to resolve resource bundle 'messaging'

    Unable to resolve resource bundle 'rpc'

    Unable to resolve resource bundle 'styles'

     

    Btw, @harUI, the link that you've given seems dead.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 8, 2013 8:37 AM   in reply to Santanu Karar

    Adding framework.swc to an actionscript project sounds like it could be a problem.  Which version of Flex are you using?

    Flex projects generally have pointers to the locale as part of the default configuration.  You might have to set that up yourself for an AS project.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 10, 2013 9:28 PM   in reply to Flex harUI

    Hello,

     

    I was using Flash Builder 4.7 with SDK 4.6 and AIR SDK 3.4. Later, I've updated to 3.6 AIR.

     

    I make it fix with some search over net, and I think its funny anyway - even don't know what its' long run effect. I've modified the locale argument in compiler as this:

     

    --locale=

     

    It fix the errors!

     

    Though, after some research I decided to drop using HTTPService as a service caller, instead I'm now using URLLoader class which I believe is the core. It just works fine, but there is also a bug. I think you may like to see this:

     

    http://forums.adobe.com/message/5136000

     

    Thank you.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points