Skip navigation
Currently Being Moderated

font change not appearing in Autonumber

Nov 14, 2012 3:43 PM

FM10, Windows 7 64-bit. Inherited documents, template has evolved over maybe 15 years so there's a lot of legacy cruft.

 

I have a Bullet1 paragraph tag. Its Autonumber Format is l\t (that's a lowercase L before the backslash). The Character Format for the autonumber is Bullet. The font for the Bullet character tag was once upon a time Zapf Dingbats but it gets remapped to Adobe Pi Std.

 

On my predecessor's machine, Bullet1 had a round bullet, maybe because he had a different Zapf Dingbats, I don't know (machine has been wiped so I can't check it). On my machine, instead of a bullet there's a question mark.

 

I was unable to get font mapping to work (see "Zapf Dingbats bad font replacement in FM10" thread) so I hacked Adobe Pi Std to add the bullet glyph from Zapf Dingbats BT Regular and map it to l. (For future reference, I had to reboot before the font change was active.)

 

If I type an l and format it with the Bullet character tag, it appears as a bullet, but Bullet1 still has a question mark in place of a bullet.

 

Suggestions?

 
Replies
  • Currently Being Moderated
    Nov 15, 2012 3:50 AM   in reply to rlauriston

    Why isn't the format using a \b ?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 15, 2012 10:43 AM   in reply to rlauriston

    Robert,

     

    As I mentioned in your other thread, you can still use the older Postscript fonts on a Win7 platform, so you could use either the ZaptDingbats or ZapgDingbats BT versions directly without hacking the AdobePiStd.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 15, 2012 2:15 PM   in reply to rlauriston

    All I'm saying is that if you install a PS version of ZapfDingbats, you wouldn't have to change anything in any document. Right now, if somebody else opens a document without your special hacked version of the font, you do have a maintenance issue.

     

    Also, you can comment out the AdobePiStd substitution line in the maker.ini to prevent FM from trying to make any substituions.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 15, 2012 2:40 PM   in reply to rlauriston

    The encodings are different. With either version of Dingbats, you would be using thee original FrameRoman and all of the characters would display as intended.

     

    Something sounds strange on your installation. I'm not seeing any substitutions taking place for ZapfDingbats on any of FM8-11 on XP or Win7 64-bit plaforms  (nor do I even have the substitution line commented out).

     

    Do you have the "Remember Missing Font Names" option set in your Preferences?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 15, 2012 6:39 PM   in reply to rlauriston

    Shouldn't that be "ZapfDingbats"? FM is case-sensitive (unix heritage) for most things.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points