Skip navigation
Currently Being Moderated

0% Hardness Brushes are pixelated/not smooth

Nov 15, 2012 7:01 AM

Tags: #pixelated #brush #smooth #cs6 #extended #hardness

I recently upgraded from CS4 to CS6 and I noticed a weird change in how brushes with 0% hardness are displayed. I'm not sure if it's supposed to look like this or if it's a problem with my settings etc.

 

So here is how it looks on 500%

 

- 0% hardness brush, Opacity 100%, black on transparent background

- Image Mode is RGB / 8bit

 

brush.png

 

I'm pretty sure it's not supposed to look like this and would greatly appreciate any help to fix this.

 
Replies
  • Currently Being Moderated
    Nov 15, 2012 7:09 AM   in reply to chris_ni

    I think it's only a display artifact in the blending of the transparency grid (the checker pattern) with your layer. The brush mark doesn't have that problem when there's an opaque layer underneath the transparent layer. By the way, I recommend you work in 16-bit mode to reduce posterization and banding when multiple semi-transparent layers are stacked, or semi-opaque brushmarks or gradients are overlayed. 16-bit mode reduces posterization and banding in adjustment layers, too. Converting from 16-bit to 8-bit when required will dither by default.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 15, 2012 8:18 AM   in reply to chris_ni

    I think there's a slight misunderstanding. I do recommend 16-bit, and 16-bit indeed does not have that display problem shown above, but your 8-bit work in CS6 is not inferior to 8-bit work in CS4. As I said, the problem you showed is only a display artifact - it isn't a part of your files.

     

    Anyway, since your work involves stacked semi-transparent layers, you should work in 16-bit mode from now on.

     

    Something about 16-bit mode to be aware of is that at zoom levels less than about 65% when Cache Levels (in Preferences > Performance) is greater than 1, the display is calculated with reduced precision, so 16-bit mode might look no better than 8-bit while zoomed out to below about 65%.

     

    Also realize that your OS, graphics driver, graphics card and monitor will be incapable of delivering a 16-bit output from the screen, so don't be surprised to see some banding on the screen regardless of the bit-depth you work in. A 10-bit per channel display pipeline will improve over standard equipment. If you're interested in that, there have been discussions in this forum.

     
    |
    Mark as:
  • Noel Carboni
    23,459 posts
    Dec 23, 2006
    Currently Being Moderated
    Nov 15, 2012 10:06 AM   in reply to chris_ni

    I haven't seen anything I would call "worked just fine in CS4" that doesn't work as well in Photoshop CS6.

     

    If you can specifically show that the exact same operation in Photoshop CS6 is producing worse image quality than when in Photoshop CS4, I imagine Adobe would be quite interested.

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 24, 2012 11:24 AM   in reply to chris_ni

    I've seen similar artefacts using PSCS5 on an iMac. Turned out to be caused by the settings in prefs > performance > Graphics Processor Setting > Advanced.

    Set it in a less advanced mode.

    http://helpx.adobe.com/photoshop/kb/photoshop-cs6-gpu-faq.html#trouble shoot

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 24, 2012 1:20 PM   in reply to Rene-)

    That means that your video card or driver has some problems.

    We have seen quantization problems with some video card drivers (failing to execute the shaders correctly, and losing precision).

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points