Skip navigation
heinrichmoser
Currently Being Moderated

photoshop elements 10 does not recognize my printers anymore, but it already did.

Nov 18, 2012 5:34 AM

()

 
Replies
  • 99jon
    12,821 posts
    Jan 6, 2010
    Currently Being Moderated
    Nov 18, 2012 5:49 AM   in reply to heinrichmoser

     

    Sometimes the printer name causes a conflict for Elements although this factor normally affects HP printers which typically have long names. But it may be worth trying to re-name your printer with a simple name such as Office Printer.

     

    Go to Control Panel >> Printers & Faxes

    Right click the default printer and choose: Printer properties

    Then re-name the printer with a short name and click OK.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 18, 2012 6:22 AM   in reply to 99jon

    Be sure that your printer is the default.

    Go to Control Panel>Devices and Printers. The default should have a green checkmark.

     
    |
    Mark as:
  • 99jon
    12,821 posts
    Jan 6, 2010
    Currently Being Moderated
    Nov 18, 2012 6:44 AM   in reply to heinrichmoser

     

    Try a dedicated printer rather than a network printer.

     
    |
    Mark as:
  • 99jon
    12,821 posts
    Jan 6, 2010
    Currently Being Moderated
    Nov 18, 2012 7:43 AM   in reply to heinrichmoser

    Try temporarily changing the default printer. On Windows go to:

    Control Panel >> Devices and Printers

    You should get a list of your printers and the Microsoft XPS Document Writer. Your own printer will have a checkmark showing it as the default printer. Try switching by making the Microsoft XPS Document Writer the default one. Right-click on its icon and choose "Set as default printer"

    Launch PSE10, open an image file, and click the menu:

    File >> Print

    In the Print dialog you should now see "Microsoft XPS Document Writer" as the default printer. Change that to your preferred printer and the close the dialog. Close PSE10 and re-launch.

    Don’t forget! Go back to Control Panel. Right-click on your printer icon and choose "Set as default printer"

     
    |
    Mark as:
  • 99jon
    12,821 posts
    Jan 6, 2010
    Currently Being Moderated
    Nov 18, 2012 8:22 AM   in reply to heinrichmoser

    Sorry I don't have any more ideas.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 19, 2012 10:10 PM   in reply to heinrichmoser

    You have written above that PSE 10 did recognize your Printers some time back but now it is not. This is a weird behavior and when PSE starts behaving weird the first step to fix it back is delete the preferences of PSE.

    For deleting Preferences please visit this URL http://helpx.adobe.com/photoshop-elements/using/undo-redo-cancel-actio ns.html#restore_default_preferences    

    I would suggest you to delete the preferences and then try.

     

    Cheers !!!

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points