Skip navigation
Currently Being Moderated

E_AUTH_BAD_DEVICE_KEY_OR_PKCS12

Nov 20, 2012 5:37 AM

Tags: #error #authorization #digital_editions #adobe_digital_editions #acsm #e_auth_bad_device_key_or_pkcs12

Hello,

 

I downloaded an e-book from lulu.com yesterday.  It was an .acsm file, which forced me to install Adobe Digital Editions 2.0 in order to view.  I installed it without authorizing and browsed the book for a few minutes then turned off the program.  Later I returned to read it but there was a message about some licence key being broken or something, with E_AUTH_BAD_DEVICE_KEY_OR_PKCS12 in the error message.  I tried to authorize ADE to see if it would help, but it gave me a message saying "Digital Editions encountered an error on the activation server", with the familiar E_AUTH_BAD_DEVICE_KEY_OR_PKCS12 code.

 

I tried removing the book from the library and reimporting it, but now it won't even do that without the same error message.  I've tried deleting the .acsm file and redownloading it, unistalling ADE and reinstalling it, made sure the firewall allows acces to the internet, and keep getting the same message.  I'm running on Vista.  It works with DRM-free .pdf's I have, but I can't download any of the sample books on Adobe's website to test further because the server doesn't respond.

 

Any ideas?

 
Replies
  • Currently Being Moderated
    Nov 20, 2012 4:01 PM   in reply to PolarPaul

    I'm going to take a guess here, based on the process you said you went

    through.  Here's hoping it's helpful.

     

    I suspect that the copy of ADE you downloaded is not going to let you

    register it with Adobe.  This happens sometimes when the various

    ebooksellers try to give you a link to a download address, and the software

    you download isn't 'legit' for one reason or another.  Ebooksellers and

    others who want to put a link out there should be going to Adobe to get the

    right link.  Some don't.

     

    Next up, Digital Editions works only on Windows and Macs.  It does not work

    - or load - on Android devices such as a smartphone.  I've seen a couple of

    postings to the forum that say they have a file on their smartdevice that

    looks like Digital Editions - sometimes complete with the DE logo.  They're

    bogus in the sense that they are not code from Adobe.

     

    My suggestion is go use your computer's utilities to copy the ebook you

    downloaded to a safe place, and then deinstall the copy of Digital Editions

    you loaded.  Then, go to the Adobe website, create an Adobe ID that's

    separate from the one you've used already, and download a fresh copy of the

    software.  BTW: ADE creates a small ID file for each ebook it downloads and

    appends it to the ebook.  To make things easy, make up an Adobe ID instead

    of using your email address.  That way, if you change email addresses,

    you'll still be able to get to your ebooks.

     

    When you deinstall ADE, there may be some scraps hanging around.  Use your

    computer's utilities to delete the Digital Editions folder and all of its

    entries.  Look to see that your registry files have been purged as well: if

    you're a Windows user, you can use the Add/Delete Programs utility in the

    Control Panel to do this.

     

     

    Good luck - and report back

     

    ==========

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 20, 2012 6:12 PM   in reply to PolarPaul

    I noticed that you are running on Windows Vista which ADE 2.0 does NOT officially support. Have you tried any other Windows platform like Windows XP or Windows 7?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 20, 2012 7:56 PM   in reply to PolarPaul

    Now that we have additional information in the conversation....

     

    Yes, the issue could be the Adobe server.  I think the only thing to do now

    is for you to try to open a Chat session with Adobe support, share this

    information (the more complete the better) and see where you go from

    there.  Adobe employees don't frequent this forum often, and when they do,

    they're not able to do anything about issues other than give advice.  You

    may have to be tenacious with the Chat, however: folks have reported that

    the Adobe person may not know anything about ADE or may tell you it's not

    supported via Chat - or at all since it's free.  That's a pile of bovine

    byproducts.

     

    I'm glad also that you are using Bluefire for the Android device.  I'm not

    an expert by any means, but that's the choice I'd make (if I wanted to get

    another pair of glasses so I could read the small screen....). 

     

    ===============

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 21, 2012 4:37 PM   in reply to PolarPaul

    same problem here; i am using multiple libraries and i cannot revert the ADE version on this machine (office workstation)

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 22, 2012 8:23 AM   in reply to web_4.0

    Keep in mind that ADE is a stand-alone program and was never designed to be

    run on a network.  So if you're trying to use the network as a gateway to

    the Internet, you could be experiencing some issues because of some

    incompatibilities or settings in software.

     

    =============

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 25, 2013 2:41 AM   in reply to PolarPaul

    I have now corrected this error!!

    at last....

    I was advised that if you open Adobe Digital Editions and then press “Ctrl + Shift key and the d key” at the same time a pop up box will appear “ Erase computer authorisation” if you click the button on the right “ Erase Authorisation”.

    Then the first time you use Adobe Digital Editions, you will be asked to authorise the software with your ID. Should you not receive this prompt, click ‘Help’ and ‘Authorise this Computer’

    And it worked!!!

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points