Skip navigation
C Kerr
Currently Being Moderated

Broken links in Robohelp 8 - Right click restore action on broken links does not work

Nov 23, 2012 8:54 AM

Tags: #problem #issue #links #broken #robohelp_8 #cpd_file

Hi,

 

The issue began when I checked in my Robohelp 8 project to TFS earlier. I checked in the whole project, which perhaps wasn't wise, as I had only changed two files. For whatever reason this seemed to confuse Robohelp, and it started prompting me to delete files from TFS. I have since removed the project from source control, but the project is corrupted. Following closing and reopening it, a large number of the project folders are missing from the Project Manager, and there are dozens of files in the Broken links list.

 

I tried following the advice on fixing broken links on Peter Grainge's site  (http://www.grainge.org/pages/authoring/opening/opening_projects.htm) but I'm stuck. Robohelp is in such a state that when I right click on a broken link and click Restore, nothing happens (no explorer opens to allow me to locate the files). Additionally, for a large number of the broken links, the 'Restore' option is greyed out in the right click menu. I noticed that all of the broken links in the latter category have '#' in their name.

 

There's some other strange behaviour. Whenever I open a project, the cursor oscillates rapidly from a pointer to a busy icon. I know this is one of the symptoms of the bug that can occur when the 8.01 and 8.02 patches are not installed, but both patches have been installed on my machine.

 

Other info: I have tried deleting the cpd file. All files are present on my C drive, but they are not displaying in Robohelp (as I said). I have a fairly recent zip backup of the project.

 

For the purposes of this question, I am more interested in the broken links issue than the version control problem, but I am also keen to prevent this from happening again.

 

Any suggestions would be greatly appreciated! At the moment all I can think to do is to uninstall and reinstall Robohelp.

 

 

Many thanks,

 

 

Chris

 
Replies
  • Anjaneai Srivastava
    1,028 posts
    Oct 17, 2011
    Currently Being Moderated
    Nov 24, 2012 5:59 AM   in reply to C Kerr

    Hi Chris,

     

    If the file name has # it probably would mean the bookmarks are broken from your project.

     

    Can you try "Check out All", and then try restoring the broken links from -- Tools -- Resolve Broken Links.

     

    Do you have a local copy of the project with you that you can check with?

    Can you try replairing broken links from this article?

     

    http://help.adobe.com/en_US/RoboHelp/8.0/RoboHTML/WSB3209593-870C-43e4 -B241-2F7BA9533F86.html#WS5b3ccc516d4fbf351e63e3d11aff59d0a2-7d01

     

    Thanks,

    Anjaneai

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points