Skip navigation
redeyegraphics61
Currently Being Moderated

PSE 7 stopped launching

Nov 25, 2012 9:47 PM

Tags: #won't_launch #photoshop_elements_7_

I have PSE 7 it has stopped lauching - Why? I've had it for years and no problem with it. I have tried all round about ways to launch it (like rt clicking a jpeg and saying for PSE 7 to edit it) nothing works. I've gone directly to the shortcuts target file and double clicking to no avail.

 
Replies
  • Currently Being Moderated
    Nov 25, 2012 11:10 PM   in reply to redeyegraphics61

    Sometimes the Preference file gets corructed. Try this solution:

     

    1. Close Elements.
    2. Launch the Photoshop Elements Welcome Screen and hold down ctrl + alt + shift as you click Editor.
    3. Continue to hold the keys until you see a message box asking if you want to delete Photoshop Elements settings file; click Yes. Elements will open with default preferences.
     
    |
    Mark as:
  • Currently Being Moderated
    Nov 26, 2012 3:03 AM   in reply to redeyegraphics61

    I had exactly the same  it just stopped working and failed to launch.

     

    Two tricks

    1. Make a short cut to the PSE Editor - you will find it in C:\Program Files;
      probably it's in here: C:\Program Files\Adobe\Photoshop Elements 7.0
      its called PhotoshopElementsEditor.exe
    2. Un-install and re-install the whole thing - there is no 'repair' option and you will need the install key again, it does not remember these

     

    On the whole its a right butt pain; but both work, I did both in that order, note that Organiser is not that useful or very good, so step 1 is all thats really required to get the Editor working again.

     

    It appears its organiser and the welcome screen that go mammaries up, the editor still works, just don't click organiniser or the whole PC can freeze.

     
    |
    Mark as:
  • 99jon
    12,821 posts
    Jan 6, 2010
    Currently Being Moderated
    Nov 26, 2012 8:05 AM   in reply to redeyegraphics61

     

    Did you say you had tried deleting the settings file?

     

    Hold down Shift+Ctrl+Alt and keep them pressed whilst right-clicking on PhotoshopElementsEditor.exe in the programs folder and choosing open.

     

    Then release the three keys. Click Yes to delete settings when you see a pop-up dialog box.

     

     

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 27, 2012 2:19 AM   in reply to redeyegraphics61

    Hi

     

    It looks like you're only choice is Option 2:

     

    "Un-install and re-install the whole thing - there is no 'repair' option and you will need the install key again, it does not remember these"

     

    It worked for me 

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 27, 2012 2:29 AM   in reply to redeyegraphics61

    Is PSE5 working fine on the same machine?

    Have you installed any third party drivers or some software updates recently?

    Did you try launching Organizer/Editor with Admin rights?

     

    Thanks

    Andaleeb

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points