Skip navigation
mikebowen000
Currently Being Moderated

Adobe Drive and Alfresco Enterprise Fails to Check-in With Custom Content Types

Nov 26, 2012 3:45 PM

Tags: #alfresco #cmis

Hello all,

 

I've been struggling with some drive limitations over the last few weeks as we try to utilize the CMIS connector to Alfresco.  I am currently testing with Adobe Drive 3.2.0.41 and Alfresco 4.0.1 Enterprise but have tested this behavior with Drive 4.0.2.6 paired with Alfresco 4.1.1.3 and seen the same behavior:

 

The issue I am seeing is that I am unable to Check in a new document into the repository when there is a rule set up to apply a custom content type from our model.  After entering my check-in comment and pressing OK, I get an unknown error from Bridge, InDesign, or Photoshop.  It works fine if I do not specialize our type with a rule (leaving the content as cm:content).  The error I recieve in Alfresco is:  org.alfresco.service.cmr.repository.CopyServiceException: The source and destination node must be the same type.

 

I understand that this might be a limitation of Drive and Alfresco working together, but I just wanted to see if anyone had any experience with this issue or any potential workaround, since it is pretty limiting for alfresco to not have any non OOTB content types.

 

Thanks, your help would be appreciated.

 

Mike

 

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points