Skip navigation
ermaster27
Currently Being Moderated

problem messaging

Dec 3, 2012 1:17 AM

I'm creating the game of bingo in flex. The bingo game  is composed of two main parts, the lobby and the rooms where players can play bingo. When a player is in any room, the server sends a message to each event to each client to change the status and update the room or the lobby. At this time, sometimes there is a blockage of the game because the server waits for messages to be sent to all clients. The communication channels are defined as follows:

 

<channels>

 

        <channel-definition id="my-streaming-amf" class="mx.messaging.channels.

StreamingAMFChannel">
            <endpoint url="http://95.131.233.10:8080/{context.root}/messagebroker/streamingamf" class="flex.messaging.endpoints.StreamingAMFEndpoint"/>
             <properties>
                <idle-timeout-minutes>0</idle-timeout-minutes>
                <max-streaming-clients>10000</max-streaming-clients>
                <server-to-client-heartbeat-millis>500</server-to-client-heartbeat-mi llis>
                 <user-agent-settings>
                <user-agent match-on="*" kickstart-bytes="2048" max-streaming-connections-per-session="10" />
                      <user-agent match-on="Firefox" kickstart-bytes="0" max-streaming-connections-per-session="10" />
                       <user-agent match-on="MSIE" kickstart-bytes="2048" max-streaming-connections-per-session="10" />
                      <user-agent match-on="Chrome" kickstart-bytes="2048" max-streaming-connections-per-session="10" />
                       <user-agent match-on="Safari" kickstart-bytes="2048" max-streaming-connections-per-session="10" />
                      <user-agent match-on="Opera" kickstart-bytes="2048" max-streaming-connections-per-session="10" />
                  </user-agent-settings>
               </properties>
     </channel-definition>

 

        <channel-definition id="my-amf" class="mx.messaging.channels.AMFChannel">
             <endpoint url="http://95.131.233.10:8080/{context.root}/messagebroker/amf" class="flex.messaging.endpoints.AMFEndpoint"/>
             <properties>
                <invalidate-session-on-disconnect>true</invalidate-session-on-disconn ect>
                <polling-enabled>false</polling-enabled>
            </properties>
         </channel-definition>

 

        <channel-definition id="my-secure-amf" class="mx.messaging.channels.SecureAMFChannel">
            <endpoint url="https://{server.name}:{server.port}/{context.root}/messagebroker/amfsecure" class="flex.messaging.endpoints.SecureAMFEndpoint"/>
             <properties>
                <add-no-cache-headers>false</add-no-cache-headers>
            </properties>
        </channel-definition>

 

        <channel-definition id="my-polling-amf" class="mx.messaging.channels.AMFChannel">
             <endpoint url="http://{server.name}:{server.port}/{context.root}/messagebroker/amfpolling" class="flex.messaging.endpoints.AMFEndpoint"/>
            <properties>
                 <polling-enabled>true</polling-enabled>
                <polling-interval-seconds>3</polling-interval-seconds>
            </properties>
        </channel-definition>

        <channel-definition id="my-http" class="mx.messaging.channels.HTTPChannel">
            <endpoint url="http://{server.name}:{server.port}/{context.root}/messagebroker/http" class="flex.messaging.endpoints.HTTPEndpoint"/>
         </channel-definition>

 

        <channel-definition id="my-secure-http" class="mx.messaging.channels.SecureHTTPChannel">
            <endpoint url="https://{server.name}:{server.port}/{context.root}/messagebroker/httpsecure" class="flex.messaging.endpoints.SecureHTTPEndpoint"/>
             <properties>
                <add-no-cache-headers>false</add-no-cache-headers>
            </properties>
        </channel-definition>

 

        <channel-definition id="per-client-qos-polling-amf" class="mx.messaging.channels.AMFChannel">
             <endpoint url="http://{server.name}:{server.port}/{context.root}/messagebroker/qosamfpolling" class="flex.messaging.endpoints.AMFEndpoint"/>
            <properties>
                 <polling-enabled>true</polling-enabled>
                <polling-interval-millis>500</polling-interval-millis>
                <flex-client-outbound-queue-processor class="flex.samples.qos.CustomDelayQueueProcessor">
                     <properties>
                        <flush-delay>4000</flush-delay>
                    </properties>
                </flex-client-outbound-queue-processor>
             </properties>
        </channel-definition>

 

    </channels>

 

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points