Skip navigation
Currently Being Moderated

How do I turn off CSS Minify in DreamWeaver CS6?

Dec 3, 2012 6:56 AM

Tags: #minify

This is very disruptive during site development. I've looked everywhere.

 
Replies
  • Currently Being Moderated
    Dec 3, 2012 7:00 AM   in reply to akamax

    Hi

     

    This is not Dw. but the css file you are using.

    e.g.

    If jQuery css file, check that you are using the developer version of the file, and not one with 'min' in the file name.

     

    PZ

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Dec 3, 2012 8:34 AM   in reply to akamax

    I checked my style.css file and it was Formated. I uploaded it with DW CS6 and looked. Now it was Minified.

    This is definitely not caused by DW.

     

    Either you have a plug-in installed in WP for minification or this is happening enroute to your webserver. DW has nothing to do with this.

     

    Can you try this:

     

    1. Login to your File Manager on your webserver
    2. Create a new file - name it test.css or something
    3. Copy & paste the non-minified version of the CSS from DW to that file
    4. Save it directly from the server
    5. View the file from there

     

    See if it is minified.

     

    Also, is it possible for you to give us a few links to one of the CSS files you're saying is 'minified' on your server? And the same CSS non-minified, from DW?

     

    -ST

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 3, 2012 8:39 AM   in reply to akamax

    Just change your preferences to look like this:

     

    2012-12-03_1634.png

     

    To get to this window, go to:

     

    Edit >> Preferences >> Code format.  Now look for the CSS format shown here in RED

     

    2012-12-03_1638.png

     

    Good luck.

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Dec 3, 2012 8:51 AM   in reply to mytaxsite.co.uk

    mytaxsite:

     

    The OP mentioned the formatting remains intact up until he uploads it to his webserver and reviews it there.

     

    The code formatting preferences in DW - if changed, should reflect in DW itself, isn't it?

     

    -ST

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 3, 2012 9:00 AM   in reply to akamax

    Hi

     

    Dw does not have a minification option, so this is definitely not being caused by Dw or any of the Dw settings.

     

    As Sudarshan says, it is probably happening on your server as many servers have an options setting to minify css or javascript files for delivery, on the server, (gzip). It could also be caused by running SASS or LESS on your server.

     

    PZ

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Dec 3, 2012 6:57 PM   in reply to akamax

    Akamax,

     

    Can you create and save the file from DW and upload it using a 3rd party FTP - such as Filezilla to your server? See if the code is minified or not when you upload this way.

     

    Let us know how it goes.

     

    -ST

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Dec 3, 2012 6:59 PM   in reply to Sudarshan Thiagarajan

    Also, let us know if you're running any WP plug-ins such as W3 Total Cache or 'Minify' - http://wordpress.org/extend/plugins/w3-total-cache/ on your site.

     

    -ST

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Dec 3, 2012 10:09 PM   in reply to akamax

    Can you post a screenshot of your Remote Server Settings, including 'More Options' panel?


    Site > Manage Sites > Double click desired site definition > Servers > Double click Remote server definition > Toggle open 'More Options' dialog and screenshot please

     

    -ST

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Dec 3, 2012 10:33 PM   in reply to Sudarshan Thiagarajan

    One more thing Akamax,

     

    If you have another website for which you have remote server access, can you try uploading this CSS file there using DW to see if that gets minified? This will help us rule out the possibility of something to do with this particular domain's server settings.

     

    -ST

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Dec 4, 2012 7:12 PM   in reply to akamax

    Akamax, why don't you use www.screencast.com or upload it privately to www.youtube.com (don't enable listing) and share that link with us? Once it is resolved, you could delete it?

     

    Btw, are you on Creative Cloud or is it a perpetual DW license?

     

    -ST

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Jan 20, 2013 11:08 AM   in reply to akamax

    Akamax, it looks like the minification is not just happening to CSS but to the overall script.

     

    In DW CS6, do you have any other site defined? If so, can you try putting this file in that location and upload it to a new FTP folder or a different FTP server altogether to see if it still persists?

     

    -ST

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 20, 2013 4:02 PM   in reply to akamax

    Go to Edit | Preferences > Code Format.  Which Line-Break type are you using in CS6?

     

    Which OS do you have?

     

    Nancy O.

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Jan 20, 2013 8:28 PM   in reply to akamax
    Line Break Type
    Specifies the type of remote server (Windows, Macintosh, or UNIX) that hosts your remote site. Choosing the correct type of line break characters ensures that your HTML source code appears correctly when viewed on the remote server. This setting is also useful when you are working with an external text editor that recognizes only certain kinds of line breaks. For example, use CR LF (Windows) if Notepad is your external editor, and use CR (Macintosh) if SimpleText is your external editor.

    Note:  For servers that you connect to using FTP, this option applies only to binary transfer mode; the ASCII transfer mode in Dreamweaver ignores this option. If you download files using ASCII mode, Dreamweaver sets line breaks based on the operating system of your computer; if you upload files using ASCII mode, the line breaks are all set to CR LF.

     

    Taken from http://help.adobe.com/en_US/dreamweaver/cs/using/WSc78c5058ca073340dcd a9110b1f693f21-7be0a.html

     

    Try changing your Line Break Type to LF Unix - if your webserver is running Apache. See if that helps.

     

    -ST

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Jan 21, 2013 7:02 PM   in reply to akamax

    All 3 websites that you've linked above are running Apache. Weird.

     

    It comes down to 2 things now:

     

    1. Site Definition (FTP Definition)
    2. Cache

     

    Try clearing your DW cache - http://forums.adobe.com/thread/494811

     

    Post a screenshot of your FTP Server definition from your 'Site definition' window. Mask your username/ password

     

    -ST

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 22, 2013 10:29 AM   in reply to akamax

    Changing line-break type in  preferences won't effect your previous files.  It will effect any new ones you create.   Make a new test page with Unix line breaks.  Save & upload to servers.  View source in browser to test the code.

     

     

    Nancy O.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points