Skip navigation
jmtanner
Currently Being Moderated

Export .fla to .mov

Dec 4, 2012 12:00 PM

I work with Flash CS5.5 on a MacPro with OS 10.7.5 with a 2 x 2.4 GHz Quad Core Intel Xeon processor and 32 GB 1066 MHz DDR3 memory and an ATI Radeon HD 5870 1024 MB graphics card. When I export my Flash to a .mov file the results are cluttered with artifacts of previous scenes and images over the current video images. What causes this? My coworkers on Windows-based PCs have no problems. Is there a process or preference I am missing?

 
Replies
  • Currently Being Moderated
    Dec 4, 2012 2:59 PM   in reply to jmtanner

    When you open the export window and select Quicktime output, you get a second window titled "QuickTime Export Settings". At the bottom left corner of that window is a button labeled "QuickTime Settings". That will open yet another window that will allow you to select the video and audio compressors. The default video compressor is Animation. That should never be used for anything. I have no idea why it is in the list.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 5, 2012 4:48 AM   in reply to jmtanner

    In previous versions of Flash, CS5 and earlier, you could select to save the video out as uncompressed. This is what I still use when I need video as the final product. You can then take that uncompressed video and use a video editing app, or Squeeze, to save out the final compressed file.

     

    I have found that shorter Flash files work better than longer files. I sometimes cut up the Flash movie into 7 to 8,000 frame movies, export those, and then stitch them back together as video.

     

    Do you know what compressor and settings your coworkers are using on their windows machines?

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 5, 2012 6:15 AM   in reply to jmtanner

    The Macs here also have issues using Adobe Media Encoder with H264 directly from an app rather than a finalized video. Do what Rob suggested which is what we do here except I'd recommend using the Animation codec in millions+ (lossless) just for a tiny savings on disk space. Take that highly supported codec into Adobe Media Encoder (or the other apps mentioned, I uses Sorenson Squeeze also myself) and recompress the video. Your issues should go away.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 5, 2012 7:43 AM   in reply to jmtanner

    Sure it's a standard spatinal encoding issue. The idea of lossy encoding is only the data that changes frame to frame is included in the video stream. Keyframes contain the entire picture are are used during busy areas to remove artifacts just like you see in your picture. You probably see the artifacting being removed at a very paced interval (every 1 second, 2 seconds, 5 seconds or 10 seconds is common).

     

    Did you export to uncompessed or animation codec (millions)? If so, did that contain the same artifacting? If not, what did you use to re-encode and what were the settings? Also was there transparency desired?

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 5, 2012 8:25 AM   in reply to jmtanner

    This feature hasn't worked properly since Flash 8. Here's what I've had to do:

     

    1. Choose Export Movie in Flash
    2. Under "Save as type" choose PNG Sequence
    3. Open Quicktime Player 7 Pro (NOT Quicktime X)
    4. File > Open Image Sequence
    5. File > Export

     

    It's a lousy workaround and a crummy broken feature, but that's what works unless you want to go back to Flash 8.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 5, 2012 8:44 AM   in reply to jmtanner

    Before you clog your system with PNGs, either take Million+ off (if you don't need transparency as you haven't mentioned) or change the codec to Uncompressed. I have other Macs here (running the unsupported Mountain Lion 10.8) that don't produce these issues.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 5, 2012 9:58 AM   in reply to jmtanner

    Yes I mean an alpha channel. Just reduce the colors from millions+ (RGB + Alpha) to just millions (RGB). It will be lossless and no longer contain an Alpha channel. Then see if you get the same frame to frame glitches. If you don't you know where the issue is.

     

    I mentioned Mountain Lion 10.8 because Adobe has said CS6 isn't supported in it. So I'd expect more glitches here than for you as your OS is supported.

     

    Although some of our luck may be that we export using SheerVideo HD Pro. It's a commercial (alpha supporting) QuickTime codec that compresses down about 2:1, yet is 100% lossless. We use it interchangably between Mac and Windows and it's saved us tons of disk space while keeping a lossless workflow.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 5, 2012 10:29 AM   in reply to jmtanner

    The option in Quicktime for "Uncompressed" is called "None". You can try that. There'd really have to be something terrible wrong for this to fail as every single frame is a keyframe. It's like exporting with Animation and setting the keyframe setting to "All".

     

    While there may be (hopefully) some shared libraries under the hood, Flash CS5.5 renders the video itself. Otherwise you'd see it launch AME, add itself to the queue and wait for you to configure/start the rendering.

     

    I'm just hurling ideas to go around the sequence of images approach because you probably have some audio you want synced up. It's a pain to export images, then export audio, then recombine, export/compress.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 5, 2012 12:25 PM   in reply to jmtanner

    I'm sorry none of those options worked for you. I wouldn't suggest buying a commercial codec to solve the issue rather than opening a bug report or finding an existing report to vote it up. It's a very commonly used feature that should work for you.

     

    I can tell you 100% it is absolutely not hardware. Flash is not After Effects or Premiere which are capable of utilizing a video cards openGL to render both effects and frames. There is no GPU utilization at all during Flash export that you should worry about. This is strictly a Flash or encoder bug on Mac.

     

    Lastly while not a "good" alternative, if you have the suite, After Effects supports SWF as an input format.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points