Skip navigation
KellyMitchell2690
Currently Being Moderated

Printing from Photoshop CS4 with Epson PX710W Running Mac OS X 10.8.2?

Dec 8, 2012 8:55 AM

Tags: #cs4 #photoshop #printing #epson #macbook_pro #mountain_lion #mac_os_x_10.8.2 #epson_px710w #blank_prints #paper_profiles #epson_paper_profiles #epson_premium_glossy #px710w #photoshop_cs4_mac_os_x_10.8.2_epson_printer_px710w #no_warning #no_error_messages

I need help Printing, I am using Photoshop CS4 and trying to print using my Epson PX710W with my New MacBook Pro (OS X 10.8.2 - Mountain Lion) but every time I send a photograph to print it comes out blank?

 

I am trying to print on to Epson Premium Glossy (4x6) Paper and I have tried other types of paper and sizes but every time it is blank. I always select the correct Paper Profile in the Print Menu depending upon the paper I am using and I select the correct size and paper tray. The print will print from Photoshop if I dont select an Epson paper profile but whenever I use the Epson Profiles it wont work. I even tried reinstalling the paper profiles but nothing happened, and the print remained Blank!

 

Does Anybody have any idea what might be causing this?

 

The Printer works with all paper through any other programme just not Photoshop CS4!

 

I am desperate to get it working and I just don't know what else to try. There is No Warning or Error Messages - It 'thinks' its printing it out fine and yet the sheet just gets dragged through with nothing printed on to it.

 

Please let me know if you have any ideas what might be going wrong?

 

Thanks

 
Replies
  • Currently Being Moderated
    Dec 8, 2012 9:46 AM   in reply to KellyMitchell2690

    you don't mention anything about the latest Epson (or CS4) updates

     

    did you review any of the numerous Epson-10.8 posts here (and all over the web)

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 8, 2012 12:01 PM   in reply to KellyMitchell2690

    I already had before I had to replace my broken MacBook with a new one, I never had any problems with my old MacBook printing

     

    point is 10.8 is the bleeding edge and there are a lot of posted Epson printing issues discussing its various issues

     

    it may be in your best interest to state you have downloaded the latest print driver (version) off Epson-com, deleted the old printer(s) from Print & Fax (or 10.8 equivalent), rebooted, installed the latest driver fresh, added the printer back, ran Disk Utility: Repair Disk & Repair Permissions, rebooted the machine (and it still fails)

     

    also what method you are connecting the printer (can you try a different method)

     

    also posting a screenshot of your Photoshop File> Print window may be useful (what settings are you using)

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points