Skip navigation
IsANYscreennameavailable?
Currently Being Moderated

Messed up drive names and folders 'missing' in LR 4.1

Dec 8, 2012 2:59 PM

Tags: #problem #missing #library #import #folder #lightroom4 #drivenames

Using LR 4.1 on a Windows machine with C (internal) and D (DVD) drives.  I import photos onto a FreeAgent drive, using a temporary folder (/Incoming) in which they are stored until I move them to descriptively-named folders and add metadata.  (All done in LR, not in Explorer or any other software.)

This has worked fine until an import I just did.  The Library is now showing an E: Removable Drive, which shows as offline (it is not shown by Explorer if I look there), AS WELL AS the FreeAgent, correctly identified by name, as F:    The E drive shows the descriptive folder list from all my past imports, apparently correct, but all marked with ?  The F drive shows ONLY the temporary folder, with the correct number of photos that were most recently imported.  If I click on the first (earliest) folders in the E list, the message is ‘no photos in folder, subfolders not show’.  This applies to roughly half the folders in the list.  The other half of the list, chronologically later, displays thumbnails when clicked, but is still marked ?

Can anyone please explain what is going on and how to fix this??

 
Replies
  • Currently Being Moderated
    Dec 8, 2012 3:36 PM   in reply to IsANYscreennameavailable?

    I'd recommend for this case, fixing a drive letter for the removable hard-drive, rather than letting it be dynamically assigned each session based on the next available drive letter.

     

    Then it will not be able to vary (depending on what other drives or card readers or USB-connected camera,. phone etc may be already in place at that moment).

     

    So your solution might be, to first set an entirely new drive letter for the FreeAgent drive (wisest to go higher up the alphabet, so it will be very unlikely to clash with any auto-assigned drives - perhaps X: for "external").

     

     

    http://www.windows-secrets.co.uk/2012/07/set-a-usb-drive-letter/

     

    Then you can go to the LR display of the E: drive, and right-click on the top level folder that shows within this (as missing), and choose "Find Missing Folder" in the context menu. Then browse to the right location for that, in what is now your X: drive (or whatever). The images will all come back online and you will now see an X: drive instead of an E: drive in the LR Folders list.

     

    Then you can go to the LR F: drive and do the same for the /incoming folder. Those images will come back online too and the F: drive will disappear from LR.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points