Skip navigation
jfr8036
Currently Being Moderated

error LNK1123: failure during conversion to COFF

Dec 10, 2012 6:52 AM

Tags: #newbie #sdk

hello,

I'm new to the sdk and I'm trying to open the sample projects to understand what's going on here,

the problem is that when i try to build the project(for example the SDK_File_Import project)

i get the error:

 

Error1error LNK1123: failure during conversion to COFF: file invalid or corrupt

 

why is that?

 

please help

 

thank you very much in advance

jony

 
Replies
  • Currently Being Moderated
    Dec 10, 2012 9:49 AM   in reply to jfr8036

    Hi Jony,

     

    Just checking, are you using Visual Studio 2010 or Visual Studio 2010 Service Pack 1?  I'm on SP1 and I'm not seeing this link error.  And are you using the Premiere Pro CS6 release 2 SDK, with the Visual Studio 2010 sample projects?

     

    Regards,

     

    Zac

     
    |
    Mark as:
  • Currently Being Moderated
    Calculating status...
    Oct 30, 2013 12:30 PM   in reply to jfr8036

    Hello,

     

    This topic is a bit old, but I have the same problem. My english isn't perfect so I don't understand everything in the pdf guide.

    I just started, and I would like to build the Export project, which is in the Exemple directory. (I took the cs6 premiere pro release 2)

    I did this part of the guide : "On Windows, to specify where you want the built plug-ins to go, set a user environment variable

    (right-click My Computer > Properties > Advanced > Environment Variables > User variables)

    called PREMSDKBUILDPATH to the desired path (e.g. “C:\Program Files\Adobe\Common\

    Plug-ins\[version]\MediaCore\”)", and I also put the exemple directory on  “C:\Program Files\Adobe\Common\Plug-ins\[version]\MediaCore\”.

    Then, I opened the SDK_Exporter file with visual studio 2010 (from “C:\Program Files\Adobe\Common\Plug-ins\CS5\MediaCore\Examples\Projects\SDK_Expor ter\"), and tried to debug it with the x64 debugger.

    I obtained this error : "LINK : fatal error LNK1123: failure during conversion to COFF: file invalid or corrupt"

     

    May someone help me to build this?

    Thanks for your help!

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 31, 2013 6:12 AM   in reply to naithriell

    Well, if it can help someone, I uninstalled .net 4.5 framework to install .net 4.0 framework and it worked (I don't really know whyt but ..)

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points