Skip navigation
Currently Being Moderated

problem with typing Cyrillic in InDesign

Dec 11, 2012 7:01 AM

Tags: #windows #type #true #international #cyrillic

Previously I was able to type in Cyrillic type using Windows True Type fonts in my InDesign. I have both CS4 and CS6 running. The fonts are still there and everything else is pretty much the same. Somehow now I can't type in Cyrillic type using Windows TT fonts. The Unicode fonts are still typing fine in Cyrillic on my InDesing. Windows TT Cyrillic shows just bunch of squares. But when I just copy and paste some Cyrillic text from Word document into InDesign, it shows fine. I place my cursor behind that text and start typing, and it starts showing squares instead of letters. Microsoft programs do not have problem typing in Cyrillic.

 

I had this problem before. Somehow I was able to solve it but can't remember what I did.

Does any one know what is wrong with my computer?

 
Replies
  • Currently Being Moderated
    Dec 11, 2012 10:23 AM   in reply to generalbatzorig

    I have no idea what is wrong, but I have some fairly random questions and suggestions:

     

    Microsoft Word will silently substitute another font if you switch keyboards - but InDesign won't. When you paste Cyrillic text into ID, what font is being used in ID? Can you tell us which fonts work in Cyrillic in Word that don't work in ID?Of course, not all fonts have Cyrillic glyphs, and "TrueType" is a file format, while Unicode is a font encoding - so your separation of these does not make sense to me.

     

    Is your default text marked with a character style? (Is there a character style selected when you don't have any documents open?)

     

    If you run through this:

     

    ...  when I just copy and paste some Cyrillic text from Word document into InDesign, it shows fine. I place my cursor behind that text and start typing, and it starts showing squares instead of letters...

     

     

    then select the Cyrillic text to check the font, then a single pink square. Same font, or different fonts?

     

     

    There's a setting I've never used or understood in Edit -> Settings -> Advanced Type "Use inline input for non-Latin text." Is that box checked?

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 11, 2012 12:33 PM   in reply to Joel Cherney

    I think "Use inline input for non-Latin text" shouldn't really affect typing Cyrillic directly at the keyboard.  As far as I know, the feature determines where the CJK IMEs show the list of "candidates" (possible characters for a given input string), either near the cursor or at the edge of the screen.  However, enabling it has caused problems in the past so I leave it unchecked.

     

    David

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 12, 2012 11:47 AM   in reply to generalbatzorig

    There's a lot going on in here!

    those Mongolian cyrillic modified fonts have have strange name extensions, such as Ch_Minion, Arial Mon etc

    That is a very old way of handling Mongolian text input. All of the glyphs for Cyrillic Mongolian are in plain old Arial now, and a pretty decent number of other fonts. And the Mongolian glyphs are in a place that the OS (where any Unicode-compliant app) can find them, while the modified fonts store them in non-standard locations. So you shouldn't need to use any kind of

    Unicode>Windows text converter. 

    to switch between codepages for Cyrillic Mongolian text if you are using contemporary fonts.  We did it that way back in the 20th century, but now such specialized codepage-conversion tools are mostly unnecessary, even in some very rare complex scripts. (Sadly, traditional vertical Mongolian scripts is not one of those scripts.)

     

    For what it's worth, the only evidence anywhere on Google that the "Ch_Minion" font exists is... this thread.

     

    What can you tell us about your text converter? Converting Unicode text to some pre-Unicode encoding system is a bad idea in almost every circumstance.

     

    I remember being able to type  in Mongolian cyrillic in ID before. It was before I reformatted my computer and added Adobe CS6 Master Collection. I am wondering if this change caused the problem.

    The format, maybe. Certainly not CS6. Can you tell me what input method you use? Do you use the one built into Windows? (By the way, what version of Windows are you using?) Or do you use a third-party solution?

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 13, 2012 3:37 PM   in reply to generalbatzorig

    Now my only option is to copy and paste from Unicode>Windows text converter or hit the glyph letters one by one.

     

    I am 100% certain that we can do better than that. Not tonight; I have some research to do before I can answer you. I had no idea that Mongolian required the y-with-straight-descender. You're right, that is not in most fonts, not even the Adobe Pro fonts with the extensive Cyrillic coverage.

     

    However, there are plenty of languages (Burmese, Khmer, Bulgarian, you name it) where I have to make the old-fashioned broken-custom-encoding fonts work happily in InDesign next to new, well-encoded OpenType fonts. So give me a couple of days and I'll post again.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points