Skip navigation
pixelpeddler
Currently Being Moderated

Premiere Pro "video display module" with no switchable graphics?

Dec 16, 2012 10:52 AM

I am getting the "no video display modules" error message when trying to open PP CS6. I have read previous discussions, updated my drivers, downloaded a new catalyst center, run as an administrator, with no luck. Everyone is saying to right click on the desktop and select "switchable graphics" -- but I DON'T HAVE THAT OPTION....

 

I'm running a ATI Radeon HD 5450, desktop computer, Windows 7 64bit. I just need to know where to go now! Thanks to anyone who can help.

 
Replies
  • Currently Being Moderated
    Dec 16, 2012 8:01 PM   in reply to pixelpeddler

    What model CPU?

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 17, 2012 8:22 AM   in reply to pixelpeddler

    Try updating your video drivers from the AMD site.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 17, 2012 8:42 AM   in reply to pixelpeddler

    So you are running 12.10 drivers or maybe even 12.11?

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 17, 2012 9:48 AM   in reply to pixelpeddler

    I'm assuming you have an i7-3770 Ivy Bridge, the non-K version with 16 GB RAM, correct?

     

    Have you tried to reopen the project that says 'no video display modules', right after this error message? I would suggest to reboot your system before you do that. Sometimes that helps. If not, create a new project and import the troublesome project into it. See if that helps.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 17, 2012 9:56 AM   in reply to pixelpeddler

    Intel i7

     

    What model?

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 17, 2012 10:07 AM   in reply to pixelpeddler

    OK.

     

    Reboot into the BIOS and make sure any Integrated Video is disabled.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 3, 2013 4:04 PM   in reply to pixelpeddler

    Hey there,

     

    I recently had the same issue on a Dell laptop with switchable AMD graphics. I fixed it by going into the Catalyst display settings, and in the section where you can choose which graphics to run for what program, I toggled 'gpusniffer.exe' to high performance graphics.

     

    Hope this helps.

     

    Chris

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points