Skip navigation
Currently Being Moderated

Why does Photoshop CS6 blink on Windows 8?

Jun 19, 2013 10:56 AM

When using Photoshop CS6, my screen blinks and flashes, especially when using editing tools or adjusting the image (increasing/decreasing size.)  I am an Adobe Cloud member and using a new machine that has Windows 8 which I am still getting used to.  I had been using my CS apps on my laptop/W7 with no problem whatsoever.  Not sure if the OS makes a difference.  Suggestions?  Thank you.

 
Replies 1 2 Previous Next
  • Currently Being Moderated
    Dec 21, 2012 6:23 PM   in reply to michaeljstevens@live.com

    Known problem with Windows 8 GPU drivers.

     

    We're working with the GPU vendors and Microsoft to come up with a solution.

     

    For the time being, set the GPU drawing mode to "Basic" in preferences.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 7, 2013 2:15 PM   in reply to Chris Cox

    I am having the same exact problem.  Brand new computer and also using the free trial of adobe cloud until my funds arrive to purchase the full service. (However, now I'm very leery of purchasing the cloud ).   Not cool seeing as I need to use these programs all day and every day for both of my businesses...

     

    I tried setting the GPU mode to "Basic", even tried "Normal" but still getting the same exact results with frequent flashing and it is the only program I have open on my PC.  For example, when I try to use the lasso tool, it constantly flashes black as I'm selecting until I let go.

     

    I cant work like this and it's hurting business and it is making me fall behind with clients.

    Is there any estimate as to when this will be fixed?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 7, 2013 2:28 PM   in reply to PozziToonsXtina

    Setting the GPU mode to "Basic" should avoid the known GPU issues in Win8.

    (don't forget to restart Photoshop after changing the mode)

     

    We're still working with Microsoft and the GPU vendors to get this fixed, but we cannot speak as to their schedules.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 7, 2013 2:34 PM   in reply to Chris Cox

    Haha Derp!  Yup, that seemed to help.

     

    Hopefully you guys can get everything sorted out soon. Thanks for the help

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 19, 2013 9:11 AM   in reply to PozziToonsXtina

    I wonder how this turned out. Same problem here except that PS6 works fine, and CC has the flickering problem with the lasso tool. It seems rather a long time since this problem was identified. How's the working it out going, gentlemen?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 19, 2013 10:32 AM   in reply to michaeljstevens@live.com

    THe GPU vendors have improved the situation in recent driver versions - but we cannot set Microsoft's release schedule.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 19, 2013 10:43 AM   in reply to Chris Cox

    Thank you, Chris. I appreciate knowing that the issue is being dealt with. I have set the performance to basic and it worked so far, but it's too bad to not be able to run this machine at it's optimum settings. ASUS, i7, 2 graphics cards - one onboard Intel 4000 or something like that and nvidea with 2G RAM, 8 G RAM, 2 LaCie T drives and a 7500 rpm primary drive. If those specs don't run PSCC, I don't know what will. The cards have the latest drivers. WIn8.

     

    There was no problem with PS6.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 19, 2013 10:46 AM   in reply to KateMann

    The problem exists in Photoshop CS6, and we've tried to work around some of it in Photoshop CC.

     

     

    But some OS level things we can't completely work around...

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 19, 2013 10:58 AM   in reply to KateMann

    I would disable the onboard Intel.  PS does not like 2 dissimilar cards and you may have it swithing back and forth.  nVidia should be able to handle everything.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 19, 2013 2:05 PM   in reply to Chris Cox

    This may help some people. On another site: http://www.tomshardware.com/forum/342967-33-switching-onboard-graphics -nvidia-graphics-card

     

    A gentleman replied to the question of how one switches from the onboard (not so powerful) graphics processor to the video card (very powerful) using software in the case of nVidea cards. It is easy, and might work out some of the kinks. I have switched and will now try to see if I can mess up PSCC using the higher setting. bbiab

     

    "

    Yes, this is called 'Optimus Technology' developed by nVidia, where your main graphics card is the integrated one and it works together with nVidia dedicated/discrete graphics card to deliver great performance but still save battery live. It's basic, the nVidia one is powerful and the Integrated one is not. But the nVidia one is power hungry and quickly put down battery very quick, where the integrated one does not. So what nVidia do is, when you are gaming, they automatically switch to use the nVidia so the performance is high. When not gaming, you turn of the nVidia one and switch back to the integrated graphics. But this does not work when you don't set it up yet. Don't worry, it's not hard and does not require change on hardware, only software. The first thing to do is, go to your nVidia driver by right clicking on your desktop and choose 'nVidia control panel'. If you can't find it go and download the driver. After you are at the control panel of nVidia, in the left side of that window there is 'Manage 3D settings' Under the 'Select a Task'. Click on that and you see in the other part there is a 'global settings' tab and 'program settings'. Go to the global one and in the 'preferred graphics processor' choose 'High Performance nVidia Processor'. You should then have the optimus technology when you choose apply. The 'program settings' in the other hand is to choose what graphics card you want to use for each program of your preference. So you choose on your program and select your preferred graphic card there.

     

     

    P.S. Some programs are sadly not supported by the Optimus graphic card, so which means that the program will still run in the main graphics (which is the integrated graphics) and you still have the integrated performance. To get rid of this issue you must to contact your nearest ASUS service to disable the optimus technology.

     

     

    Sorry for grammar mistakes............."

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 19, 2013 2:12 PM   in reply to KateMann

    So, I followed the instructions above booted PS, changed the performance setting to the highest setting, rebooted. Then I grabbed the lasso tool, and presto it seems to be working. No flickering. In short, it's the performance that I am used to having. Mind you, this is a Raw file with one layer so far.

     

    I hope this might help out somebody else.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 20, 2013 11:43 PM   in reply to KateMann

    Thanks for all the info folks.  I too have WIndows 8 and am having the flickering in Photoshop CC I just downloaded yesterday.  I had CS6 and had no issues.  I will check out these fixes!

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 25, 2013 4:33 PM   in reply to michaeljstevens@live.com

    Solution Found!

     

    [:Instructions:]

     

    [--

    1) Click your Battery Display in the ToolBar.

    2) Change Power Settings to "High Performance"

    2B) If you do not have a button titled "High Performance" then click "More Power Options" It should show up. If not, click the arrow on the line connecting to the text "Show Additional Power Plans" It now should show up.

    3) Close Photoshop CC/CS6 and restart the program.

    4) It should now work. If not, try updating your drivers or check if the program is compatible with your current OS.

    --]

     

     

    ~M1ST3RF1X1T to the rescue!

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 31, 2013 11:38 AM   in reply to michaeljstevens@live.com

    Guaranteed to work:

     

     

    Solution

     

    #

    Change the GPU Drawing Mode to Basic:

    1. In Photoshop, choose Edit > Preferences > Performance.
    2. Select Advanced Settings.
    3. Choose Basic from the Drawing Mode pop-up menu.
    4. Click OK to close the dialog boxes.
     
    |
    Mark as:
  • Currently Being Moderated
    Aug 3, 2013 7:50 PM   in reply to Jwizz720

    This solution worked great for me.  I am using Photoshop CC on a new Windows 8 machine.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 6, 2013 10:34 PM   in reply to Ryan814

    You're welcome.

    Share with others

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 7, 2013 2:38 AM   in reply to Jwizz720

    After a few weeks of using CS6 on a new PC (aargh) with Windows 8 and being driven nuts with the blinking screen problem, I found this forum, followed your advice re changing to basic drawing mode and am very pleased to say it works!  It has potentially saved me from an epileptic fit! Thanks.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 7, 2013 10:14 AM   in reply to bakewell_72

    The better solution is still to update your video card drivers from the GPU maker's website.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 7, 2013 12:50 PM   in reply to Chris Cox

    I solved this problem by getting a Quadro K2000 graphics card.

     

    Bob Frost

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 8, 2013 5:56 PM   in reply to michaeljstevens@live.com

    This has been driving me INSANE I've googled the issue before with no luck finding a solution. Finally used different set of keywords and found this thread. I think this solution did the trick with the flickering.

     

    NOW I need to figure out how to stop certain random colors from displaying only in black. For example, certain hues of blue appear black, but when you move the image window around the screen the correct blue color appears for a second. But as soon as I stop dragging the image around the screen, the color turns from blue black again.

     

    I think this is related to the Windows 8 graphic driver issue. Any thoughts?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 8, 2013 7:37 PM   in reply to eriqc

    Update your video card driver from the GPU maker's website.

    And from the description, you have an AMD/ATI card with a driver that's at least a year old.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 9, 2013 12:55 AM   in reply to Chris Cox

    AMD card. Thanks for the suggestion I'll give that a shot.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 3, 2013 11:13 PM   in reply to eriqc

    I am going to have a seizure if this bs continues

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 3, 2013 11:16 PM   in reply to chris garrido

    So I am potentially gonna have to buy this CC to inherit a seizure? ridiculous

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 4, 2013 12:07 AM   in reply to chris garrido

    No, you just update your video card driver, or turn down the GPU level in Photoshop to avoid the system bug.

    Or you could just wait for Microsoft to patch it (but updating drivers is much quicker).

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 4, 2013 12:14 AM   in reply to Chris Cox

    I had the same problems running Windows 8 with CS6. This fix worked - go to Preferences, Performance, Advanced Settings (under Graphics Processor) and change the Drawing Mode to Basic.

     

    Sent from my iPhone

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2013 7:39 AM   in reply to michaeljstevens@live.com

    This has been an issue for me for a few months. I'm a digital painter, so each time I make a stroke it will start to flash. I've also changed my settings, but the bug is still happening. Only reason why I use the programs now is to work on logos, and poster designs.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2013 4:48 PM   in reply to Nalbina

    Please read the previous replies -- you need to update your video card driver.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 15, 2013 5:41 PM   in reply to Chris Cox

    Exactly the same problem on a new Windows 8 machine, 16 GB RAM and ATI Radeon 7600 series vid. card. Updated the driver. Same issues. Got rid of all 3rd party plugins. Same issues. Resetting drawing mode to Basic fixed the flashing screen while painting, but introduced new issues such as flashing screen while scrolling around document after zooming in, odd changes to image (darker) when clicking on the eye icon of Layers to assess changes, or a white and gray checkerboard screen when clicking on eye icon of layer. None of this occurs with any of my many other photoediting software, only with Photoshop CC. It would be nice if you would roll back the new graphics until you get it sorted. What I thought was a minor irritation is quickly developing into a major pain.

     

    I am tempted to install an old copy of CS4 and be done with it until a fix comes down the pike. Will CS4 work on Windows 8?

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 15, 2013 6:00 PM   in reply to Snofox42

    Did you update the driver from AMD's website?  So far everyone who actually updates the driver correctly has the problem disappear.

     

    This isn't a matter of "new graphics", this is just a bug in Windows 8.

    Other than the driver updates, we're not sure when Microsoft will have the more complete fix ready.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 15, 2013 6:13 PM   in reply to Chris Cox

    Thanks for the quick response! Yes, I udated the driver from the AMD web site. They sent me an email with the most recent driver listed, dated 2013-09-06. After installation, however, it is dated 2012-08-28 in Device Manager, I found today. I am writing them to clarify this.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 16, 2013 12:41 AM   in reply to Snofox42

    I cured this problem by getting a new graphics card - nVidia Quadro 2000. These seem to be designed for reliability rather than for playing games like most consumer graphics cards.

     

    Bob Frost

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 17, 2013 2:29 PM   in reply to Chris Cox

    I noticed your response mentioned that Adobe and Microsoft are working together to fix this blinking problem in 2012.  Have they come up with anything yet?  It is impossible for me to select or transform images, which makes photoshop pretty useless for me.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 17, 2013 2:34 PM   in reply to STS098

    We can only say that Microsoft knows about this and is working on it.

    In the meantime, updating the drivers almost always solves it.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 17, 2013 3:59 PM   in reply to Chris Cox

    Reinstalled the graphics card driver to ensure I have the most recent version. I do. For the record, all of the flickering problems continue. I will just have to wait it out, I guess. I just hope it doesn't take too long...other software is beckoning.

     
    |
    Mark as:
  • Noel Carboni
    23,455 posts
    Dec 23, 2006
    Currently Being Moderated
    Sep 17, 2013 4:54 PM   in reply to Snofox42

    A lot of you folks upgraded to Windows 8...  Why?

     

    Microsoft released what they want you think of as an upgrade, but which really delivers nothing significant.  Name something Windows 8 does for you that Windows 7 couldn't.

     

    Conscientious folks who need critical things to keep working don't just change out a working OS and complain to application makers that their having done so breaks their applications.  They test, they research.  THEN they migrate when it's safe to do so.

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 17, 2013 5:19 PM   in reply to Noel Carboni

    I think most people just get Win8 with their new machine and deal with it...

     
    |
    Mark as:
1 2 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points