Skip navigation
t_bryan
Currently Being Moderated

Flickr publish service plugin does not work after upgrade to Windows 8 Pro and Lightroom 4.3

Jan 1, 2013 4:06 PM

Tags: #plugins #flickr #publishing_service #lr4 #lightroom4

I'm having the same symptom mentioned in this thread: http://forums.adobe.com/thread/1058075

 

In the Flickr Publish service configuration dialog, the Authorize button pops up a dialog that explains "Lightroom needs your permission to upload images to Flickr," but when I click that dialog's Authorize button, it appears to do nothing (no browser, no error message, etc.). 

 

I am currently running Windows 8 Pro 64-bit and Lightroom 4.3 64-bit.

 

Here's a history of this problem. 

 

I was using Windows Vista 64-bit with an updated Lightroom 3 (version 3.6?).  I was publishing to Flickr using the built-in Flickr publish plugin.  That worked flawlessly for the last year, and I never had a problem.

 

I then upgraded to Windows 8 Pro 64-bit.  Unfortunately, I did not test Lightroom 3 at this point.

 

I then upgraded to Lightroom 4.3 64-bit. 

 

After these upgrades, I tried to publish two photos to Flickr using my existing Flickr publish configuration.  I believe that I got some error the first time, which I did not write down.  I wasn't sure that the Flickr publish service would upgade correctly, and I did some searching online. 

 

I'm familiar with the Flickr APIs, and I thought that after the upgrade, I probably needed to re-authorize the plug-in.  I went to my Flickr account in my browser and revoked Lightroom's permissions.  I may have also clicked "Remove Authorization" in the Flickr publish plugin's settings page.  After that, I started hitting the problem described above.  When I click the Authorize button, I never get a browser pop up.

 

I then tried a few things. 

 

  1. I verified the registry entries had the values described in this thrad: http://forums.adobe.com/message/3121076#3121076
  2. I removed the old Flickr publish service that had been migrated from Lightroom 3.6.
  3. I uninstalled Lightroom 3.6.
  4. I ran the "repair installation" for Lightroom 4.
  5. I ran lightroom.exe -register as the administrator.
  6. I ran Lightroom 4 as the administrator.

 

Between each of those steps, I rebooted the machine.  When the machine came back up, I opened Lightroom 4 and clicked the Flickr publish service's "Set up" button.  I then when to the plugin manager and reloaded the Flickr plugin.  Finally, I clicked "Authorize" in the Flickr plugin's settings.  Every time, I get the same behavior.  "Not authorized" in the settings dialog changes to "Authorizing..." while it shows me a dialog.  I click the Authorize button in that dialog.  I briefly see a different message in Flickr publish service settings page (Waiting for response...).  Then it changes to "Not Authorized."  I never see a browser or an error.

 

With each experiment, I tried with both IE and Firefox set as my default browser.  I get the same behavior with both browsers. 

 

I verified that running "start lightroom://www.flickr.com" from the Windows command prompt opens Lightroom 4.3.  Therefore, I believe that the registry settings for the lightroom URL protocol are correct.

 

I have never used the Facebook publish service in the past, but I cilcked on the set up button for that plugin.  When I click Authorize on Facebook, it launches my browser (or opens a new tab) for Facebook.  Therefore, it looks like Lightroom plugins are able to launch the browser.

 

It seems like there's something wrong with the Flickr publish service plug-in itself.  I'm not sure how to get any additional diagnostic information from the plugin.  I'd be happy to try something else, but at this point, I'm out of ideas for troubleshooting.

 

I can try switching to Friedl's Flickr plugin, but I'd rather just see the builtin plugin fixed or my current problem diagnosed. 

 
Replies

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points