Skip navigation
Currently Being Moderated

Connect Google Android devices

Jan 4, 2013 3:50 AM

 
Replies
  • Currently Being Moderated
    Jan 4, 2013 3:50 AM   in reply to Community Help

    How can I save above mentioned change in android_winusb.inf when Windows claims an access denied error alert?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 4, 2013 8:19 AM   in reply to freeland joe

    Hmmm. I am able to update and save this file. Do you have it open somewhere else or maybe have the SDK Manager or Virtual Device Manager running?

     

    Sorry I can't be more helpful,

    Randy Nielsen

    Senior Content and Community Manager

    Adobe

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 4, 2013 7:46 PM   in reply to jrunrandy

    Have closed everything but still alert. I will try on another device and compare the settings.

    B.t.w. - I am also unclear about No.6: Copy and paste a comment and hardware listing - where does each comment start and the listing end?

    Is this the complete addition for Nexus 7 for example:

    Re:  Connect Google Android devices

    ; Nexus 7

    %CompositeAdbInterface%     = USB_Install, NEW HARDWARE ID

    I´d really appeciate your help - (for arts on the web).

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 4, 2013 10:20 PM   in reply to jrunrandy

    Finally an installation package of drivers for androids from the developer site of android solved the problem:

    http://developer.android.com/tools/extras/oem-usb.html#Win7

    There are instructions for different O.S. and Wndows Versions and the installation is commented.

    Everything works fine now with Nexus debugging. Thanks.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 13, 2013 4:22 PM   in reply to Community Help

    I'm using Flash Builder 4.7. I've connected my ASUS Eee Pad Transformer Prime TF201, which is in the list of supported Android Devices. Drivers are installed and windows recognizes the device, and allows me to transfer files to and from the device no problem. However, Flash Builder does not recognize the device when I try to debug. USB debugging is turned on in the tablet. I've tried adjusting all the Developer settings on the tablet, but Flash Builder still will not recognize the device. Suggestions?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 13, 2013 6:25 PM   in reply to nwoevhm

    @nwoevhm,

    Make sure the device is not mounted as an external drive. Flash Builder/Android SDK needs to see your phone as a phone, not a mounted drive.

     

    Let me know how it goes.

     

    Regards,

    Randy Nielsen

    Creative Cloud Product Integration Manager

    Adobe

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 19, 2013 10:13 AM   in reply to jrunrandy

    Thanks Randy, but that option doesn't seem to exist on this tablet. My only options are Media Device and Camera.

    After some research it seems I'm not the only person having this problem with the TF201. I found this link which seemed to help MAC users having the same issue, but I still can't get it to work for Windows. http://nc-design.net/home/-/blogs/debugging-air-mobile-on-the-asus-tra nsformer-prime-tf201-

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 19, 2013 11:11 AM   in reply to nwoevhm

    Hmm. That's odd. If you have the appropriate USB driver installed and haven't mounted as a Media Device, it should work.

     

    I only have one more idea: Do you have the Android SDK installed? If so, navigate to the platform-tools directory in a command shell and issue an adb devices command. This will tell you whether or not the Android Development Kit recognizes the device. (Because Flash Builder not recognizing the device is really Android not recognizing the device).

     

    HTH

    -Randy

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 25, 2013 11:29 AM   in reply to jrunrandy

    My Samsung Galaxy S4 is doing the same thing to me...  I cannot get Flash Builder 4.7 to recognize it at all, despite the fact that it does show up correctly in the Windows Device Manager -- it says "Samsung Android ADB Interface in the Device Manager, so Windows is clearly recognizing it correctly...

     

    One thing I have noticed -- when I plug in the phone, it automatically defaults to "Media Device".  There is no option to turn that off -- I can leave it either as a Media Device or switch to Camera mode, but there is no option to turn off the connection.  It always shows up on Windows Explorer as an external drive, no matter what I do.

     

    Where is this 'platform-tools' directory you're talking about?  Where can I find the adb command?  I can't find it anywhere in my Flash Builder 4.7 folder...

     

    Thanks for any help you can give.

    Laurence MacNeill

    Mableton, Georgia, USA

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 25, 2013 11:48 AM   in reply to Laurence MacNeill

    The platform-tools directory is part of the Android SDK, which you download separately these days from developer.android.com.

     

    And you might want to check http://stackoverflow.com/questions/16256048/eclipse-android-sdk-cannot -see-new-samsung-galaxy-s4-device-via-a-usb-connection. It sounds like a similar problem to yours.

     

    HTH

    Randy Nielsen

    Adobe

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 25, 2013 11:56 AM   in reply to ranielse

    Oh, yeah -- I've already done that.  Developer Options is enabled, and I have selected USB Debugging...  If I turn off USB Debugging, the phone doesn't show up as "Samsung ADB Interface" in the Device Manager -- it only shows up as an external USB drive in Windows Explorer...

     

    I guess I'll try downloading the SDK and see if that will work...

     

    L.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 25, 2013 12:14 PM   in reply to Laurence MacNeill

    Did you enable Developer Mode? It sounds weird to me, but this page describes the "secret handshake":

     

    http://blog.immersion.com/2013/05/developer-options-galaxy-s4/

     

    Let me now how it goes.

    -Randy

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 25, 2013 12:29 PM   in reply to Laurence MacNeill

    Well, typing "adb devices" from a command-prompt gives me no devices attached.  So if the Android SDK can't recognize it, I'm assuming Flash Builder 4.7 never will...  I'll report back if I figure out how to get the Android SDK to recognize it.

     

    L.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 25, 2013 12:31 PM   in reply to Laurence MacNeill

    Yeah. Good luck. My only other suggestion is to try restarting, but it sounds like you've already tried just about everything.

     

    -Randy

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 25, 2013 12:31 PM   in reply to ranielse

    Yes, developer mode is on.  I can see a Developer Options item on the Settings screen, and I have USB Debugging turned on.

     

    Thanks,

    L.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points