Skip navigation
Liger357
Currently Being Moderated

Can't open jpg from Windows 7 Explorer in newly installed Photoshop Elements 11

Jan 5, 2013 3:09 AM

Elements opens but the image does not appear in the editor.

 

Other people have reported similar problems but I cannot find a solution.

 
Replies
  • Currently Being Moderated
    Jan 5, 2013 3:24 AM   in reply to Liger357

    How are you trying to open it? Double clicking on the image?

     

    Well this solution works for me on Windows 7.

    1. Right click on any jpeg image, and select Open With > Choose Default Program >Browse.

    2. A dialog box will appear. Go to this location: C:\Program Files (x86)\Adobe\Photoshop Elements 11  (Kindly make sure you select Program Files (x86) if you have 64 bit OS)

    3. Select the file : PhotoshopElementsEditor, and click Open button.

    4. Check the box "Always use the selected program to open this kind of file ".

    5. Press OK button.

     

    Now whenever you double click on any jpeg it will by default open in Editor.

     

    See if it works for you as well.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 5, 2013 10:27 AM   in reply to Liger357

    It's working on my Win 7 machine. Just want to make sure you are following all the steps?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 5, 2013 12:05 PM   in reply to Liger357

    I believe that Adobe have made a blunder with this aspect of Elements 11.  I have asked for a solution to the same problem within the past 36 hours but nobody has an answer which works.  I flatly refuse to use the organiser as it has never offered any useful utility for me.  As I stated earlier, I'm as organised as I want to be and neither want or need Adobes help.  I just wanted to click on an image icon and have that image open straight into Elements 11 Expert Mode - as in all other previous versions.  Currently it seems impossible.

     

    What I have to do now is open Elements 11, click Open and find the image I want.  A major backward step for me.

    I'm using Windows 7, 64 bit and had already worked through the suggestions others had kindly made.  None of them work.

     

    Next stop  - phone Adobe experts - or see what the photo press make of it.  Good luck to all of us.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 5, 2013 12:27 PM   in reply to graill4214

    Something which has not been mentionned in that discussion:

    When you open PSE, you get the Welcome Screen. Did you set it to open automatically in the editor ? That choice is on a menu activated by clicking on the wheel just left of the close 'X' icon. Maybe worth a try.

    I'm also on Win7 and double clicking on a file in the Windows explorer has always opened the image in the editor just like in PSE10.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 5, 2013 2:35 PM   in reply to MichelBParis

    Hi,

     

    The steps given above should normally work, however, I find that the Windows 7 system can sometimes get confused, possibly due to the number of characters in the filename. If the above fail then try these steps.

     

    1) Use Windows explorer to navigate to C:\Program Files (x86)\Adobe\Photoshop Elements 11  (omit the (x86) if on a 32bit system

    2) Right click on PhotoshopElementsEditor.exe and select Copy

    3) Right click the blank space and select Paste, you will need to confirm this action but it should produce a file PhotoshopElementsEditor - Copy.exe

    4) Right click on PhotoshopElementsEditor - Copy.exe and select Rename - then rename it to PSE 11 Editor

    5) Now follow the steps in message #1 above but point it to the new PSE 11 Editor file

     

    My system does get very confused but that is because I have versions 9, 10 & 11 installed for testing purposes. I Had to resort to the above trick to allow me to open a jpg with any of the editor versions using Open With..

     

    Hope the above helps

     

    Brian

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 5, 2013 3:19 PM   in reply to MichelBParis

    Yes, tried that.  Also reinstalled Elements 11, updated it.  Even when I get to open an image, it defaults to the Quick editor.

     

    Thanks anyway.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 5, 2013 3:26 PM   in reply to Little_Pale_Face

    Just tried it and it seems to work a treat but I’ll see what happens after it’s had a decent nights sleep.  Many thanks.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 5, 2013 3:40 PM   in reply to graill4214

    Hi,

     

    Please keep us updated - if it doesn't work, then we will have to have another think.

     

    Brian

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 5, 2013 11:21 PM   in reply to graill4214

    graill4214 wrote:

    I just wanted to click on an image icon and have that image open straight into Elements 11 Expert Mode - as in all other previous versions.  Currently it seems impossible.

    .Just a note that this bug is not new to PSE11. I think there has been the same amount of posts about this in PSE10; is it a problem with Win7 ? possibly.

    I think that reinstalling the software can't cure the problem unless you use additional 'cleaning' tools after the uninstall. I don't find the posts about the adequate software, someone should help here. I'd use a tool like ccleaner anyway to correct the Windows registry.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 5, 2013 11:25 PM   in reply to Little_Pale_Face

    Just confirmed that this fix does work – it does.  Also checked that the RAW editor (v 7.3) works, had the same problem initially but applied the same fix and everything works a treat.

     

    Many thanks – once again very happy with Elements. 

     

    Graham

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 5, 2013 11:44 PM   in reply to graill4214

    There has been similar problems with opening files.

    Here is an example and the solution (post #7).

    http://www.elementsvillage.com/forums/showthread.php?t=76466

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 6, 2013 1:41 AM   in reply to graill4214

    Hi Graham,

     

    Thanks for letting us know that it works.

     

    I hope that Liger357 has a chance to try it to see if they can get it to work.

     

    Brian

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 18, 2013 10:12 AM   in reply to Liger357

    I got hit with the same issue ... but found a simple clean answer (after a while):

     

    The "default program" ("recommended program" when you use "open with" in the explorer context) which is associated with a file extension ultimately points to the following command: "C:\Program Files (x86)\Adobe\Elements 11 Organizer\Photoshop Elements 11.0.exe" "%1", which is the PSE Organiser

     

    This command didn't work for me (not even from the command line does this work, so it's a bug). I guess it gets hung up at the welcome screen in the background

     

    I changed the "default program" / "recommended program" to point directly to the Photoshop Elements Editor.  Then it works as it should.

     

    To do this cleanly, you need to delete the wrong "default program" entry by deleting the relevant entry in the Windows registry for each picture file extension associated with PSE 11:

     

    For example, on WIndows 7 64bit, the relevant registry entry for .cr2 files (Canon raw format) is HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\ FileExts\.cr2\OpenWithList

    and may have several entries labled a, b, c...., one points to Photoshop Elements 11.0.exe - delete it.

     

    After the clean up, go into WIndows Control Panel, select Default Programs, Associate a file type or protocol with a program and then for the first file extension use "Browse" to find the PhotoshopElementsEditor.exe and select it  (mine was at C:\Program Files (x86)\Adobe\Photoshop Elements 11).

     

    Afterwards, you need to do this for each additional file extension you want to link with PSE 11, but you can pick it now from the Recommended Programs list

    Since I only use raw and JPEG, I only needed to change this for .cr2 and .jpg - you may need others as well...

     

    If you are not sure which program (Organiser or Editor) is now shown under the "Recommended Progams" list when you use "open with" from Explorer? 

     

    Photoshop Elements Organiser

    Adobe Photoshop Elements 11

    Adobe Systems, Incoporated     <====== note the comma after Systems

     

    Photoshop Elements Editor

    Adobe Photoshop Elements 11

    Adobe Systems Incoporated      <====== note the absence of the comma after Systems

     

     

    Hope this gets you working more productively....

     

     

    Chris - IT support for www.photo2m.ch

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (1)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points