Skip navigation
algrom77
Currently Being Moderated

Strange line between object and stroke when Stroke is Outside

Jan 5, 2013 10:34 AM

Tags: #line #stroke #cs6 #outside #indentation #firework

Hello.

 

I have FW CS6.

When i use stroke for nonrectangular objects (for circle and etc.) and make it "Align Stroke to Outside" then there appear light annoying line betwen object and stroke line. Also this line saves in all projects (PNG, JPG and etc.) It's clearly visible only when the background and stroke are dark colors.

 

I saved picture of the line. It appears only on the "Align Stroke to Outside".

 

Stroke line.png

 

Is it some sort of bug in FW? Is it possible to fix someway?

 

Thanks in advance.

 
Replies
  • Currently Being Moderated
    Jan 5, 2013 5:39 PM   in reply to algrom77

    Holy moly! There's an aspect to stroke rendering here that I've just never noticed before.

     

    If you soften the Edge setting of a stroke when it's center-aligned, you'll see both inside and outside of the stroke soften or feather. But if you set the stroke alignment to outside or inside, only one side of the stroke will soften; the other side will be anti-aliased, almost as if that side is being rendered with the use of a mask. You can really see it if you remove the fill:

     

    strokeAlign.gif

     

    So what you're noticing in your example is the point or line along which two anti-aliased, semi-transparent edges are meeting: the fill and the stroke. And their point of overlap is not being intelligently coordinated in any way by Fireworks. So semi-transparent portions remain at their juncture, and the background shows through.

     

    I think the simplest solution is to use a center-aligned stroke and adjust any object and stroke dimensions accordingly. You could also try selecting "Fill over Stroke" within the Stroke Options accessible from the bottom of the Stroke presets dropdown menu: This way, you can make a center-aligned stroke look more like an outside stroke, without the semi-transparent gap. Finally, I think that the Stroke effect available within Photoshop Live Effects (at the bottom of the Filter effects menu) somehow avoids the "gap" problem altogether, no matter what stroke alignment is used. So it's another option to explore.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points