Skip navigation
Currently Being Moderated

Premiere Elements 11 - Organizer - Missing thumbnails

Jan 6, 2013 9:07 AM

Tags: #optimizer #video_thumbnail

I have downloade some video files from my Canon HF S100 using Organizer.  The file format is .MTS.  The data files were downloaded into a named folder rather than the default suggested by Organizer.  I used a new Catalogue and loaded the entries into two Albums under the top level (i.e., I did not create an Album Category).  Initially few of the files had a thumbnail.  I tried Optimizing the Catalogue and that produced a few more.  I then highlighted the group still without a thumbnail and tried Update Thumbnail.  This produced a few more.  However ther are still 6 files for which I cannot get a thumbnail to appear despite repeated running of Optimize and Update Thumbnail.  Is there anything else that I can try?

 
Replies
  • Currently Being Moderated
    Jan 6, 2013 1:50 PM   in reply to NewToPremiereElements

    What operating system are you using?

     

    The Mac version sometimes will not show thumbnails for certain file formats.

     

    If you are using the Windows version, have you ensure you have the latest version of Quicktime installed?

     

    In either event, have you started a new project with this video as the first clip on the project timeline? The Elements bundle will not download  many components until it needs them in a Premiere Elements project.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 8, 2013 10:32 AM   in reply to NewToPremiereElements

    As I said, starting a new project and adding one of those files to your timeline will often cause the program to download the necessary components and make your file visible in the Organizer.

     

    It doesn't always work. But it should work for virtually all major camcorder formats.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 15, 2013 11:32 AM   in reply to NewToPremiereElements

    I don't know if you were able to sort this out but what you need is the appropriate Codec installed. If you are using Windows 7, scour the WEB for the Windows 7 Codec pack. This will install the appropriate MTS extension codecs you require. I had the same issues.

    This is the one I used: http://download.cnet.com/Windows-7-Codec-Pack/3000-13632_4-10965840.ht ml

    This should do the trick. Lyndon

     

    PS. You will have to 'update thumbnails' once in Organiser and the Codec App has run [and PC subsequently restarted].

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points