Skip navigation
BSTsteve
Currently Being Moderated

AVI file incomplete on import to Premiere Pro CS5

Jan 8, 2013 8:50 AM

For the past week I have been working with video content created in Camtasia and exported out of Camtasia Studio as AVI files using the Camtasia codec (TechSmith Screen Capture Codec). I then import the footage into Premiere Pro CS5 where I combine it with other elements. I had no problems with this until yesterday when I attempted to import an 18 minute long video created in Camtasia. The video exported fine and I am able to play it in full using Windows Media Player, but when I import it into Premiere, the video is only 2 minutes 38 seconds long (the first 2:38). I have attempted to re-export the video out of Camtasia Studio and attempted to re-import the footage into Premiere several times now, but the result is always the same. Premiere will only import the first 2:38.

 

I am on a PC running Windows 7 and Premiere Pro CS5. Not sure what other info might be helpful. Any insights would be greatly appreciated.

 
Replies
  • Currently Being Moderated
    Jan 8, 2013 8:55 AM   in reply to BSTsteve

    We get a lot of folks here with TechSmith problems.  The only thing I can suggest is not to use it.  Others may have more helpful suggestions.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 8, 2013 9:45 AM   in reply to BSTsteve

    I have encountered the same, though not with Camtasia footage. I have never discovered exactly what contributes to the Duration being missed, but did find a workaround, though an odd one.

     

    In my case, the files have been DV AVI's, via conversion from other formats, and PrPro misses the Duration of some, though not all. I found that if I Imported those problem files into Adobe Premiere Elements, then Exported them to the exact same format/CODEC, DV-AVI, those resulting files would Import into PrPro perfectly, and the Duration would be correct. Why? Never found the reason, or why seemingly identical files worked differently.

     

    I can only guess that something is incorrectly formed/written in the offending files' headers, and PrElements corrects that. It has never failed to see the correct Duration.

     

    Sorry that I do not have a better suggestion, other than, it happens to me too.

     

    Good luck,

     

    Hunt

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 8, 2013 11:08 AM   in reply to BSTsteve

    Instead of using the Techsmith codec, install Lagarith and save your recording with this codec.

    Premiere has no issues with Lagarith.

    I am still using Camtasia Studio 3 with Lagarith.

    http://lags.leetcode.net/codec.html

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 9, 2013 3:40 AM   in reply to BSTsteve

    After you have done your recording then save as avi with Lagarith.

    This option is in the Camtasia Recoreder Tools options / General

    Under Streams you set the codec. Give it a spin.

    The Camtasia Studio 3 does not work on my pc, so I cut the video on the timeline.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 8, 2013 2:45 PM   in reply to Ann Bens

    Ann,

     

    Thank you for that. It was a workflow that I had not considered for my case, as usually the DV-AVI's are perfect.

     

    Will test, when I next encounter a problem one.

     

    Appreciated,

     

    Hunt

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 9, 2013 3:56 AM   in reply to Bill Hunt

    I do not understand your post.

    THis is about Camtasia and techsmith codec

    And not about dv-avi and Elements.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 9, 2013 8:24 AM   in reply to Ann Bens

    What I was explaining is that the exact same thing happens, with some other material. The symptoms are exactly the same, as what the OP is encountering. It appears that the same problem can exist beyond the TechSmith CODEC's - while they might be causing the issue in the OP's case, the behavior is not limited to the TechSmith material.

     

    From my investigations, it seems to be an improper file header, and PrPro's inability to fully extract the Duration information, and act on that.

     

    In both the OP's case, and in mine (different input material), it seems to be unique to only certain files, where many Import with the proper Duration, but not all of the files. Without doing a spreadsheet, I would guess that it happens to me only about 5% of the time, with 95% of the files Importing perfectly, with the correct Duration.

     

    In my case, seeing the same behavior, albeit with different soucrce material, I found commonality between the OP's issue, and what I have observed. That leads me to believe that there might be something wrong with the faulting files, that are not 100% unique to the TechSmith material.

     

    Hunt

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 29, 2013 4:50 PM   in reply to BSTsteve

    I think the best way to work around this issue is to extract the actual .avi files created by Camatsia. I had the same issue, and searched the web and here as well with hardly any luck, and managed to fix it on my own. Techsmith needs to place this workaround where other people facing the problem can access this solution.

     

    Simple open up the .camrec project in Camtasia Studio, then right click on the file on the Clip Bin then choose "Extract camrec contents."

     

    camtasia.jpg

     

    Then choose a folder where you would like the extracted files placed. It will extract the video and audio separately, along with some icons. From here just import the newly created .avi file into premiere and use that file instead, along with the audio file to accompany your vide. This will show the full lenght of the video and not just a portion. While this worked out for me, I am not sure it will work out for everyone. If this solution works for anyone, please let me know. I am using the latest version of Camtasia 8, and Adobe Premiere CS6.

     

    I found no reason to export as mp4, nor to export as .avi using the actual Camtasia Studio presets, or to install any other codecs x64 or other.

     
    |
    Mark as:
  • Currently Being Moderated
    May 29, 2013 8:34 AM   in reply to Bill Hunt

    I am having the same problem with .avi files created with GoPro Cineform software.  I take an .avi that is over 17 min and plays the full duration with Windows Media Player and every time I import it to PP CS6, it only imports a little over 3 minutes.  Very frustrating.  I would love to know how to import the whole file to PP...

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 17, 2013 9:45 AM   in reply to LightPainting2

    I too am having the same issue with .avi files created with GoPro Cineform software. After converting a batch of raw MP4s to .avi files in Cineform, 4 out of 21 files showed up in Premiere Elements 11 with shortened durations. The original files were between 8'19'' and 10'33'' duration. The other files imported fine.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 10, 2014 1:45 AM   in reply to Raycoteknik

    Same issue. I previously used  NeoScene to convert .mov files from a Canon 5d mark ii to the easier to edit with Gopro Cineform .avi format in Premiere Pro CC. They used to work fine but now Premiere only recognizes a very small part of the file. The first 18 seconds of an 8 minute file.

     

    I tried importing the file to a new clean scene and the problem remained.

     

    I need to be able to work with this footage. Somehow Premiere is no longer able to properly read clips it used to be able to read.

     

    I would like to hear something from Adobe on this issue.

     

    EDIT: I just updated my GoPro software to 2.0 and the problem was instantly solved. The same might apply to TechSmith.

     

     

    EDIT 2: Upon rendering the edit I discovered that while the entire length of the clip was represented it in fact stopped playing new frames at the same frame as it had before. So no luck. Updating GoPro Cineform made the length of the file display correctly (7min) but did not actually let me play the file beyond the first 18 seconds - it just showed the same frame.

     

    I deleted all preview files and cleaned Media Cache files (under media/preferences) - this didn't help.

     

    Finally I made the file offline, closed Premiere, changed the file name and re-opened Premiere. Then I right clicked over the file in the Project window and chose replace file to re-connect. The file finally came in correctly. I've now rendered it and it runs through the entire 7 min.

     

    Message was edited by: ereitz

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (1)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points