Skip navigation
MelEmJay
Currently Being Moderated

Device driver error msg at startup-get white screen w/audio during playback

Jan 19, 2013 3:24 PM

Tags: #error #premiere #playback #elements #display #screen #10 #message #white #driver

PE10 has been working fine until today.

Upon startup I get an error message saying my display driver is incompatible.

I checked the driver in Windows 7-it says the driver is up to date and working fine.

When playing back a video clip I'm editing in PE10, I get a white screen in the playback area with the correct audio. When I pause the playback, the video image appears. Play = white playback screen.

 

I have

-checked the display driver

-rolled my computer back to an earlier restore point

-uninstalled and reinstalled PE10

-turned off my firewall

 

Any other suggestions to try?

 
Replies
  • Currently Being Moderated
    Jan 19, 2013 3:32 PM   in reply to MelEmJay

    Have you manually gone to Windows Update and ensured you installed even the updates that don't install automatically?

     

    What is the model number of your video card? Have you gone to the ATI or nVidia sites and downloaded the latest version? (People always brush off this suggestion, but it does fix this more often than not!)

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 19, 2013 3:50 PM   in reply to MelEmJay

    You do not describe your computer, so this MAY not apply to you

     

    Dual video laptop problems

    -http://helpx.adobe.com/premiere-pro/kb/error---preludevideo-play-modul es.html

    -http://forums.adobe.com/thread/1001579

    -Use BIOS http://forums.adobe.com/thread/1019004?tstart=0

    -link to why http://forums.adobe.com/message/4685328

    -http://www.anandtech.com/show/4839/mobile-gpu-faceoff-amd-dynamic-swit chable-graphics-vs-nvidia-optimus-technology/2

    -HP Fingerprint/Password conflict http://forums.adobe.com/thread/911575

    -Mac Utility http://forums.adobe.com/thread/1017891?tstart=0

     

    These questions below may be for a different product... but the information you need to supply is the same, for the products you use

    .

    More information needed for someone to help... please click these links and provide the requested information

    -Information FAQ http://forums.adobe.com/message/4200840

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 19, 2013 5:07 PM   in reply to MelEmJay

    Go back to http://forums.adobe.com/community/premiere_elements and type

     

    incompatible display driver

     

    in the line just below Ask a Question to read other discussions

     

    You may need to click See More Results below the 1st listing to find a discussion that helps

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 20, 2013 11:48 AM   in reply to MelEmJay

    Great news.

     

    For others, who come upon this thread, with the same problem, they will likely be helped by this article: http://forums.adobe.com/message/4943624#4943624

     

    Good luck to all,

     

    Hunt

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points