Skip navigation
Currently Being Moderated

Printing Problems with Elements 11

Jan 20, 2013 4:11 AM

I have just started with Elements 11. At first it printed ok. but when I tried to set it up with Elements to control the printer ( Epson SX400 ) I keep getting a message saying that ICC Profile is invalid, and the program will not let me print at all. My computer O/S is Windows 7, 64 bit.  the Printer driver is one supplied by Epson EU to run the O/S.

 

I have tried returning to Printer controls settings, this has not worked. I have tried to print on a different printer (Brother HL-2250DN Laser Printer) this will not print either.

 

I have tried to print on my old Serif PhotoPlus program this is OK. So the problem is in my settings for Elements 11,

 

Do I Need to Reinstall the programme

 

Andy H

 
Replies
  • Currently Being Moderated
    Jan 20, 2013 7:05 AM   in reply to AKH1947

    Ask in the PSE forum.

     

    Mylenium

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 21, 2013 1:22 PM   in reply to Mylenium

    Moving this discussion to the Photoshop Elements forum.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 21, 2013 11:51 PM   in reply to AKH1947

    Which profile you are selecting in Printer Profile ? This information would help.

    It might possible that the printer profile you are selecting to print is corrupted. 

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 22, 2013 2:18 AM   in reply to AKH1947

    I would explain you the steps you need to follow if you are giving control to Photoshop Elements to manages color.

     

    Step 1- Select your printer and then Click More Options at the bottom left of the Print window.

    Step 2- No click on Color Management tab.

    Step 3- Now from "Color Handling" drop down select Photoshop Elements Manages color. As you select this option "Printer Profile" drop down will become enable.

    Step 4- If Image Space is sRGB then select sRGB profile from Printer Profile drop down else select Adobe RGB.

    Step 5- Click On Printer Preferences button. It will open your printer's preferences dialog.

    step 6- Now click on "Main" tab and then click Advanced button.

    step 7- Now under "Color Management" section please select No Color Management here.

    step 8- Click OK and come back to main Print dialog of Photoshop Elements.  Now click Print.

     

    Note -If you choose Photoshop Elements manages color, it is very important that you disable color management in your printer driver.Letting the application and the printer driver simultaneously manage colors during printing results in unpredictable color.

     

    Try with above written steps I hope it would help.

     

    Cheers !!!

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 22, 2013 9:34 AM   in reply to AKH1947

    Nice to hear that it works for you.

    Please mark this post as answered so others having similar issue can get benefit.

     

    Cheers !!!

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points