Skip navigation
MaxK81
Currently Being Moderated

Can't Tether Between LR 4.2 64bit and Nikon D7000

Jan 21, 2013 2:14 PM

Tags: #nikon_d7000 #lightroom_3.6 #tethered_capture #lightroom_4.2 #update_errors #lightroom_4.3

Hi all.
I was able to tether from the same camera, to the very same PC with the exact same cord when I had LR 3.
When version 4 came out and I updated I didn't had the need to tether. Now I've been hired to capture a promo for a fashion event, and wanted to bring my laptop along, so I could make sure everything goes great.


After 9 and a half hours of tinkering with 5 different cables, I haven't found why the hell LR 4 is not seeing my D7000.
I uninstalled the camera's driver from my PC and let the plug and play find it again, and it even tells me my D7000 is ready to use. It basically appears as another storage unit, but I can't tether it to LR 4.2. I even tried plugin the USB cord to 8 different USB ports. It's worth mentioning that since I installed LR 4, I've never had any problem with any other software. Hence, there hasn't been any O.S re installs or anything of the kind.

 

Before you ask me why I keep using v4.2 and haven't updated to 4.3 it's simply because I gave up on trying to install a 700+mb update that is broken. Tried the "Unblock" option from the ".exe" properties dialog, and nothing changes. Runned it as Admin, nothing. Cpy-pasted it to the root folder where 4.2 is currently installed (just in case), and still, no luck. I've grew tired of the installer telling me to free more space when there are 2.7 TB available for it to use.
So, leaving aside the update failure, I need LR 4.2 to let me tether with my Nikon D7000, just as LR 3 let me.

 

Any help is appreciated.

 

 

 

Thanks,

 

Max Kimmich

 
Replies

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points