Skip navigation
MargoToth
Currently Being Moderated

Save Ditamap As FM 11 book with components causing xrefs to disappear

Jan 26, 2013 8:45 AM

When we used the Framemaker option Save
>Ditamap As > FM 10 book with components, all of our cross references were maintained.

Now for some odd reason with Framemaker 11, all the cross references are
disappearing when you save as FM 11 book with components.

 

We are using our own defined cross reference formats, such as heading and Page #.


This is repeatable across several machines in our office, and we have the
lastest version of Framemaker installed.

Has anyone seen this, or does anyone have any ideas? I rechecked this on a machine that has Frame 10 and it works fine there. I noticed a template folder was added to Framemaker 11 and I am wondering if we need to import our cross references formats into it.

Thanks in advance.
Margo

 
Replies
  • Currently Being Moderated
    Jan 26, 2013 9:12 AM   in reply to MargoToth

    Hi Margo,

     

    I believe you've struck upon the solution.

     

    When working with DITA, your XML files get imported into a series of template files each time you open them. I'll wager that if you import the xref formats into those template files (make a backup of the templates folder, just in case...) that you'll get what you're looking for.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 12, 2013 7:23 AM   in reply to MargoToth

    Hi,
    what setting was that, can you explain your solution? I am having a similar problem.

     

    Robert

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 12, 2013 7:44 AM   in reply to MargoToth

    Thanks for the fast response. The template you mention is used for saving as composite documents. I am having problems with that and have shifted to saving as book with components (as you did in your original post). When I save as a book then my correct template (which also has all xref styles) is used, but yet the xrefs are still missing in the output.

     

    I guess that my problem is different from yours then after all.

     

    BR
    Robert

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 12, 2013 8:05 AM   in reply to R_Sem

    Yes, the ditafm-output.ini (in the userdata\roaming\blah blah directory is used when saving an ditamap (or other xml structure) to .book with FM components.

     

    As part of a 1-hour Adobe webinar on DITA to PDF, I'll be showing that workflow in a webinar in just under 2 hours. The registration link is

    "How to" webinar: "FrameMaker DITA output to PDF" adobe.ly/14ZzI3E

     

    I believe you will also be able to use that link to access the recording. If not, feel free to contact me for the link.

     

    -Matt

     

    Matt R. Sullivan

    co-author Publishing Fundamentals: Unstructured FrameMaker 11

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 12, 2013 8:08 AM   in reply to R_Sem

    Hi Robert,

     

    We save our bookmaps as a book with components and in the ditafm-output.ini General Options section, as Margo pointed out above, for the CompostiteDocTemplate_1.2, we still use the ditabase.template.fm. (CompositeDocTemplate_1.2=ditabase.template.fm).

    Maybe it shouldn't, but it works for us.  

     

    If you haven't yet tried it, give it a try.

     

    Marsha

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 12, 2013 8:10 AM   in reply to mattrsullivan

    Thanks that looks very interesting.

     

    My problem is that xrefs that are valid in the DITA sources (they are resolved correctly when loading individual XML files) are not converted when I save to an FM book with components.

     

    In the generated FM files, they look like this. As you see there is a problem with the outputclass, even though this is the correct xref name (it exists in the output files with this name).

     

    Robert

     

    FM_link_error.png

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 12, 2013 8:19 AM   in reply to R_Sem

    Oh yes, that brings back memories, and those memories aren't good ones. We had the same exact issue.

     

    I know I'm repeating myself and it probably doesn't make sense, but try what I suggested before if you haven't already tried it. I'm speaking from experience.

     

    Marsha

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 12, 2013 8:25 AM   in reply to Marsha Lofthouse

    Hi Marsha,

    thanks for the hints, just to be sure in which folder do you store the ditabase.template.fm file with your xref definitions?

     

    I am using DITA 1.1 here so I edited the corresponding CompositeDocTemplate_1.1 setting. I placed my templates into the Structure\xml\DITA\outputTemplates folder. It seems however that it is not the correct location yet.

    Robert

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 12, 2013 8:32 AM   in reply to R_Sem

    Where you store you templates is up to you but you must call that out in the ditafm-output.ini file as well.

     

    In the General Options section, find this line:

    TemplateDir=$STRUCTDIR\xml\DITA\outputTemplates

     

    I changed mine to:

    TemplateDir=$STRUCTDIR\xml\DITA_1.2\app\technicalContent\template\Book _Templates

     

    HTH,

     

    Marsha

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 12, 2013 11:28 AM   in reply to Marsha Lofthouse

    Marsha, you're a charm! I changed the path to the xml\DITA_1.2\app\technicalContent\template\Book folder and stored my template there, now it works. The template was simply ignored in the original outputTemplates folder even with the path set correctly.

     

    So although I am using the DITA 1.1 mode, storing a template in the DITA 1.2 directory and adjusting the path in the ditafm-output.ini file is required to fix the xrefs.

     

    Sometimes working with Fm is like mastering black magic.

     

    Robert

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points