Skip navigation
williambub
Currently Being Moderated

Random Accented Characters Appearing

Jan 28, 2013 11:32 AM

I opened a document created by a coworker on this same machine several months ago. There are lots of random accented charcters taking over the document. They are in place of spaces, in place of other letters (randomly, not in a way that reads/makes sense - a capital, accented A doesn't replace an A, etc.) and scattered throughout. I think the issue is confined to one character style in particular. There is no easy way for me to know what each title is supposed to read as...

 

For instance, the screen shot below is supposed to read: Prenatal / Peripartum / Neonatal

Screen shot 2013-01-28 at 1.30.25 PM.png

Any ideas?

 
Replies
  • Currently Being Moderated
    Jan 28, 2013 12:06 PM   in reply to williambub

    That's typical of the kind of character remapping that used to be rampant when moving text between PC and Mac. What's the font?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 28, 2013 12:49 PM   in reply to williambub

    You can check the file history by holding down the Cmd key when you choose About InDesign fom the InDesign menu.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 28, 2013 1:08 PM   in reply to williambub

    I think the issue is confined to one character style in particular.

     

    What is defined in that one character style?

     

    Peter mentioned that it would indicate cross-platform text conversion issues because the ancient & venerable MacRoman encoding a) doesn't map onto ASCII perfectly, meaning that it doesn't map onto Unicode perfectly either in the plain-vanilla latin-script area, and b) MacRoman crops up on Macs in unexpected areas. Cross-platform conversion would be an expected area to find this, but your coworker could have done any one of a number of things to cause an unexpected character-encoding issue.

     

    Did you get a missing font warning when you opened the file? Are there any brackets around the font name if you select one of the accented characters? If you set the View mode to Normal (View -> Screen Mode -> Normal) are the damaged entries highlighted in pink? They might not be if Edit -> Preferences -> Composition -> Substituted Fonts is unchecked.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 28, 2013 1:44 PM   in reply to williambub

    Without changing anything else, try this: in the character style, DISABLE Ligatures. See if that does any good; if not, go ahead and enable them again :-)

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 28, 2013 1:50 PM   in reply to [Jongware]

    Interesting. Why would you expect a ligature in an ata or rtu combination? And what about the /?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 28, 2013 2:13 PM   in reply to Peter Spier

    Um. Only makes sense if it actually works ...

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 28, 2013 2:19 PM   in reply to [Jongware]

    OK. Bu there must have been some cog spinning in tha back or your brain to think it was a potential fix.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 29, 2013 1:39 AM   in reply to Peter Spier

    Sorry, not a fix per se, more by way of diagnosis. If this clears the problem, there are three possibilities:

     

    1. there are duplicates of this font installed, with different version numbers.

    2. an older version of the same font was used but ID's font cache hasn't been updated.

    3. the system font cache needs to be cleaned.

     

    (1) can be checked using Find Font (check if the path is what you expected) and/or a global, system-wide search of likely font file names.

    (2) requires deleting the AdobeFnt*.lst files, so ID's cache can rebuild itself -- is there a permalink somewhere to this procedure?

    (3) requires resetting OS X's own font cache -- also not something I do on a regular basis, wasn't there a tool somewhere?

     

    -- the last time I got similar effects, I had a duplicate font somewhere.

     

    The problem occurs because ligatures are not, as one would think, linked to character names and themselves referred to by name ("f" and "i" make "fi", "f"and "o" make "fo", etc.), but rather by glyph index number -- the logical glyph order inside the font file. The OpenType feature that creates ligatures from separate characters doesn't look up names, but mere switches "glyph #5" and "glyph #10" with "glyph #25". Hence, if this system gets corrupted by invalid font files or out-of-date caches, you get random replacements of random characters with yet other random characters.

     

    If merely switching off ligatures appears to "fix" things, the OP might be tempted to say, 'oh now that works I'll leave it this way'. DON'T. There is something wrong with this font, and even if it seems a good fix, you are bound to run into other font related problems later on.

     

    .. then again, all of the above is purely based on the premise that switching off ligatures actually changes something. We'll have to wait for the OP to try.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 29, 2013 2:35 AM   in reply to [Jongware]

    See how helpful that was?

     

    (2) -- no permalink. Just delete all adobefnt*.lst files where * is a two-digit number.

     

    (3) -- I believe Onyx, or perhaps Cocktail (Mac utilities), will clear the system caches easily. You can do it without them, but htey make it easier. David Dilling from Markzware posted a helpful video on YouTube.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points