Skip navigation
WRC IAO
Currently Being Moderated

I can't access ColdFusion 10 Admin

Feb 5, 2013 10:35 AM

I installed ColdFusion 10 on a Windows Server 2008 R2 a couple months ago with no problems. I have been testing the server since without it plugged into the network and have had no problems. Yesterday I plugged it into our network and everything worked like a charm with the exception of SMTP. I was troubleshooting SMTP and finally realized this morning that I needed to set the SMTP in ColdFusion. I tried to login to the ColdFusion Administrator and it said it was an "Incorrect Password". I was able to successfully login to the Admin yesterday multiple times but not today.

 

I have run the passwordreset.bat and selected "1" then typed in the new password and confirmed the password then the popup went away. I restarted the ColdFusion service then closed the browser and reopened the browser and typed the password and still received the "Incorrect Password".

 

I also went into the "neo-security.xml" file and changed the "admin.security.enabled" boolean value from "true" to "false" to get into the Administrator without a password. I was able to login to the Administrator without a password but when I made a change and hit "Submit" it didn't accept the change and it gave me an error:

"There was an error accessing this page, check logs for more details.

 

The log file showed the following error:

"There was an error while verifying the token. Either the session timed out or un-authenticated access is suspected."

 

I'm not really sure what else to do at this point besides re-install ColdFusion which is my last resort on a production server. If anyone has any possible solutions please let me know.

 

Thanks,

Josh

 
Replies
  • Currently Being Moderated
    Feb 6, 2013 6:51 AM   in reply to WRC IAO

    Hi Josh,

     

    Can you please "admin.security.enabled" boolean value from "false" to "true" and reset your currect browser, also try to access the administrator from a different browser and from the different machine.

     

    Please let me know that fixes the issue.

     

    Thanks

    Priyank

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 6, 2013 11:13 AM   in reply to WRC IAO

    Thanks for your response.

     

    Can you please try to access the ColdFusion Admin in your workstation by using the machine IP address instead of Localhost or 127.0.0.1 and check if that will help.

     

    Thanks

    Priyank

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 23, 2013 2:50 PM   in reply to Priyank Srivastava

    That did not work.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 23, 2013 9:01 PM   in reply to trubel

    Hi,

     

    Are you trying to access this from IE10? Can you mail us request/response header?

     

    Thanks,

    Shilpi

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 26, 2013 8:35 PM   in reply to Shilpi Khariwal

    At further investigation as Shilpi recommended I send the network request/response.   I found that the URL path I was using http://localhost:8888/cfusion/CFIDE/Administrator/

     

    In reality.  the Administrator folder that use to be capitalized is not lower case "administrator"  so the correct path is http://localhost:8888/cfusion/CFIDE/administrator/  This is a weird error since the page loads but the configuration enter.cfm can not locate sha1.js file. Since JavaScript is case sensitive this must be the reason.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 26, 2013 8:41 PM   in reply to trubel

    Hi Trubel,

     

    Can you confirm if now Administrator is working for you?

     

    Thanks,

    Shilpi

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 24, 2013 2:16 PM   in reply to Shilpi Khariwal

    Turing on "static Content" under the add windows features "common HTTP features" fixed it for me.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 11, 2013 1:33 PM   in reply to WRC IAO

    I have the same problem. Tried everything above but none works.

     

    Please help.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 11, 2013 2:02 PM   in reply to dhaneht

    Hi,

     

    Can you please try to access the ColdFusion admin from a different machine.

     

    Regards,

    Priyank

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 11, 2013 2:55 PM   in reply to WRC IAO

    I did tried on 3+ machines and all browser I can get (IE, FF, Chrome, Safari) with no luck.

     

    However, I solved the problem. For some reason, I start the IIS "Default Web Site" which makes http://localhost works. Then I browse to localhost/CFIDE/admistrator and everything works!!! But it works for localhost only, if I put the real IP or the real url, it doesn't work.

     

    Anyone has any clue?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 12, 2013 12:50 PM   in reply to dhaneht

    I think the default setting in the CF 10 Administration is for localhost access only and I would not recommend changing this setting. A vast majority of CF hacks are related to CFIDE/Administrator access. I recommend going further and removing CFIDE as a virtual directory on your sites and create a new one that points to an empty directory then add a scripts virtual directory under it that points back to the original CFIDE/scripts directory. There are one or more threads on this site that describe the process.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 13, 2013 11:06 PM   in reply to Steve Sommers

    Thank you so much. I will do per your advise.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 15, 2013 3:55 PM   in reply to WRC IAO

    I had the same issue accessing cfadmin from the browser on the server.  For me the issue was that the browser couldn't download and exeute the script "/CFIDE/administrator/sha1.js", needed for the cfadmin login form to work, due to IE running in protected mode by default on Windows Server.

     

    My solution was to add the server URL to the "trusted sites" zone in Internet Explorer.

     

    Hope this helps.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 15, 2013 4:04 PM   in reply to SethBienek

    Or you could just install an actual browser like Google Chrome.

     

    DEATH TO EXPLORER!!!

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 15, 2014 10:24 AM   in reply to SethBienek

    Thanks. Turing on "IE Enhanced Security Configuration" was aslo preventing me from logging into the adminstrator and giving me the Incorrect Password message. Simply turning it off temporarily whenever I need to logon to the Coldfusion administrator fixed it for me.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 18, 2014 7:24 AM   in reply to WRC IAO

    OS: OSX maverics

    Browser: Chrome/FF 27.0.1/Safari 10

    Coldfusion 10: Installed within Apache

     

    I had tried all the above and went back to investigate my mod_jk after  i read the post from  tubel.

     

    My solution was the path to my CFIDE had the 'coldfusion10' spelled 'Coldfusion10'. I changed to lower case 'C' and my CF was back with a bang!!

     

    Hope this solves problem for someone out there.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 9, 2014 10:47 PM   in reply to WRC IAO

    To the original poster above, reporting that he gets an error once logged into the Admin, where certain operations give him "There was an error accessing this page, check logs for more details.", there is indeed a workaround for that issue.

     

    Basically, it's a duplicate cookie problem for the CF session cookie(s). There are in fact a few solutions to that, and I discuss the problem and those workarounds in a blog entry I just created:

     

    'CF911: Solving problem in #ColdFusion Admin getting "error accessing this page" on certain actions'

    http://www.carehart.org/blog/client/index.cfm/2014/4/10/CF_Admin_error _about_error_accessing_this_page

     

    Hope that may help some readers here.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (1)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points