Skip navigation
drzuco
Currently Being Moderated

LR4, MacOS Can't delete files "ag.library.expandAllStacks" Error

Feb 9, 2013 2:39 AM

Tags: #error #delete #lightroom4 #lr4.3 #lightroom4.3 #performcommanddesc

Hi I have LR 4.3, Camera Raw 7.3

Until yesterday I was able to delete pictures, using the contextual menu or the delete key. I got the message asking me if I wanted to delete them from disk or from the catalog.

But now, that popup message doesn't appear. The picture is not removed, just nothing happens.

 

I checked the logs and this is the error message:

 

performCommandDesc could not perform command ag.library.expandAllStacks (Command was disabled.).

 

I uninstalled LR moving it to the trash. Then I deleted the com.adobe.Lightroom4.plist and I also removed the folder ~/Library/Application Support/Adobe/Lightroom.

I rebbooted the machine and installed it again. But the issue is still there, with the same error message.

 

I verified the disk and checked file permissions.

I also tried to use another catalog from a backup.

 

Nothing, same error.

 

One anusual thing that I did before the error was to install the "HDRsoft Merge to 32-bit HDR Plug-in for Lightroom - Version 1.0"

I removed it but the error was still there. After the re-install I didnd't install that plug-in again so if it was the problem, it shouldn't be after the clean installation that I did again.

 

Please help!

 

Machine Specs:

Man mini server mid 2011

2GHz Intel core i7

Ram: 8G

Graphics: Intel HD Graphics 3000 512MB

OSX: 10.8.2 (12C60)

 

Thanks.

 

P

 
Replies
  • Currently Being Moderated
    Feb 9, 2013 2:59 AM   in reply to drzuco

    Try,in the Lightroom preferences dialog, General tab click on "Reset all warning dialogs".

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points