Skip navigation
greenpaint53
Currently Being Moderated

Vector symbol appears on 3D surface, but label won't?

Feb 9, 2013 5:03 PM

A label that I've created in Illustrator isn't mapping onto a can in 3D revolve - can anyone tell what the problem might be?

 

1. Traced the side of a can using the pen tool, and turned it into a 3D object using revolve (NOTE: I haven't applied any stroke to it, just a white fill - otherwise, Map Art wouldn't even open, it would just say " Artwork produced no surfaces for artwork mapping.")

 

2. Dragged the  label into symbols

 

3. Clicked on the side of the can, opened 3D revolve, and clicked preview

 

4. Clicked Map Art, selected the appropriate surface

 

5. Selected the label from the symbols, scaled it, and clicked preview

 

 

When nothing happened, I tried everything:

     It wouldn't show in Invisible Geometry, so it can't be on the inside of the surface...

     When I tried Shade Artwork (slower), the whole program just shut down right away...

              

Interestingly, when I selected a vector symbol, it appeared on the surface perfectly...any thoughts on what that could be?

 

 

Thank you!

 
Replies
  • Currently Being Moderated
    Feb 10, 2013 12:51 AM   in reply to greenpaint53

    What system? What version of AI? Screenshots?

     

    Mylenium

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 10, 2013 3:39 AM   in reply to greenpaint53

    It sounds as if you are doing everything right.

     

    Does the symbol of your label work properly in other surroundings?

    For example did you try putting it onto a plain coloured background?

     

    Does your label contain a pixel image? If so, is the image embedded?

    If not, it should be.

     

    Try trashing the symbol of the label and re-doing it.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 10, 2013 5:42 PM   in reply to greenpaint53

    If you have a properly made symbol and it just isn't showing up as it should after you've mapped it to your 3D form, then look closely for problems with the 3D form.

     

    Slight misalignments or other irregularities can cause the symbol to map to the inside of the form instead of the outside. a stroke on the form can cause this as well so I usually recommend to my students to only use fills and no strokes when working with Illy's 3D feature.

     

    If you post your file we could check it, otherwise you'll need to troubleshoot it for those issues.

     

    Hope that helps,

     

    Michael

    http://www.learnadobesoftware.com

     

    Sent from my iPad

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 11, 2013 9:25 AM   in reply to greenpaint53

    can you post the file?

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 11, 2013 9:50 AM   in reply to greenpaint53

    Wel, the screenshot shows a void in the top of the can where you are suddenly looking into the inside from the outside. That suggests a problem with the construction of the original vector drawing. You might have self-intersecting angles. Tweak the drawing. Make sure it uses only the fewest amount of points that it needs to hold your contours.

     

    It also appears from the screenshot that the can isn't drawn completely. The vector outline suggests the top shoulder of the can is not connected physically to the lower half. That would be problematic as well. Odds are the symbol is flipping onto another surface, either in the can or on the edge of a stroke where it can't really be seen at all.

     

    So, my advice is to revisit your vector outline, have a complete shape for the can base and bottom, a rectangular form for the upper lip and top, group them and re-revolve them.

     

    hope that helps

     

    Michael Riordan

    http://www.learnadobesoftware.com

     

    Message was edited by: Michael Riordan should say "group" not "join"

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 11, 2013 9:57 AM   in reply to greenpaint53

    I didn't even notice the label, my bad.

     

    It may well be the gradient. Illy's 3D hates gradients. Should work in theory but often does not. Try your symbol without the gradient and see if it works

     

     

    Michael

    www.learnadobesoftware.com

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 11, 2013 10:05 AM   in reply to greenpaint53

    Maybe the label is too complex. Try and convert it to pixels and see if it works.

     

    You could also try to move the "Perspective" slider in 3D dialog box by 1 or 2 degrees.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points