Skip navigation
Currently Being Moderated

Can I prevent certain words from being hyphenated or split?

Feb 12, 2013 6:30 AM

I have a client that is real picky about the title of their business which is 2 words from being separated with the first word on one line and the next word on the line below.  There are other times like names of people that will get hyphenated and they dont want that either.  I know I can turn off all hyphens but I still want them, just not with certain words.  Is there a way to control both of these?

 
Replies
  • Currently Being Moderated
    Feb 12, 2013 6:37 AM   in reply to kellyjaye1

    Select the word(s) you don't want to break. Apply the "No Break" attribute from the Control panel menu or the Character panel menu.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 12, 2013 6:59 AM   in reply to kellyjaye1

    Choose Edit/Spelling/dictionary. Type the word in the first line,  type an hyphen or tilde BEFORE the word, add the word to the dictionary.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 12, 2013 9:58 AM   in reply to kellyjaye1

    Make a new character style with No Break its only attribute. Open the Find/Change dialog and type the company name in the Find field. In the Change Format field, set your No Break character style. Set the search scope to Document and click Change All.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 12, 2013 10:49 AM   in reply to John Mensinger

    Hello,

     

    Just to throw in another option, I sometimes do this through find and change.

     

    I just type the word in the Find what field that I don't want to hyphenate,  and then I go to the change format area on the bottom of the dialog box and click the no break check box in the basic character formats area,  and then I change all in the document.


    Hope that helps too..

    babs

     

    Screen shot 2013-02-12 at 9.41.32 AM.png

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 12, 2013 11:01 AM   in reply to iBabs2

    Too much steps, every document again. Like I said: add the word once to the dictionary of the required language with a tilde before the word, it really works, and it works fine!

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 12, 2013 11:03 AM   in reply to F van der Geest

    Oh, and do not forget to click on ADD and be sure your oaragraph that contains the word has rhe same language as the dictionary you added it to...

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 12, 2013 11:17 AM   in reply to F van der Geest

    I agree with F can der Geest 100%. My option was just for a random situation that comes up. Quick and painless for a 1 shot deal.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 12, 2013 1:09 PM   in reply to kellyjaye1

    > .. There are other times like names of people that will get hyphenated and they dont want that either.

     

    For that you can disable Hyphenate Capitalized words in your paragraph styles.

     

    But don't use this if you have to typeset German text. In German, *all* proper nouns are capitalized -- and "Fahrvergnügen" isn't the longest one by far.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points