Skip navigation
Currently Being Moderated

Photoshop CS6: soft brush suddenly looks pixelated instead of smooth

Feb 16, 2013 6:51 AM

Tags: #brush_problems #photoshop_color

I've never had this problem before. I'm using the standard soft round brush to blend colors, which has always given a smooth effect, but now it suddenly looks all pixelated. The brush strokes also appears in rings instead of a smooth gradient. It looks as if the picture has been sharpened too much or saved in bad quality. I've already tried things like changing the brush settings, deleting photoshop preferences, increasing the RAM assigned to photoshop, but nothing works. Does anyone know what caused this? It's driving me insane! I get the same problem in an older version (Photoshop CS), so perhaps it's not photoshop itself?

 
Replies 1 2 3 Previous Next
  • Noel Carboni
    23,526 posts
    Dec 23, 2006
    Currently Being Moderated
    Feb 16, 2013 8:09 AM   in reply to Caroline Vanlint

    Sounds like a problem with your display settings on your system, or possibly a problem with your monitor.

     

    Does it show in a screen grab?

     

    If so, please post a screen grab here so others can see exactly what you're seeing.

     

    Please also describe your system (hardware, OS, etc.).

     

    -Noel

     
    |
    Mark as:
  • Noel Carboni
    23,526 posts
    Dec 23, 2006
    Currently Being Moderated
    Feb 16, 2013 9:32 AM   in reply to Caroline Vanlint

    Everything looks smooth from here in your screen grabs (within my ability to tell - you've downsized the images).  This may imply you're having a monitor, cable, or (possibly) video card failure.

     

    Just to verify in the other direction, does this image look smooth to you or blocky and pixelated?  Check it in both your browser and Photoshop.

     

    SmoothGradientTestImage.png

     

    -Noel

     
    |
    Mark as:
  • Noel Carboni
    23,526 posts
    Dec 23, 2006
    Currently Being Moderated
    Feb 16, 2013 9:57 AM   in reply to Caroline Vanlint

    Were they looking at downsized copies, exactly as you posted here?

     

    -Noel

     
    |
    Mark as:
  • Noel Carboni
    23,526 posts
    Dec 23, 2006
    Currently Being Moderated
    Feb 16, 2013 12:32 PM   in reply to Caroline Vanlint

    The image you posted up above is MUCH darker than your photo.  And I can assure you the images above are downsized, possibly by photobucket, which may mask what it is you're trying to show.  Why not just attach them ot the posts here using the little camera icon?

     

    At this point I'm not even sure I'm perceiving what it is you're trying to point out, possibly because of terminology problems...  Posterization describes a "paint by numbers" appearance where instead of smooth gradients you see "blocks" or "regions" with all the same color - making kind of a "digital" appearance out of it.  Is that more along the lines of what you're trying to say?

     

    My best guess so far, and I have little confidence in it, is that maybe you have a miscalibrated monitor (set way too bright) and perhaps that is interacting with the fact that you're painting on an 8 bits/channel document.

     

    Have you tried using 16 bits/channel mode?

     

    -Noel

     
    |
    Mark as:
  • Noel Carboni
    23,526 posts
    Dec 23, 2006
    Currently Being Moderated
    Feb 16, 2013 1:08 PM   in reply to Caroline Vanlint

    Do you see the problem if you paint on a 16 bits/channel document?

     

    Given that you seem prone to making wide brightness changes (presumably with Curves or something), you'll want the extra accuracy and smoothness the deeper data format will provide.

     

    Perhaps you just weren't seeing the effect because of the nature of your prior work.  Working in limited bit depth isn't something that's just gone wrong, unless perhaps you were creating new documents in 16 bits/channel before without thinking about it and somehow your File - New dialog got switched to 8 bits/channel.

     

    -Noel

     
    |
    Mark as:
  • Noel Carboni
    23,526 posts
    Dec 23, 2006
    Currently Being Moderated
    Feb 16, 2013 1:47 PM   in reply to Caroline Vanlint

    Nice work.

     

    Just changing an existing 8 bits/channel image to 16 bits is not going to correct the posterization that has already occurred due to the quantization of color values into one of 256 luminance levels.

     

    You may have to use some smoothing tools such as the Blur Tool or maybe the Smudge Tool, or even just the Brush Tool again and brush over those spots  to clean them up.

     

    I'm afraid there may not be an easy fix for the places where it's happened already.

     

    -Noel

     
    |
    Mark as:
  • Noel Carboni
    23,526 posts
    Dec 23, 2006
    Currently Being Moderated
    Feb 16, 2013 2:04 PM   in reply to Caroline Vanlint

    Just to be absolutely certain you're not having another problem, if you paint over a spot that's smooth, does it stay smooth?  Or does that "block up" too?

     

    -Noel

     
    |
    Mark as:
  • Noel Carboni
    23,526 posts
    Dec 23, 2006
    Currently Being Moderated
    Feb 16, 2013 2:25 PM   in reply to Caroline Vanlint

    I can explain it, but it gets a bit technical.

     

    In 8 bits/channel mode, every red, green, and blue component of a pixel's color is quantized to fit in 8 bits - meaning there are only 256 different levels of red, green, and blue.

     

    In short, in an 8 bits/channel document, there are only so many shades you can have.  Generally speaking, with a good monitor the difference between these shades is just about visible. 

     

    Worse yet, if you do anything to an image where you manipulate it  - e.g., brightening it with Curves or something - adjacent shades that differed by one level can end up differing by more than one level and become even more visible.

     

    In order to "cover up" the blockiness/posterization that you've already accumulated, you'll need to blend those areas after having switched to 16 bit mode, possibly as I said using the Smudge Tool to "smear" adjacent pixels together.  Try it.  It may take a while to get the hang of it, but it does work.  The other alternative is to just repaint those areas from scratch.  Like I said, it may not be easy to fix, but I don't think all is lost.

     

    Another technique people sometimes use to hide posterization is to add noise selectively, which tends to break up the digital appearance of the noise.

     

    As an example I smudged, added noise, and a tiny bit of motion blur to selections within one of the feathers in the image you posted...

     

    FixedFeathers.jpg

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2013 7:20 AM   in reply to Noel Carboni

    This hasnt solved the same problem i'm getting. is there anything else i can check?

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2013 10:41 AM   in reply to Caroline Vanlint

    ive tried this, and no luck :/

     
    |
    Mark as:
  • Noel Carboni
    23,526 posts
    Dec 23, 2006
    Currently Being Moderated
    Feb 21, 2013 1:47 PM   in reply to RezKhan

    At this point I'm not even sure I understand what it is you're seeing that you don't like, or whether your monitor is showing you what others' monitors show to them.

     

    The initial image you posted, with soft brush strokes, looked pretty soft to me. Then the first feather image was almost black.

     

    Perhaps it would be good if you'd start over.

     

    Please create a new document and paint just a bit on it, in brightness levels that are easy to see, annotate the image with arrows showing *just* what you mean, and post the image here.  Perhaps someone will recognize what I'm apparently missing.

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2013 2:10 PM   in reply to Caroline Vanlint

    Untitled-1.jpg

     

    its looks like paint by numbers
    it doesnt gradient smoothly it might be my colour settings. but the stroke is jaged

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2013 2:13 PM   in reply to Noel Carboni

    Untitled-1.jpg
    almost grainy like colours are missing, i really have no idea how to explain this.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2013 2:25 PM   in reply to RezKhan

    Looks like a hard Brush with about 10% Spacing and very low Flow. Try reducing Spacing to 1% in Brush panel.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2013 2:36 PM   in reply to conroy

    Here's Spacing at 20, 10, 5, 2, 1% when Flow is 1%.

     

    Screen-shot-2013-02-21-at-22.33.00.png

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2013 2:57 PM   in reply to conroy

    R.S.Khan, here's Opacity 100, 50, 25, 12, 6 % when keeping Spacing at 1% and Flow at 1%. Maybe that'll help if you want to use reduced Flow.

     

    Screen-shot-2013-02-21-at-22.39.24.png

     
    |
    Mark as:
  • Noel Carboni
    23,526 posts
    Dec 23, 2006
    Currently Being Moderated
    Feb 21, 2013 2:51 PM   in reply to RezKhan

    Your monitor is likely WAY out of calibration for gamma, as the images you continue to post seem very dark.

     

    +1 to post 27 - as Conroy has said, with these latest images you're showing what happens with Spacing values that are higher than you might want.

     

    -Noel

     
    |
    Mark as:
  • Noel Carboni
    23,526 posts
    Dec 23, 2006
    Currently Being Moderated
    Feb 21, 2013 3:07 PM   in reply to Noel Carboni

    Which of these two images seems more the proper brightness to you?

     

    GammaQuickCheck.jpg

     

    -Noel

     
    |
    Mark as:
  • Noel Carboni
    23,526 posts
    Dec 23, 2006
    Currently Being Moderated
    Feb 21, 2013 3:20 PM   in reply to Caroline Vanlint

    You almost certainly  have a monitor gamma problem then, since that image is actually too dark, and the one on the right has normal brightness levels. 

     

    This explains why you're seeing the differences between adjacent levels of brightness on an 8 bits/color display.  I suspect you've been choosing dark colors to compensate, which is why the images you post look too dark.

     

    Is it possible someone used your computer to play a dark game and they left it set (e.g., in the video driver) with a hugely out-of-calibration gamma setting?  You mentioned turning things down once already.

     

    -Noel

     
    |
    Mark as:
  • Noel Carboni
    23,526 posts
    Dec 23, 2006
    Currently Being Moderated
    Feb 21, 2013 3:39 PM   in reply to Caroline Vanlint

    There's not an easy answer...

     

    What graphics adapter does it have in it?

     

    Does your display driver have the ability to change the brightness/gamma/etc.?  If so, are there non-default settings there?

     

    Windows does provide a display calibration process that might help...  Try clicking Start and typing calib in the search box, then choose Calibrate Display Color when it comes up.

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 22, 2013 2:38 AM   in reply to Noel Carboni

    i have the same peoblem still as like Caroline.
    my gaphics crad is the AMD radeon HD 7800 series

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 24, 2013 8:31 AM   in reply to Caroline Vanlint

    I see it to

     

    Its something to do with the colour profiles.

     

    Ive reformatted and still see it, im going to try a clean sweep of windows and see if my brother can figure it out,
    he has fixed it before, ill get back to you

     
    |
    Mark as:
1 2 3 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points