Skip navigation
senzaconfini
Currently Being Moderated

PSE 9 how to load only pdf files ina catalogue?

Feb 22, 2013 11:17 AM

I chose "file type:" PDF in the menu "Load Photos, Videos from folder and files" but I am not able to avoid that also JPEG files are loaded in the catalogue.

Moreover, the program freezes many times.

Am I doing something wrong or is not possible to load only a type of file?

My purpose is to get a catalogue with only a copy of all my PDF I have split in many directories.

Thank you for help

 
Replies
  • 99jon
    12,810 posts
    Jan 6, 2010
    Currently Being Moderated
    Feb 22, 2013 11:33 AM   in reply to senzaconfini

    Hold down the Ctrl key and click on PDF's in the folder or use Shift click on the first and last pdf files if they are consecutive.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 23, 2013 12:05 AM   in reply to senzaconfini

    I don't see a way to import automatically only pdf files in your cases.

    But I believe it's quite possible to set the import for all media files, then use the menu 'view' by media type and delete all media types other than pdf from the catalog. (NOT from the disk...)

    Can the import be done with 750 000 files ? It will be long. All files will be scanned and only media types will be imported, leaving aside other types like docs etc. Let's say you have 100 000 to 150 000 real media files left, the catalog organizer is able to manage that quantity at import time. If you have more, it would be safe to work by importing by main folder trees, splitting the import into several batches.

    (Note that there must be a media type present in the upper level folder tree to enable the search to the entire folder tree.)

    Anyway, it's worth a try. The catalog (database folder) size itself is not huge and you don't have to wait for the creation of thumbnails to be completed after the import; you can immediately delete unwanted photo, video, audio files.

     

    Edit:

    Run 'optimize' after each deletion batch to speed up the process.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 23, 2013 1:19 AM   in reply to MichelBParis

    There can be other workarounds like -

    1. Using windows search option: From Organizer, select 'File ->Get photos and videos'. In the coming dialog, navigate to root directory which contains all your PDF's (of just navigate to Computer) and type '.pdf' in the Windows search box. It will show all the PDF's. Once you have all PDF's press CTRL+A and click on 'Get media' button.

     

    2. Using 'Media type' option in Import dialog: For this, navigate to the folder which contains mix of JPEG and PDF's. Click on flyout adjacent to Filename and click on '.PDF's'. It show all the PDF's in the folder. Once you have them you can click on 'Get media' button. Note that this approach can only be used with a folder which don't contains any sub folders.

     

     

    ~Andromeda

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 23, 2013 1:41 AM   in reply to Andromeda14

    Andromeda14 wrote:

     

    There can be other workarounds like -

    1. Using windows search option: From Organizer, select 'File ->Get photos and videos'. In the coming dialog, navigate to root directory which contains all your PDF's (of just navigate to Computer) and type '.pdf' in the Windows search box. It will show all the PDF's. Once you have all PDF's press CTRL+A and click on 'Get media' button.

     

    ~Andromeda

    I have tried that, and I was unable to have the CTRL+A to work. I also tried the Shift or Ctrl selection without success. That did not work both in my Win7 computer and my old XP laptop ???

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 23, 2013 2:02 AM   in reply to MichelBParis

    It is working fine on my end. Please refer attached snapshot for more details:

     

    pdf.jpg

     

    ~Andromeda

     
    |
    Mark as:
  • 99jon
    12,810 posts
    Jan 6, 2010
    Currently Being Moderated
    Feb 23, 2013 7:55 AM   in reply to senzaconfini

    It would probably be easier to separate your PDFs from your jpegs. One suggestion is to do a system search for all PDF’s and then import them all from a single folder. It really depends how important your folder structure is.

     

     

    1. Create a new folder My PDFs

    2. Launch Windows Explorer and click the search button on the top ribbon next to folders

    3. Choose All Files & Folders

    4. In the box below All or part of File name type: *.PDF

    5. Click the Search button and wait for the search to finish

    6. Ignore results in /WINDOWS or /Program Files folders

    7. Select all other PDF’s in Documents & settings locations

    8. When all you PDF’s are highlighted click the top menu Edit >> Move to Folder

    9. Choose you new folder My PDF’s and click Move.

     

     

    You could split the task by selecting batches to move. When you have moved them all to My PDF’s import into Organizer from My PDF's

     

     

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 24, 2013 12:14 AM   in reply to Andromeda14

    Thanks for the detailed screenshot, Andromeda.

    That did not help me until I did;

    - put a pdf file into the master folder for the search

    - ask Win7 to index file for quicker search.

    Really the quicker solution when you master Win7 better than I do...

     

    I'll try to find something like this with PSE6 on my old WP laptop.

     

    Edit:

    In PSE6 and Windows XP, I select 'pdf' in the file type box, then 'Open', which shows a selection of pdf files plus a  number of subfolders.

    I highlight one of the pdfs, then CTRL A, the pdfs are highlighted.

    I can then 'Get photos'.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points