Skip navigation
Currently Being Moderated

z-index less than -1 no longer working after Player update

Feb 23, 2013 8:40 PM

I'm rebuilding my site to be HTML5 and I had all of the Flash stuff working perfectly, where it's placed on z-index:-2. However, after updating my Mac's Flash Player to 11.6.602.167, it won't go any lower than -1, so it's getting placed above other content. With JavaScript disabled, the non-Flash <img> is displayed at the correct z-index and I've triple checked to ensure that the values line up logically. I don't download every update, so it's possible that this issue, if not of my doing, has occured less recently.

 
Replies
  • kglad
    72,213 posts
    Jul 21, 2002
    Currently Being Moderated
    Feb 23, 2013 9:49 PM   in reply to Steven Vachon

    you shouldn't be adding to any index less than zero.

     

    in fact, i believe, if you were using the compiler in strict mode it would trigger an error when trying to add a display object to an index less than zero.

     
    |
    Mark as:
  • kglad
    72,213 posts
    Jul 21, 2002
    Currently Being Moderated
    Feb 24, 2013 4:18 PM   in reply to Steven Vachon

    to control the depth of your embedded swf with js make sure its window mode is transparent.

     
    |
    Mark as:
  • kglad
    72,213 posts
    Jul 21, 2002
    Currently Being Moderated
    Feb 24, 2013 11:09 PM   in reply to Steven Vachon

    check to see if this is a reported bug:  http://bugs.adobe.com/flashplayer/

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points