Skip navigation
Currently Being Moderated

Photoshop CS6 - Quick Selection tool freezes Photoshop/ becomes unresponsive for minutes

Feb 24, 2013 2:27 PM

Tags: #selection #tool #freeze #quick #unresponsive

After only two selections the tool becomes unresponsive for minutes.

 

I'm on a 2.6 Ghz retina MacBook Pro, 16 Gb RAM, and this in connection with an SSD should make this tool very good to use. Operating system: OS X 10.8 "Mountain Lion", latest update.

 

Unfortunately, it seems to develop some kind of overload, during which you cannot use Photoshop at all. No commands like "undo selection", "quit", "close file" are accepted.

 

There is no beachball, no other signs that Photoshop is working on something.

 

 

 

Hint: it seems to happen when you option select (subtract from an existing selection).

 

Hint: the freeze can be shortened by a tool switch (has to be through clicking on a tool, keyboard commands are frozen as well)

 

Hint: the "subtract selection" move that caused the freeze appears after Photoshop comes back to life after a couple of minutes. The subtraction to the selection seems to be random, makes no sense, and is not the regular function of the tool.

 

First step after this freeze would be to undo the last selection, and continue working.

 

If you do several "add to selection" moves, they add up in a kind of waiting line. If you do the subtract from selection move, this doesn't work, and the freeze happens.

 

 

So far, I have not noticed the freeze when adding to a selection. Adding to a selection was always quick and instant. The bug must sit in the "subtract from selection" code.

 

 

On most freezes, the ants continue walking, I just had one (again with subtracting selection) where even the ants stopped walking.

 

I don't think it has anything to do with Photoshop working. I have used the quick selection tool regularly under CS5 on my old machine (which was a museum piece), and while I had to wait sometimes, it was never ground to a freeze/halt like the quick selection tool under CS6.

 
Replies
  • Currently Being Moderated
    Feb 24, 2013 5:28 PM   in reply to Pacific 29

    You might try reseting your preferences, espeicially if it worked before.  Start PS and immediatly hold down the Option Cmd Shift keys.  You should get a reset window.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 24, 2013 6:39 PM   in reply to Pacific 29

    Did this work before, or has it always been this way?  Not a bug or everyone with your system would be complaining.  Have not seen that.

     

    If it has always worked that way a reset of preferences will probably not do anything.

     

    A reset of preferences will reset to factory defaults, so you will have to reset to saved workspace.

     

    Do you have at least 10% free disk space? 

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points