Skip navigation
p55mac
Currently Being Moderated

Documents with Smart Objects - Very slow to open and Save - CS6 Photoshop

Feb 24, 2013 3:39 PM

When opening and saving documents with smart objects photoshop freezes the adobe PS loader (circle dots) is replaced and the system loader (multi colored wheel of death) spins for 30 seconds or more.

 

What I've tried so far based off looking at various posts.

 

Photoshop Preferenes

  • Save in Background off
  • Maximise PSD and PSB file compatability never
  • Cache Tile Size: 128k
  • Advanced Graphic Processor Settings: Basic & Normal
  • Layer Panel options: No Thumbnail

 

Observations and workthroughs to date

  • The file size and amount of smart objects effects the file expotentially i.e. The more smart objects you have the worse it gets
  • These files worked perfectly in PS CS5
  • It also happens on files natively created in PS CS6
  • The CPU is maxing out at 100% while PS loads
  • Closing or opening suitcase has no effect.

 

System:

  • iMac 27-inch, Mid 2011
  • Processor  3.4 GHz Intel Core i7
  • Memory  16 GB 1333 MHz DDR3
  • Graphics  AMD Radeon HD 6970M 1024 MB
  • Mac OS X Lion 10.7.5 (11G63)
  • Suitcase 4

 

Anyone got any ideas? This is making me go nuts!

 
Replies
  • Currently Being Moderated
    Feb 24, 2013 4:28 PM   in reply to p55mac

    Haven't seen that problem with other users.

    Have you installed all the Photoshop updates (should be on 13.0.4 or 13.1.2)..

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 26, 2013 8:45 PM   in reply to p55mac

    OMG!!! This is the same problem I'm having!! It's taken me hours of troubleshooting to pretty much come to the exact same conclusions. At first I thought my new MBPr as a steaming pile of... then after testing I thought it was a font activation problem (firstly with Suitcase Fusion 4, then perhaps system fonts). After further testing I'm sure fonts aren't the issue, it's definitely Smart Objects.

     

    The settings you have for Photoshop Preferenes are similar to mine, also ALL of your Observations and workthroughs to date are spot on exactly with what I've found too.

     

    My system is:

     

    • 15" Macbook Pro Retina
    • 2.6ghz Intel Core i7
    • 8gb RAM
    • NVIDIA GeForce GT 650M 1024 MB
    • 512gb SSD
    • OSX 10.8.3 Mountain Lion
    • CS6 13.1.2 x64 (Creative Cloud)
    • Suitcase 4 (latest version, font activation plugins all fine, auto-activation correctly configured in prefs)

     

    This is so infuriating as we have 3 other late model Imacs, all with OSX 10.8.2/3 with CS6 13.1.2 x64 and they have no problems. Files open and save in a jiffy.

     

    I'm considering a clean reinstall of the OS to see if this does anything...

     

    HELP!!

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 26, 2013 11:37 PM   in reply to bektravels

    Try disabling Suitcase.

     

    And make sure you have all the Photoshop updates installed.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2013 2:28 PM   in reply to Chris Cox

    Thanks for the reply Chris.

     

    I have tried with suitcase disabled. Like I said, I believe it's not fonts its a smart object issue.

     

    To test this theory I took one of my massive psd's with many layers (500mb). I selectively rasterized all text layers (leaving smart objects as is) however both the saving and re opening processes still resulted in the same beachball of death lag.

     

    I went back to the original psd, kept all text layers intact but selectively rasterized all smart objects and voila! My massive file saves and opens in a jiffy now.

     

    Like the OP stated, this is not a problem in CS5, only CS6. It does not matter if the psd with smart objects was created in CS5 or CS6, it will still be a problem in CS6. The more smart objects used within a psd, the longer the beachball of death hangs on open/save (3-4 mins on my 500mb test psd). Other than this CS6 flies on my rMBP so I believe it is not like the hardware isn't capable of performing under the weight of the software/psd file size.

     

    Any ideas? Smart objects are pretty essential to my way of working in PS...

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2013 2:32 PM   in reply to bektravels

    Fwiw, I'm running the latest updates to OSX, PS CS6 and Suitcase 4 and the issue still persists...

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2013 2:44 PM   in reply to bektravels

    Other users are not seeing such a slowdown.

    But most users are not running suitcase (which sometimes causes problems with saving files).

     

    Try disabling Suitcase.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2013 2:51 PM   in reply to Chris Cox

    Like I said, I have tried disabling Suicase! With suitcase disabled or enabled, the only time the slowdown on open/save occurs is when there is a vast amount of Smart Objects in the file.

     

    In CS5 on the same computer, this is not a problem. In CS6, it is!

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2013 2:58 PM   in reply to bektravels

    Well, you are seeing something that most other users are not seeing, and that I cannot explain (since the Smart Object code really didn't change in CS6).  This is not just a smart objects issue.

     

    Either there is something important that you are leaving out of your explanation, or there is something else on your system causing a slowdown that isn't on the systems of other users.  In either case, we need you to tell us what is different about your system, or what is different about your documents that might explain the slowdown that you are seeing.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2013 3:12 PM   in reply to Chris Cox

    Thanks Chris, I appreciate the help. I got no other real points of difference that I can offer at this stage between my iMacs which are fine and the rMBP which has this problem. The iMacs and rMBP are all identically setup (with Suitcase 4, all software up to date) yet only the rMBP has this problem.

     

    I've tried going into disk utility and verifying/repairing permissions and the disk yet that revealed no problems. SMART status is vertified. I've tried all I can think of other than a clean install.

     

    I guess I might have to stick with CS5 for any psd's with large amounts of smart objects on the rMBP which is dissappointing as CS6 otherwise is great to use!

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2013 3:58 PM   in reply to bektravels

    Again, there is something specific about your system or your documents that's causing this.

    Most users are not seeing such a slowdown.

     

    I think I'd also try doing some font and font cache troubleshooting.

    See this article for more info:  http://helpx.adobe.com/photoshop/kb/troubleshoot-fonts-photoshop-cs5.h tml

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 18, 2013 11:08 AM   in reply to Chris Cox

    Any new information on this? I'm having the exact same problem.

     

    System

    Mac Pro 2008 Early 2008 (3,1)

    2 x 3 GHz Quad-Core Intel Xeon

    16 GB 800 MHz DDR2

    NVIDIA GeForce 8800 GT 512 MB

    Mac OS X Mountain Lion 10.8.3 (12D78)

     

    I'm also running Suitcase Fusion 4, but I've tried without the Type Core running and it makes no difference. I've tried all the font troubleshooting tips, reinstalled Photoshop, disabled non-standard System Preferences, etc., all with no luck.

     

    Edit: I'm running Photoshop 13.0.4 x64, not the Creative Cloud version, as part of the CS6 suite.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 18, 2013 12:20 PM   in reply to Brendan Cahill

    Have you disabled all of Suitcase?  It has been known to cause several slowdowns (and crashes).

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 18, 2013 1:24 PM   in reply to Chris Cox

    I believe I disabled Suitcase completely (maybe someone can chime in on if there's more that can be done to disable it). I stopped Type Core from within the program, removed Suitcase from my Login Items list, and restarted. When I opened one of the problem files in Photoshop, I got the warnings about missing fonts, indicating that Suitcase was no longer enabling fonts and/or no longer communicating with Photoshop.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 23, 2013 6:45 AM   in reply to Brendan Cahill

    Hello,

    I have the same problem too.

    If i use smart objects .. my computer starts to run slower.

    After quick rasterizing everything is fine.

    Work with iMac 27, i7, 32 GB RAM and 2 GB video card.

    I would say pure Mac + Adobe .

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 23, 2013 9:25 AM   in reply to valerimarinov

    A solution!

     

    It turns out the problem in my case was in fact Suitcase. Previously, I'd tried turning it off, but that didn't fix the problem, so this time, I uninstalled it completely and the problem disappeared. I then began re-adding it (installed 15.0.1, upgraded it, etc.) and the problem resurfaced with the addition of the Photoshop-specific plugin. Deleting that plugin solved the problem. So it seems that "disabling" Suitcase by stopping the TypeCore doesn't seem to actually disable all of the tentacles it sticks into your system.

     

    You can find the plugin here: Applications / Adobe Photoshop CS6 / Plug-ins / Automate / ExtensisFontManagementPSCS6.plugin

     

    (After a restart, I also had to delete the font cache, as described here http://helpx.adobe.com/photoshop/kb/troubleshoot-fonts-photoshop-cs5.h tml but your mileage may vary.)

     

    Alternately, if you don't want to delete the plugin, disabling it from within Photoshop seems to work as well. To do that, go to File > Automate > Extensis, click Preferences..., then deselect Enable Suitcase Fusion 4 Auto-Activation.

     

    Fortunately, the plugin doesn't seem necessary at all to use the the core functionality of Suitcase (enabling and disabling fonts) in Photoshop. I didn't even know what these app-specific plugins did until researching this problem, and I still don't quite understand the point of them. I guess they allow you to let the apps for which they're installed do a little bit more of their own management (enable a font via Suitcase that isn't enabled system-wide), but that seems like more control than I need--if I'm enabling a font, I want all my software to be able to use it.

     

    Anyway, the problem seems to be completely solved on my system now, though I just did all this, so more testing over the next few days is required. I'll post here if any issues crop up. I'm interested in hearing if this solves it for anyone else as well.

     
    |
    Mark as:
  • Currently Being Moderated
    May 3, 2013 3:54 PM   in reply to Brendan Cahill

    Hello all,

     

    Extensis has identified a resolution for this issue and will include the fix in an upcoming product update as soon as possible.

     

    We apologize for the inconvenience this has caused.

     

    Cheers,
    Chris Meyer
    Extensis Inc.
    Font Management Product Team

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 18, 2013 4:47 PM   in reply to FontMgmtPM@Extensis

    I have exactly this problem.  Of slowdown with Smart Object use.

     

    I have a document with ONLY Smart Objects in it.  Only of one type.  48 of them.

     

    I noticed my Hard Drive space massively reducing every single time I saved an edit to the Smart Object.  About 2 to 3 GB each edit/save. 

     

    The file is 2048x1536.  The smart object is 640x480.

     

    What is causing this?

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 19, 2013 7:22 AM   in reply to dissidently

    Hello all,

     

    This Extensis plugin issue has been addressed and is available in both currently shipping versions of Suitcase Fusion 4 and Suitcase Fusion 5.

     

    Installer downloads are here:

     

    SUITCASE FUSION 4

    (For Mac) http://bin.extensis.com/SuitcaseFusion4-M-15-0-6.zip

    (For Windows) http://bin.extensis.com/SuitcaseFusion4-W-15-0-6.zip

     

    SUITCASE FUSION 5

    (For Mac) http://bin.extensis.com/SuitcaseFusion5-M-16-0-2.zip

    (For Windows) http://bin.extensis.com/SuitcaseFusion5-W-16-0-3.zip

     

     

    Please let me know if you have any further questions or concerns.

     

    Cheers,
    Chris Meyer
    Extensis Inc.
    Font Management Product Team

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 19, 2013 5:24 PM   in reply to FontMgmtPM@Extensis

    Great! Just downloaded the Suitcase update and after a few tests with smart object ladden psd's, I believe it's fixed my problem thank you!

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 19, 2013 5:31 PM   in reply to FontMgmtPM@Extensis

    I do not have Suitcase installed.  Never have, probably never will.  Don't even know what it is.

     

    My problem is with "Smart Objects" and HUGE use of HDD space for each incremental save.  Until I run out of space.  At which point Photoshop goes into a "Pause" mode I'd never previously heard of.

     

    Purging the cache (you'd think) should fix this.  But it does not.

     

    A total hard restart of Photoshop is required to free up the space and get the system responsive again.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points