Skip navigation
kjg48359
Currently Being Moderated

amtlib.dll error

Feb 25, 2013 4:58 PM

When trying to run perform an edit against a file trying to add a text element, Elements v 10 crashes telling me that "system32/amtlib.dll" is not a valid windows file or is currupt. I am suspecious of the recent "inspiration browser" install a couple of months ago.  However that being said, Adobe's tech support is not helpful, I figured the best way fix this might be do do a clean install. 

 

However, the PC is a HP pc just purchased about 4 months ago, and of course the software was pre-installed and I do not have original system disks. 

 

Anyone have suggestions (and I've tried to replace the version of the DLL in the system32 subdirectory with the version that was in the \programs32\adobe\elements subdirectory with no differernce. 

 

Is this some kind of registration issue?

 
Replies
  • Currently Being Moderated
    Feb 25, 2013 11:05 PM   in reply to kjg48359

    Hi,

     

    The easy fix for this is to reinstall the product on your machine.Since you do not have original media,you can do that in two wyas:

     

    Firstly,You can download and install PSE10 build .

    However this is not recommended becuase you are using Hp version of PSE and it has some extra features which will break .

    So you should go for the second one.

    Secondly,Contact HP customer support and ask them for the PSE10 build that they had installed on your machine.

     

    Also,

    Can you please share screenshot of the error you are getting,just for reference.

     

    -Shikha

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 27, 2013 1:57 AM   in reply to kjg48359

    Hi ,

     

    The screenshot that you have shared says that ATMlib.dll is missing,not Amtlib.dll.

    This is a system file and is  not PSE11 specific.I have found some document about Atmlib.dll.You can have a look and do the needful.

     

    http://www.processlibrary.com/directory/files/atmlib/19962/

     

    Thanks,

    Shikha

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 27, 2013 7:08 PM   in reply to kjg48359

    If you look in the system 32 folder do you have both the atmlib.dll and amt.lib.dll?

    (capital or small letters)

     

    The atmlib.dll (adobe type manger is supposed to be in system 32) the amtlib.dll is not.

    both are adobe files

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 28, 2013 5:56 PM   in reply to kjg48359

    I would unistall pse 10 and then go to system 32 and delete the amtlib.dll (AMTLIB.dll)

    and the amtlib.dll (AMTLIB..dll) and then reinstall pse 10.

     

    If the amtlib.dll is corrupted or someting, that's what the problem with the text tool in pse 10 is and pse 10 should install a new one.

     

    In other words pse 10 needs the amtlib.dll in the system 32 folder in order for the text tool to work.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 1, 2013 6:20 PM   in reply to kjg48359

    From reading your earlier postings it seems you renamed a dll file.

     

    If you look in the C:\Windows\System32 folder do you have both an amtlib.dll and a atmlib.dll?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 19, 2013 1:37 PM   in reply to kjg48359

    Sorry for the frustration kjg48359,

     

    I have a couple suggestions:

     

    1. Try changing the font preview preference to not display font previews

    Preferences > Type > Uncheck Font Preview Size

    Restart PSE

     

    2. Have you tried launching and using PSE in a new administrator user yet?

    Seems that would be a good test.

     

    3. Also, which version of Windows are you working on?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2013 7:24 AM   in reply to Pete.Green

    Pete,

    I am having the same issue since Jan 2013. I discovered the fatal error when using Photomerge. ADOBE refused help as it was a Windows issue they claimed. Windows refused help as it is an application problem. 1 full day hanging on the phone down the drain (next to a nice phone bill for me calling from The Netherlands to the US!).

     

    I accepted the error until to day I encountered the issue with the text option in PS Editor!

     

    A IT tech friend of mine tried the lot, but as proven today NO SOLUTION. The fact that ADOBE refuses p****es me off, as I paid for a working program and at the first hick-up they turn their back on me.

     

    I ried copying in several versions of the ATMLIB file sourced from other computers, but still no luck!

     

     

    For those who can understand Dutch: the problem is a corrupt ATMLIB.dll file. 

     

     

    GREAT ADVERT FOR ADOBE THIS WILL MAKE. I am seriously looking into other programs as soon as I am sure the liberary can be converted without loads of rework, as I store about 7,500 pics!

     

     

    Regarding your option 2, how can I try that. It looks my last resort.......................

     

    I run Windows 7 and always kept up with updates.

     

    Thanks for your help anyway (Adobe is not home!)

     

    JOHN KRAAN

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2013 7:31 AM   in reply to kjg48359

    Hi kjg48359,

    I suffer from the same issue, but it pops up with me also when using Photomerge. Do you experience the same?

     

    I discovered it first in Jan when I tried to stitch/merge some pics. Adobe refused help as it was a "windows issue". Windows refused help as it was an application problem"! Still I paid fulll funds for the version including support I remembered!

     

    Can you have a check if the Merge option has the same effect with you?

     

    Just like you I am at the end of my options (and patience).

     

    Kind regards,

    JOHN

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 10, 2013 5:39 PM   in reply to DUTCHIE13A

    Hi John,

     

    Sorry for the delay in getting back to you. Thanks for posting.

     

    Did you try the first suggestion? Any luck?

    Try changing the font preview preference to not display font previews

    Preferences > Type > Uncheck Font Preview Size

    Restart PSE

     

    Regarding the second suggestion, of creating a new admin user and trying it within that.

    If on Windows 7, see this document which walks you through creating a new administrative user: http://helpx.adobe.com/x-productkb/global/create-local-administrator-a ccount-windows.html

     

    Let me know how both of those go,

    Regards,

    Pete

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 14, 2013 3:36 AM   in reply to Pete.Green

    Pete,

    can you guide me a little in your option 1? I am using the Dutch version of PE10 and have problems finding the toggle to switch off the font display. Please indicate which buttons to follow to get there in writing.

     

    I would like to try this one first, then the other to mak esure to retrieve the root couse. I am using windows 7.

     

    Unfortunately there are no other reports of the error also blocking the Photomerge, so I cannot see if there is a link between the two phenomena.

     

    Thanks for trying anyway.

     

    JOHN

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 23, 2013 9:26 AM   in reply to DUTCHIE13A

    Hi John,

     

    I don't have the Dutch PSE on my system, but this setting should be discoverable if you look in the same places as my screenshot displays.

    Note: Getting to the preferences is done within the "Edit" menu on the windows platform (instead of the Adobe Photoshop Elements Editor/Application menu as shown by my MacOS screenshot)

     

    Try unchecking this Font Preview preference, restart Photoshop Elements and see if you still get the error.

     

    PSE_Prefs_FontPReview.jpg

    Let us know how it goes,

    Regards,

    Pete

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 23, 2013 1:02 PM   in reply to Pete.Green

    Hi Pete,

    I was really excited finding the route to disable the Font Preview, but unfortunately it did not solve anything.

    PSE still shuts down with reference to the ATMLIB file once I try to add a text to a picture or if I advance with Photomerge. I heard some other users on the first issue, but I haven't seen any report on the second.

     

     

    Can you see the connection between the two occassions (there might be more, but I just don't use all possibilities of PSE Editor)? If so we might advance a little.

     

    I am organising a fundraiser this weekend to be able to procure PSE 11 and see if this issue remains. But after the "enthousiastic" support I have received from PSE support, I am looking to see if I am better off putting my money in another program............

     

     

    Thx and regards,

    JOHN

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 23, 2013 1:49 PM   in reply to DUTCHIE13A

    Thanks for getting back with your results John.

     

    Try the second suggestion when you can of creating another administrator user on your computer (helpful link in previous posting), Log in as that new user, and test PSE10 out to see if you can add text, or even start the Photomerge.

     

    This should alleviate most of the connections, unless it's a font that is tripping PSE up, in which case we'd want to troubleshoot the fonts that are installed on your system.

    For Font troubleshooting, this article can help: http://helpx.adobe.com/photoshop/kb/troubleshoot-fonts-photoshop-cs5.h tml#id_70272

     

    The other option is to go ahead and download the trial for Photoshop Elements 11 and see if that works out for you as well: http://www.adobe.com/go/tryphotoshop_elements/

    You can download and try it out for free for 30 days.

     

    Let me know how it goes for you.

    Regards

    Pete

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points