Skip navigation
Currently Being Moderated

Landscape after portrait: preview is blurry

Feb 28, 2013 9:49 AM

Tags: #preview #blurry #4.3

I noticed a weird preview bug in Lightroom 4.3 under Windows 7.

 

In Library mode, preview window set for single large preview:

 

1. Hit a portrait-oriented photo in the filmstrip below. The photo is previewed properly (sharply)

2. Hit a landscape-oriented photo in the filmstrip below. The photo preview is blurry

3. Hit another landscape-oriented photo in the filmstrip below. The photo is previewed sharply

4. Hit the landscape-oriented photo from step 2 again. The photo is previewed sharply

 

Every time I hit a landscape-oriented photo immediately after a portrait-oriented photo, the photo is previewed blurry. But if the same landscape-oriented photo is previewed immediately after another landscape-oriented photo, then everything is fine.

 

In other words, previewing a portrait-oriented photo screws up the preview for the next landscape-oriented photo. It looks like not every portrait-oriented photo has this effect. But the ones that do have this effect consistently in 100% cases.

 

I read the list of fixes in the upcoming 4.4 version and they mention the fix for blurry previews on Mac only. I wonder if this is somehow related. Hopefully they'll fix this one as well.

 
Replies
  • Currently Being Moderated
    Mar 1, 2013 2:02 PM   in reply to Andrey Tarasevich

    Hi,

     

    I can not reproduce this using W7 LR 4.4RC1.

     

    It might be, that you are just "missing" the correctly rendered preview. If you change something in the develop module or apply a preset, the fullscreen preview is not rendered by LR. It is rendered in the moment when you open the image in 1:1 view in loupe view. This my take some seconds. During the rendering of the image the old preview or the preview in the raw file are display in a blurry way. If change to an other image (with existing preview) the generation of the preview goes on. If you go back, the preview is rendered and sharp.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 1, 2013 4:31 PM   in reply to Andrey Tarasevich

    Two things to try:

     

    1) Select  a group of portrait and Landscape images exhibiting the issue and then go to Library> Previews> Render 1:1 previews with all of the images selected.

     

    Try browsing these images after all previews are rendered and see if still blurry. If so try #2:

     

    2) Update your graphics card driver using the latest version downloaded from the manufacturer's website (AMD, NVIDIA). There is usually no need to uninstall the previous driver, simply load the update. You can always rollback the driver.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 6, 2013 7:58 AM   in reply to Andrey Tarasevich

    What model monitor(s), resolution, and refresh rate are you using and what are your previews set for in the Catalog Settings?

     

    LR Preview Size 2.jpg

     

    LR Preview Size.jpg

    I'm using a 1920x1024 display and have chosen the closest (larger) display width of 2048.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 6, 2013 9:15 AM   in reply to Andrey Tarasevich

    Once 1:1 previews have been rendered it shouldn't make any difference what 'Standard Preview Size' you have selected. I would suggest setting it to 2048, since as suggested by Adobe it should be equal to or larger than your display width. Preview Quality medium is fine and saves a some storage space.

     

    I assume you are saying that once you see a blurry image it stays blurry indefinetly, even after several seconds, correct?

     

    Can you provide screen shots of the blurry images, both portrait and Landscape? Use ALT + Prt Scrn keys if on Windows and post the whole display image (1920x1200), not just the center preview area.

     
    |
    Mark as:
  • Victoria Bampton
    5,302 posts
    Apr 1, 2008
    Currently Being Moderated
    Mar 6, 2013 9:58 AM   in reply to Andrey Tarasevich

    There were some preview bugs fixed in the 4.4 release candidate, and this sounds very similar.  I can't be sure this is the same one, but that would obviously be easy to check by installing the RC from here: http://labs.adobe.com/technologies/lightroom4-4/

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 6, 2013 11:20 AM   in reply to Andrey Tarasevich

    Here's the LR4.4 RC fix Victoria is referring to on Mac platforms. What OS are you running?

     

    Previews of photos in portrait orientation were blurry when viewed in the filmstrip in the Develop module. (Mac only)

     

    Here's a 1920x1200 JPEG, lets see if it gets resized:

     

    Double-Click on the image to see full size:

    1920x1080 Image.jpg

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 6, 2013 11:36 AM   in reply to trshaner

    When I double-click on the above image it is a litlle less than full-size on my 1920x1080 display. By right-clicking again on the enlarged image and selecting 'Save Picture as....,' it is saved as a full-size (19120x1200) image.

     

    If you're using a Mac system I'd go ahead and try LR4.4 RC and see if that fixes the problem. If not post the two full-size screenshots with portrait and Landscape blurry images.

     

    Has the forum default text changed to Italic font? All LR forum text now appears to be in Italics, at least in IE9. Other Adobe forums look OK and are NOT in Italics. I just checked the LR Forum with FireFox and it is NOT in Italics.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 6, 2013 6:06 PM   in reply to trshaner

    Regarding the italics of Adobe Forums in IE9 and IE10, and possibly other IE versions, the culprit seems to be font-family:  “adobe-clean, …” in the BODY styles that inherit to everything visible and the adobe-clean seems to be dynamically loaded via the HEADER tag that includes a line which downloads a stylesheet from the website use.typekit.com.

     

    So one way to get rid of the italics, with possible other side-effects that I haven't noticed, is to add a line to your hosts file that disables use.typekit.com by assigning it to the local computer loopback address instead of using the real website address: 127.0.0.1 use.typekit.com making the styles from this website impossible to load.

     

    You will need to clear the browser cache and the windows DNS cache with c:\> ipconfig /flushdns and possibly close and reopen the browser before the italics is gone because the stylesheet still might exist in the browser cache and the dns-address might be cached by the OS despite having been disabled in the hosts file.  If you don't know what a hosts file is or where it is located, it's probably not a good idea to attempt this hack.

     

    BTW, I was able to determine the above using the F12 mode of IE and then deleting the adobe-clean from the font-family BODY styles and seeing that the italics went away.  YMMV.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 10, 2013 4:59 PM   in reply to Andrey Tarasevich

    Yep, pretty clear it's NOT clear. First step is to try deleting your preferences file here:

     

    Windows 7/Vista

    The preference setting file is Lightroom 4 Preferences.agprefs, in C:\Users\[user name]\AppData\Roaming\Adobe\Lightroom\Preferences\.

     

    You can copy it to the desktop before deleting, which will allow you to quickly replace it if the problem remains. You may also want to record your Preferences settings, which you will need if it does work. Close LR, delete the Lightroom 4 Preferences.agprefs file, and restart LR. A new Preferences file will be created with LR default settings.

     

    If that doesn't work try uninstalling LR4.3 and then reinstalling it. Your catalog and previews will not be removed. If still not fixed try LR4.4 RC.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 27, 2014 11:14 AM   in reply to trshaner

    I have the same problem as OP for LR 5.3. Portrait pictures are blurry in fill mode in the Library. I have uninstalled, reinstalled, recreated previews, but to no avail. Landscape pictures appear to be sharper. Does anyone have a solution?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 27, 2014 1:27 PM   in reply to anonym0use

    When using Fit and Fill modes the image must be "resized" from the Library Preview image pyramid (i.e. 1:16, 1:8, 1:4, 1:3, 1:2, 1:1 sizes). At smaller Loupe sizes the image may still appear sharp, but at larger sizes such as Full-Screen the reinterpolation algorithm may add visible softness.

     

    The solution is to use the numbered Zoom sizes 1:16, 1:8, 1:4, 1:3, 1:2, 1:1 for critical review. 'Fit' also seems to work fairly well with almost any Loupe preview size including Full-Screen mode.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)