Skip navigation
bannerboy32
Currently Being Moderated

why does (the object "move" is currently not availible) dialoge box pop up when I run action script?

Mar 6, 2013 2:24 PM

Tags: #illustrator #not #script #bug #action #bugs #cs6 #the #crazy #is #currently #object"reflect" #availible

when I run actions in CS6 it does nothing close to what Ive recorded , "move" dosnt work, "reflect" dosnt work  ,"copy" dosnt work ? and when I record simple moves it places shapes in compleately different areas then where I recorded them Ive try'd breaking the set up into the smallist possible actions ,with function keys and without . Ive try'd reconfigureing all types of presets in all sorts of combo's its driveing me nuts can anyone esplain ?!?!?

 
Replies
  • Currently Being Moderated
    Mar 6, 2013 2:46 PM   in reply to bannerboy32

    Do you have align to pixel grid turned on in the transform palette? That attribute is assigned to each object so you need to have a slection prior to checking.Screen Shot 2013-03-06 at 4.44.18 PM.png

     

    All those commands you mentioned should work, you just need to select what you wnat the action to run on prior to running the action (whcih it sounds liek you did for the move test you did).

     

    What would help to solve this is to know if you are having a problem with these action not running at all, or are the objects snapping to a different location because of something like align to pixel grid being on.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 6, 2013 3:44 PM   in reply to bannerboy32

    What exactly do you record? Please describe step by step.

     

    Are you monitoring the actions panel while recording to check if the step actually was recorded?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 6, 2013 4:40 PM   in reply to bannerboy32

    If Copy is not available, then nothing has been selected.

     

    It sounds as if you may need scripting rather than simply actions.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 15, 2013 5:32 PM   in reply to bannerboy32

    Sorry, no solution, but here's chiming in to say I have the same problem, and it's driving me nuts.

    Actions I saved earlier, and then imported, behave this way, "fresh" actions do not. I filed a report with Adobe, here's hoping they can trace it to something

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 19, 2013 8:36 AM   in reply to bannerboy32

    Same problem here. Some (not all) imported Actions throw up similar errors: "The object "Scale" is not currently available."

     

    I've seen it happen with the Scale and Shear commands. Not all Actions are affected, but the ones that are generate the error consistently.

     

    Actions/steps created in CC work fine.

     

    Illustrator CC on Mac 10.9.1.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 19, 2013 8:47 AM   in reply to JamesProvost

    That sounds bad!

    ..even more so because all of my troubles are completely in CC

    Here's hoping your luck holds

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 16, 2014 9:55 AM   in reply to JamesProvost

    Problem persists in Illustrator CC (17.1.0)

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (1)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points