Skip navigation
Currently Being Moderated

@fontface works offline, but not online.

Mar 10, 2013 6:19 AM

Tags: #fonts #font #not #offline #working #dreamweaver #online #fontface #polegysm

Hey everyone!

 

http://grafisk.kts.dk/elever/piwe2/opgave/kbh/index.php

 

The text "Kort om Turen går til København" is wrapped in a h2 tag. It's styles with a font called "Polegysm" via fontface.

 

For some reason when it's online it wont show.

 

I've tried with several browsers, but it doesn't seem to work when the website it uploaded.

 

Peace.

 
Replies
  • Currently Being Moderated
    Mar 10, 2013 7:26 AM   in reply to jameswood69

    The file "polegysm.woff" is not found on the server. Did you upload it?

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Mar 10, 2013 10:33 AM   in reply to jameswood69

    To add to Murray's response of checking the font file (it is not uploaded or the path to it in your CSS is incorrect), you may want to use fallbacks for your custom webfont. Here's a compatibility sheet for .woff fonts: http://caniuse.com/woff

     

    You may want to also include .eot and .ttf or .svg files for supporting other browsers.

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Mar 10, 2013 10:39 AM   in reply to jameswood69

    My method is only for 'compatibility with other browsers'. It should still work if you only have .woff. But in your case the file is not present where your code says it is.

     

    If it is uploaded, where is it uploaded to?

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Mar 10, 2013 10:49 AM   in reply to jameswood69

    Prefix 'assets' is missing in the font-face definition in your CSS file. It should be ../assets/font/...

     

    This folder exists. But the full file link doesn't show up. And I cant see your directory listing as it is disabled on your server.

     

    You may want to open this on a FTP program like FileZilla or even within Dreamweaver once to check the filename is correct (make sure the case is correct. Some servers give an error as they're case sensitive.)

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Mar 10, 2013 10:53 AM   in reply to Sudarshan Thiagarajan

    It is this folder: http://grafisk.kts.dk/elever/piwe2/opgave/assets/font/ - Check this folder on your remote server to see if the font exists and if the filename matches with that of your css definition.

     

    Regarding the /assets, sorry, my bad. I just realized that you're calling the font-file from within your CSS file - so, your filepath is correct. My apologies.

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Mar 10, 2013 11:10 AM   in reply to jameswood69

    Can you post a screenshot of the folder listing of assets/font on your remote server?

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Mar 10, 2013 11:15 AM   in reply to jameswood69

    Right click the 'polegysm.woff' file, 'File Permissions' or 'Change Permissions' to '644'. See if that works.

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Mar 10, 2013 11:17 AM   in reply to Sudarshan Thiagarajan

    Also, CHMOD is a Unix command and will not work on Windows servers. The server hosting your file is a Windows server, not Unix. But you should be able to right-click and change it.

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Mar 10, 2013 11:19 AM   in reply to jameswood69

    File > Site Manager > (Select your site) > Advanced > Server Type - ensure this is set to 'Autodetect'.

     
    |
    Mark as:
  • Sudarshan Thiagarajan
    4,000 posts
    Oct 15, 2010
    Currently Being Moderated
    Mar 10, 2013 11:25 AM   in reply to jameswood69

    Your server is not supporting it.

     

    • Try deleting the 'font' folder in entirety and re-upload it afresh
    • If that still doesn't work, do you have a web control panel for your server? If you do, you could try changing the file permissions there
    • Still no luck - try putting the font file within your CSS folder itself and re-write the path in your .css file to see if that works
     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points