Skip navigation
Currently Being Moderated

Introducing: Open Ai Files Maximized Script

Mar 15, 2013 9:46 PM

Tags: #script #maximized #double_click

there has been some talk lately about the Illustrator window not being Maximized when opening Ai files via double-clicking...I don't think this happens on macs though, but if it does, hope this fixes it too.

 

http://forums.adobe.com/thread/1053059?tstart=0

 

http://forums.adobe.com/thread/1024321?tstart=0

 

this script attempts to workaround the problem by resizing the window to a "maximum"

 

 

before...

maximized1.png

 

after...

maximized2.png

 

please MAXIMIZE the window manually before running the script.

 

be patient...it will take a couple of seconds to close and re open the application

 

download

http://pastebin.com/AwWBPxRk

 
Replies
  • Currently Being Moderated
    Mar 16, 2013 2:46 AM   in reply to CarlosCanto

    Thanks Carlos, I ran the script with window maximised, and AI restarted, but after that nothing appears to be changed. Opening a file by double-clicking still un-maximises the window.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 16, 2013 4:12 PM   in reply to CarlosCanto

    Ok, that doesn't seem to hellp though. AI closes and restarts OK, but after that nothing seems to be changed, double-clicking to open a new document still un-maximises it. Just to make sure I have done it correctly: I open a document in AI, Maximise the AI window, then run the scrip. A dialog shows saying it will restart AI, I click OK and AI restarts maximised. Then I open a new document by double-clicking it and the AI window un-maximises. By running the script once, is that supposed to do something that makes the AI window open maximised every time after that?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 16, 2013 5:20 PM   in reply to CarlosCanto

    Same specs, but running CS6. That's probably the issue.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 7, 2013 8:33 AM   in reply to CarlosCanto

    Have you had any luck fixing this bug since? I have CS6 and am still having this issue and its VERY aggravating.
    Thanks

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 30, 2013 8:54 AM   in reply to CSC_Ali

    Check out this post.  I was having the same issue and this helped me:

    http://forums.adobe.com/message/5640644#5640644

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points