Skip navigation
LizzieOxbow
Currently Being Moderated

Saving with tif file extensions

Mar 19, 2013 5:00 AM

I work in publishing and convert hundreds of jpgs into tifs each month. In CS6 under save-as when I click on format> tif, I loose the end of my file name. Eg Figure 8.7.jpg goes to Figure 8.tif >loosing the last part of the filename.

When I have a big list of files to run through, I need the saving process to be as quick as possible without having to alter the file name manually. Does anyone know why this is happening, it was fine on CS3!

Thanks

 
Replies
  • Currently Being Moderated
    Mar 19, 2013 11:10 AM   in reply to LizzieOxbow

    Hi there! Because the forum you originally posted in is for beginners trying to learn the basics of Photoshop, I moved your question to the Photoshop General Discussion forum, where you'll get more specialized help.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 19, 2013 11:20 AM   in reply to LizzieOxbow

    Believe a dot is a prohibited character in file name.  System sees anything after dot a an extension.  So 8.7.jpeg would consider the a .7 an extension.  Do you files work like this?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 19, 2013 12:27 PM   in reply to Curt Y

    Any OS that's modern enough to run Photoshop will support multiple periods in a filename.

     

    Some Photoshop programmer does seem to have a problem with handling periods in filenames, though, because other apps' Save As dialogs do not remove substrings from filenames when only the extension should change.

     

    A solution for CS6 and CS5 on OS X is to set Append File Extension to "Always" in Photoshop's Preferences > File Handling. That'll cause the Save As dialog to display the full name and extension, so a selection of another file format will only change the extension.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 21, 2013 6:23 AM   in reply to LizzieOxbow

    LizzieOxbow wrote:

     

    I can't seem to find an Append File extension option (see screenshot)

     

    When you post to the forum by email, image attachments don't make it to the page.

     

    The image below shows the location of Append File Extension in Photoshop's Preferences > File Handling.

     

    Screen shot 2013-03-21 at 13.18.25.png

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 21, 2013 7:28 AM   in reply to LizzieOxbow

    LizzieOxbow wrote:

     

    Is there any way of stopping the system thinking that numbers after my dots are extensions?

     

     

    As I already said, the system understands your file names and it's only Photoshop which is not correctly programmed to handle the names unless the preference to append file extensions is enabled.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 21, 2013 8:07 AM   in reply to LizzieOxbow

    Windows versions of photoshop don't have a preference for Appending File Extensions (adding file extensions)

    because since windows requires file extensions, it's always on in the windows versions of photoshop.

     

     

    All i can say is i stay away from periods in file names other than for the file type extension, because it always seems to cause problems and not just in photoshop.

     

    To be fair though i did try some different jpeg files named in the same scheme as your example in photoshop cs6 on an xp system and didn't seem to have any problems saving the file as named to a tif (periods included).

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 21, 2013 8:29 AM   in reply to LizzieOxbow

    LizzieOxbow wrote:

     

     

    Stupid Windows...  grumble grumble...

     

    For the third time!

     

    It's not stupid Windows. It's some stupid applications like Photoshop.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 25, 2013 9:59 AM   in reply to LizzieOxbow

    Lizzie,

     

    What you encountered is the default setting for Windows. I often forget about that, plus the hiding of System & Hidden files, as about the first thing that I do with a new Windows installation is to set those to SHOW file extensions, and SHOW System & Hidden files/folders. That is just how I always do the OS set-up, and assume that all users are like me. Have poured over myriad problems, and then someone mentions making those changes - giving me a real "DUH!" moment.

     

    Glad you found the cure.

     

    Good luck,

     

    Hunt

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points