Skip navigation
Currently Being Moderated

Data Merge's multiple records preview glitch?

Mar 26, 2013 7:24 AM

My company will be producing election material for the city. It will contain 300 candidates details and images. I've set up a test document with Excel as the data source. And I've reached the stage of producing one record accurately, that contains a candidate image, bio and answers to three static questions.

 

My [CS5.5] indd page will contain between 3-5 candidate profiles per document page (depending on the race). My '3-candidate layout' is set up with the static info on the master page. When selecting the multiple records option in the Data Merge tab, everything looks great - in preview - until I click 'OK'. I then get one record, skewed off to the right of the page, with the other two records off the page completely. Anyone have any ideas what I'm doing wrong?

 
Replies
  • Currently Being Moderated
    Mar 26, 2013 7:28 AM   in reply to sewollefselrahc

    Wahthappens if you resist the urge to preview (it's buggy for multiple records per page) and just run the merge?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 26, 2013 7:58 AM   in reply to sewollefselrahc

    Can you show us some screen shots, please?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 26, 2013 8:34 AM   in reply to sewollefselrahc

    I'd like to see the template, too, if you don't mind.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 26, 2013 8:54 AM   in reply to sewollefselrahc

    Are your placeholders on the master page, or the document page?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 26, 2013 9:14 AM   in reply to sewollefselrahc

    OK.

     

    Let's start by adding an empty no-fill/no-stroke frame around all the sutff that's supposed to be duplicated, and then group tat and all of the objects it contains so it makes a single unit. This may not help, but it definitely won't hurt, and it makes moving things easier if you need to at some point.

     

    You now have a choice. You can leave the group where it is on the master page, and in theory other master items will be ignored and not duplicated during the merge, or you can move it back to the document page. If you do the latter, apply the None master to the document page so there are no master objects showing -- only your group to be duplicated -- and the muliple records should work. Your previous problem using the document page I suspect came from there being other objects that would not fit if they were also duplicated.

     

    Finally, CS6 seems to be a little flaky about margins, so reset the margins in the merge options. Leave the top and left margins as they are, but rest the bottom and right to 0. Try a merge without preview.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 26, 2013 10:01 AM   in reply to sewollefselrahc

    Did your reset the right and bottom margins? hard to tell from the screen shot, but it doesn't look like there's enough space with the current setting for space between rows to get another record on the page (and even if there is, as I mentioned ID can be flaky about it if the last record touches the bottom margin.\

     

    Also check to be sure the ruler zero point is set to the upper left corner of the page....

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 26, 2013 12:45 PM   in reply to sewollefselrahc

    OK, let's try something else. Enlarge the surrounding frame until it hits the left edge of the page (and you want to remove the stroke on it so it doesn't show), then change the left margin to 0 also in the merge options.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points