Skip navigation
Currently Being Moderated

Problem with the scale of pictures when importing.

Mar 26, 2013 8:00 PM

I have taken 250 images which I will edit into a stop motion film. however, I've encountered a few problems.

 

The biggest problem is that when I imported the images into the timeline they were severely magnified and not even centered in the frame. as you can see by this screenshot:

 

 

ffdsdgsfgd.jpg

 

This is a big problem. You'd think I wouldn't have to go through every signle image and scale it down to correctly fit the frame..... right?? It's not even centered which means I have to scale and move and be very accurate and it's going to take so many hours to do! What is wrong here, how do I fix it so that when I import the images, they are the correct scale?

 

problem 2: when i put the images in the timeline they were "backwards". As in, the last image was first in the timeline and the first image was last. It's like the program is TRYING to make my life a living hell.

 
Replies
  • Currently Being Moderated
    Mar 26, 2013 11:02 PM   in reply to DanielFilming

    First of all, be careful how you select the images. Start with the first and end with the last. Or use Automate to sequence.

     

    Also, you probably want to select "Default Scale to Frame Size" in the Preferences on the General tab. That will put the images in the center of the frame, scaled down as required.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2013 6:38 AM   in reply to DanielFilming

    Daniel, so as to solve your issue in principal, you shouldn't import your numbered stills as single images, you should import them as a sequence - tick 'Numbered Stills' checkbox in the Import dialog box, and Bob's your uncle - PrPro will treat all those stills as a single footage.

     

    Go to Edit -> Preferences -> Media -> Indeterminate Media Timebase and set default desired frame rate. So as to change the framerate of already imported image sequence select it in the Project panel, right-click and choose Modify -> Interpret Footage...

     

    Default duration for stills is also set via Preferences: Edit -> Preferences -> General -> Still Image Default Duration. So as to change the duration of all the stills in your timeline select them all, right-click, choose Speed/Duration and set the duration to e.g. 1 frame. Don't forget to tick Ripple Edit, Shifting Trailing Clips checkbox.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2013 6:53 AM   in reply to Fuzzy Barsik

    Oh, good. Fuzzy took the hardest subject leaving me the easier ones.

     

    Just remember that the duration of the stills is initially determined at import. So starting over might be the easiest way after you do what Fuzzy suggested.

     

    The scale of the clips, the size, can be changed by changing one still and copying it. Then you select all the rest and Paste Attributes.

     

    Your real problem, as far as I can tell is that you shoot 3:2 and you want to edit 16:9. That means you only have a few choices.

     

    1. When you scale it down, use the Motion Effect's Scale parameter. That leaves you with choices.

     

         a. Make it look like what you posted, with black bars on the sides. (You can put other things in the black area, by the way.)

         b. Zoom in to where all the frame is filled but you lose some of the top and bottom.

     

    2. Zoom out even farther, put frames around the images, float them around the screen. This makes it look like you did it on purpose.

     

    3. Create a sequence that uses a 3:2 ration and export it that way. If it is for the web, it works great. If for a DVD, not so much.

     

    Of course, you could always choose to shoot 16:9 in the future if your camera is capable of that. (Mine is.)

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2013 11:55 AM   in reply to DanielFilming

    What's inside of this nested 'Sequence 02' at this very frame? Any chance the still is corrupted?

     

    What were your export settings: codec, bitrate etc.? If you exported to e.g. H.264 with default 32/40 Mbps of HDTV preset bitrate, it might be your mediaplayer can't play it back in real time on your machine.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2013 12:28 PM   in reply to DanielFilming

    As I said, chances are your media player can't playback 60 fps of H.264 with quite high bitrate, 32/40 Mbps, in real time. No worries, YouTube will decrease it for you with care.

     

    There's very little chance the pictures are corrupted.

    Just check that frame (Shift+T within your 'Sequence 03' to jump to that very frame within 'Sequence 02'). So as to nail down the issue it's easier (and wiser) to check than keep guessing...

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2013 12:51 PM   in reply to DanielFilming

    First and foremost, why are you working at 23.976 and 59.94 fps if you live in the PAL side of the Earth and your goal is just to upload your video on YouTube? Isn't it better start from proper sequence settings?

     

    Secondly, set Bitrate Encoding to VBR, 2 Pass so as to benefit from better quality out of smaller file size.

     

    Regard to bitrate settings, it depends on how you plan to watch the video. If your media player can't play it back in real time, start to gradually desrease it. Keep in mind, modern AVCHD camcorders shoot with 28 Mpbs, first AVCHD cameras shot with 17 Mbps, H.264 YouTube preset offers 10 Mbps, H.264 Vimeo preset - 8 Mbps.

     

    Rather turn 'Use Maximum Render Quality' off. See e.g. this thread.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2013 2:06 PM   in reply to DanielFilming

    See e.g. this Wikipedia article on frame rate. Use 25 fps for regular sequence.

    I counted at least 3 times where the picture flickered. How do I fix this?

    It's hard to guess without knowing what's in those frames exactly. If everything is OK with all stills, there might be issues with your machine and disk setup in particular. Start a brand new project, import stills as a sequence, create 1080p25 sequence, drop your footage out of the numbered stills into the sequence and check if the issue persists. If yes, upload that project and stills somewhere so that we can check.

     

    By the way, what is your spec: CPU, RAM, GPU, HDD setup? Where do you store your footages: on internal or external drive? Etc.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2013 2:53 PM   in reply to DanielFilming
    ......what? do i set the project at 25 aswell?

    You can't set the project at 25 fps, you set a sequence.

    Now you're telling me to render in 25?

    Not just to render, but being consistent. Regular PAL is 25 fps. Monkeying with fps without understanding what you're doing and why is not wise. If you're not striving for 'film look', you don't need 24 fps. If you do and create your sequence out of stills, be stick to 24 fps throughout your pipeline. Meanwhile, messing up with frame rates hardly causes that flickering.

    ...are you telling me I have to do everything all over again? I don't know what you mean.

    I'm telling you to start a brand new project so as to narrow down what might cause the issue. It's up to you whether to debug it or not. I'm going to sleep

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 28, 2013 1:35 PM   in reply to DanielFilming

    Don't think that your issue is related to PrPro version. I'm still on CS5.5 and never had an issue with image sequences.

     

    Regard to frame rate, as I said, if you deliberately shoot in 24 fps (which is likely 23.976 and, therefore, NTSC), be stick to it and edit and export in 23.976 fps. Since your goal is to upload your video on YouTube and not to deliver it to a Norway or any other European broadcaster, don't bother about PAL too much.

     

    However, as I also mentioned, I don't think that your ongoing issue is caused by mixing frame rates - I have no problems with interpreting numbered stills as 23.976 fps, editing in 23.976 fps and exporting as 24p. Something is wrong with either your footages or your system. You'd rather upload your test project along with some of your problematic stills with which you can reproduce the issue (either old good flickering or the new one with a nice completely black screen) so that we could test them on our machines.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 28, 2013 3:21 PM   in reply to DanielFilming
    I upgraded to cs6 and... There was no dslr preset either...

    You should install all the latest updates to fix the issue.

    I shoot with a canon dslr 60D in 24fps and upload all my stuff in 1080p. Please advice.

    Check your MOV files, they are 23.976 fps.

    And again, upload your test PrPro project file along with some stills somewhere and post the links.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 28, 2013 3:40 PM   in reply to DanielFilming

    Yes, upload your project file and some stills. No needs to upload all your stills, just enough to see the issue. E.g. if you can reproduce the issue with just two or three stills, upload just those two or three ones. The purpose is to make sure that the source files are not corrupted and explore in details what is inside your PrPro project.

     

    Use any file hosting service like FileFactory or Dropbox.

     

    See you tomorrow...

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points