Skip navigation
Currently Being Moderated

The angle parameter of Drop shadow layer style reverts to default when reloaded in new file

Mar 27, 2013 12:53 PM

Tags: #revert #save #layer #default #styles #angle #.psd #.asl

My questions is how to prevent the following from happening. I created a layer style drop shadow in a .psd file with the below parameters.

Screen Shot 2013-03-27 at 12.50.03 PM.png


I saved it as an .asl file that I could use later. When I loaded it into a different .psd file later that day some parameters stayed the same but the angle reverted back to 30 degrees from 120 degress all on its own as shown below.

Screen Shot 2013-03-27 at 12.50.15 PM.png

I just want to know how to keep layer style parameters I saved in an .asl file from reverting back to defaults when loaded in to a new .psd file.


My systems parameters are as follows:

Photoshop CS6 Extend Version 13.0 x64

Mac OSX 10.8.2  with 705.44 GB used out of 749.3 GB available

The only other software I am running is Safari web browser

This is my first time trying to save a layer style and use it in a different .psd file other than the one I created it in.





Nikki Gutierrez

  • Currently Being Moderated
    Mar 27, 2013 1:58 PM   in reply to Tissal

    First thing you need to do is update photoshop using Help>Updates from within photoshop cs6 as many bugs were fixed and your still on 13.0

    (not that what your describing is a bug, but version 13.0 had lots of  glitches that'll drive you crazy when you encounter one)


    Also, the global lighting may be different from one document to the next as you have Use Global Light checked in the drop shadow dialog


    Layer>Layer Style>Global Light>Angle


    See if unchecking Use Global Light makes any difference





    Mark as:
  • Noel Carboni
    23,471 posts
    Dec 23, 2006
    Currently Being Moderated
    Mar 27, 2013 3:26 PM   in reply to R_Kelly

    I've been through changing the angle many times myself, but it's explainable:


    The Global Light value does not get saved with the style.


    R_Kelly has described the right approach.  Save the style with the Global Light checkbox off and you should be good to go.  This thread reminded me to go change a preset style I made that I use a lot to do just that, since when I'm using it I always seem to forget to change it.  Hopefully neither of us will see light falling from the wrong angle again.



    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points