Skip navigation
Currently Being Moderated

cs6 bug

Mar 27, 2013 3:01 PM

Hello!

Win7x32 and PS CS6.

 

To reproduce bug create any new file. Create levels layer with any mask. Activate "mask viewing" by pressing Option/Alt and clicking to mask icon on the levels layer in layers panel. Then try to call menu->select->color range. PS will crash.

 

.

 
Replies
  • Currently Being Moderated
    Mar 27, 2013 1:52 PM   in reply to r-bin

    What version of photoshop cs6 are you using?

     

    Help>About Photoshop

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2013 2:42 PM   in reply to R_Kelly

    Better yet: Help -> System Info.

     

    Have you installed all the Photoshop updates?  You should be on 13.0.1 or 13.1.2.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2013 2:50 PM   in reply to r-bin

    Yes, provokes crash in 13.0.1 on OS X 10.6.8.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2013 3:12 PM   in reply to conroy

    On MacOS you should be on 13.0.4 or 13.1.2.   You need to install the updates to pick up bug fixes.

     

    I cannot reproduce this problem in 13.0.4 or 13.1.2.

    If you have a Macintosh crash log, I need to know the email address it was submitted with in the Adobe Crash Reporter so I can search for it in our database.

     

     

    But I can reproduce this in 13.0.1 on Windows.

    And cannot reproduce it in our current codebase (possibly fixed, possibly random, I'll keep testing).

     
    |
    Mark as:
  • Noel Carboni
    23,526 posts
    Dec 23, 2006
    Currently Being Moderated
    Mar 27, 2013 3:14 PM   in reply to Chris Cox

    No crash here on 13.1.2 on PC.

     

    It came up with something unexpected in the dialog, though.  Might be a wild pointer.

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2013 5:51 PM   in reply to r-bin

    No crash here on windows 7 x64 photoshop cs6 32 or 64 bit 13.01.1 so far, but a couple times on the 64 bit version it acted as though a crash was coming (the select menu froze for a second)

     

    Maybe i'm doing something wrong.

     
    |
    Mark as:
  • Noel Carboni
    23,526 posts
    Dec 23, 2006
    Currently Being Moderated
    Mar 27, 2013 5:52 PM   in reply to Chris Cox

    Does it make sense for the preview in the dialog to look like this, when everything's all white?

     

    OddSelectionInColorRangeDialog.png

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2013 6:23 PM   in reply to Noel Carboni

    Makes a nice, if not strange mask though

     

     

     

    Untitled-2.png

     

    Message was edited by: R_Kelly

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 28, 2013 4:44 AM   in reply to Chris Cox

    Chris Cox wrote:

     

    On MacOS you should be on 13.0.4 or 13.1.2.   You need to install the updates to pick up bug fixes.

     

    I cannot reproduce this problem in 13.0.4 or 13.1.2.

    If you have a Macintosh crash log, I need to know the email address it was submitted with in the Adobe Crash Reporter so I can search for it in our database.

     

     

    I've tried it again (still 13.0.1 on OS X), in order to send a crash report this time... but no crash now.

     

    Tried 16-bit mode and 8-bit mode, several times, several relaunches, docs with just Background and Levels, docs with numerous layers... no crash.

     
    |
    Mark as:
  • Noel Carboni
    23,526 posts
    Dec 23, 2006
    Currently Being Moderated
    Mar 28, 2013 6:17 AM   in reply to conroy

    Sounds like a bad pointer that usually points to somewhere benign.

     

    I should think the appearance of that strange and wonderful stuff in the preview pane of the dialog should be enough to help find the problem.  Unless there are multiple problems, that is. 

     

    -Noel

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)